Project

General

Profile

Bug #746

Create Pop-Up Login Overlay

Added by Matt Gold about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-05-07
Due date:
% Done:

0%

Estimated time:

Description

Right now, when one visits the Commons and clicks "Login," one is taken to a completely different login page whose only purpose is to log in. I'd love to see the act of clicking "Login" pop-up a little window so that one could enter info without leaving the page. Even if the page had to be reload on login, that would cut a page load out of the process.

mockup.jpg (90.2 KB) mockup.jpg Raymond Hoh, 2011-05-13 04:11 AM
mockup_trans.jpg (67.4 KB) mockup_trans.jpg Raymond Hoh, 2011-05-13 03:38 PM
mockup_trans_80.jpg (71.6 KB) mockup_trans_80.jpg Raymond Hoh, 2011-05-14 01:40 AM

History

#1 Updated by Raymond Hoh about 11 years ago

Here's something I coded quite fast.

Still need to add the javascript, but is this what you had in mind, Matt?

#2 Updated by Matt Gold about 11 years ago

Yes, that's exactly what I had in mind, Ray -- thanks! The only change I'd make is to the color -- instead of orange, I'd use a semi-transparent black, like the dropdown menus you see on our nav bar when you mouseover "About" or when you look at the image slide on the homepage. Thanks so much for your work on this!

#3 Updated by Raymond Hoh about 11 years ago

How's this?

#4 Updated by Matt Gold about 11 years ago

Better! I think that a little bit darker would be good, so that a bit less of the background shows through. Thank you!

#5 Updated by Raymond Hoh about 11 years ago

I originally used the transparent black from the slider, which was 70% black.

The new background in the attached screenshot uses 80% black. Take a look and let me know if it's dark enough!

#6 Updated by Matt Gold about 11 years ago

Great! Thanks so much, Ray!

#7 Updated by Matt Gold about 11 years ago

One other thing -- should/could it include a "Forgot your password?" link? My worry is that if we change the login link to just this pop-up, there will be no way for people to reset their passwords if they need to.

#8 Updated by Raymond Hoh about 11 years ago

I'll include a "Forgot your password" link next to the "Remember me" checkbox.

Don't worry about the login link! I never actually change the link; I use a little javascript to check if someone clicks on the login link and when the link is clicked the popup login form appears.

So if someone does have an unsuccessful login or if that someone attempts to reset their password, wp-login.php will still be used.

#9 Updated by Matt Gold about 11 years ago

Sounds great to me! Thanks, Ray. Boone, what do you think.

#10 Updated by Boone Gorges about 11 years ago

This looks good to me.

#11 Updated by Raymond Hoh about 11 years ago

Add login form to adminbar:
https://github.com/castiron/cac/commit/78c99ea5fd90c845cbd805061bbf2d6ae5a133b4

Boone, I've added the javascript inline in wp_footer to save a server request. If you're not a fan of this, let me know and I'll add it to an external JS file.

The login form is basically a duplicate of the BP sidebar login form; I wish this login form was a template tag!

#12 Updated by Raymond Hoh about 11 years ago

  • Status changed from Assigned to Resolved

#13 Updated by Boone Gorges about 11 years ago

Mighty purty.

Inline JS is fine. We're making so many HTTP requests on the front page already, it's probably good not to add anymore.

Also available in: Atom PDF