Project

General

Profile

Bug #783

Broken Avatar Images

Added by Matt Gold over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-06-02
Due date:
% Done:

0%

Estimated time:

Description

In looking over the list of our newest members, I notice that many of them have broken avatar images. My guess is that this is a structural issue with the site rather than user error. What are your thoughts?

gravatar.JPG (74.4 KB) gravatar.JPG Matt Gold, 2011-06-02 04:11 PM
Screen_shot_2011-06-02_at_8.57.53_PM.png (53.6 KB) Screen_shot_2011-06-02_at_8.57.53_PM.png Matt Gold, 2011-06-02 08:58 PM

History

#1 Updated by local admin over 10 years ago

Any one in particular you could point to? I'd like to double-check it isn't a permission, again!

#2 Updated by Matt Gold over 10 years ago

Hi Andre,

Please visit the member page (http://commons.gc.cuny.edu/members/) and filter by Newest. You'll see a bunch. Here are a few in particular:

http://commons.gc.cuny.edu/members/mightyeducator/

http://commons.gc.cuny.edu/members/mfabricant/

http://commons.gc.cuny.edu/members/gfmiller13/

http://commons.gc.cuny.edu/members/cviteritti/

Thanks for your help with this.

#3 Updated by Boone Gorges over 10 years ago

Maybe they just didn't upload avatars?

#4 Updated by Matt Gold over 10 years ago

Boone Gorges wrote:

Maybe they just didn't upload avatars?

In which case they should have the default avatar, not a broken image link. . . .

#5 Updated by Boone Gorges over 10 years ago

They all show the default avatar for me. Try a different browser, or clearing your cache.

#6 Updated by Raymond Hoh over 10 years ago

Works for me as well. I see the default blue Gravatar.

What happens when you navigate directly to the Gravatar image?
http://www.gravatar.com/avatar/d7f5f5db67b36fc1f45e0a72ac8678e2?s=50

#7 Updated by Matt Gold over 10 years ago

No dice. In both Chrome and IE, I can't see the default avatar, either on the Commons or through a direct link to the image. Attached is a screenshot of what I see when I go to the direct link in Chrome.

I'm at work; could my network somehow be blocking gravatar? I do see my own gravatar avatar on the Commons.

And have you both refreshed your browsers/caches?

#8 Updated by Matt Gold over 10 years ago

So, I can see the default avatars at home, which makes me think it must have something to do with City Tech's connection to gravtar.

If that's so, two questions:

Why can I see other gravatars (including my own) even after I have emptied the cache, but not the default gravatar?

André, can you see the default gravtar from the GC network? It should look like the attached screenshot.

#9 Updated by local admin over 10 years ago

I can confirm that the default avatars appear correctly both at home and at GC.

Try right-clicking the broken links from citytech and picling view image. This way we'll see the image path in isolation, hopefully making it easier to troubleshoot.

Do the images appear broken from any machine at citytech?

#10 Updated by Matt Gold over 10 years ago

André Pitanga wrote:

I can confirm that the default avatars appear correctly both at home and at GC.

Try right-clicking the broken links from citytech and picling view image. This way we'll see the image path in isolation, hopefully making it easier to troubleshoot.

Do the images appear broken from any machine at citytech?

Thanks, André. A sample image path is above - http://www.gravatar.com/avatar/d7f5f5db67b36fc1f45e0a72ac8678e2?s=50

I will definitely check to see whether it is accessible from other computers at City Tech -- I'll try to get that on Monday.

#11 Updated by Boone Gorges over 10 years ago

  • Target version changed from 1.2.3 to 1.2.4

#12 Updated by Matt Gold over 10 years ago

It appears that City Tech is blocking the entire domain of gravatar.com. I have submitted a ticket to CIS; I'll let you know what I hear. But at least we know the cause now, and that it is indeed local to this campus network (though it might be an issue on other CUNY networks, as well).

#13 Updated by Matt Gold over 10 years ago

  • Status changed from Assigned to Resolved

My CIS department informed me that City Tech's new web network security devise caught gravatar.com in its net by mistake. The site has been released and is now whitelisted here.

We should still be alive to similar issues that could crop up at other campuses, but I'll mark this particular instance of the issue as resolved.

Also available in: Atom PDF