Project

General

Profile

Bug #8025

HTML markup in group forum notification

Added by Matt Gold over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2017-04-25
Due date:
% Done:

0%

Estimated time:

Description

A member created a new forum post by cutting and pasting text from her Outlook mail client.

when I received the email notification and viewed it through my web-based gmail account, I saw HTML markup

I asked the user to send me a screenshot of the notification she received; it does not show HTML markup.

Do you know how to account for the differences? Screenshots attached. And here is a link to the post itself: https://commons.gc.cuny.edu/groups/cuny-technology-group/forum/topic/reminder-meeting-fri-apr-28-3-5-pm-envisioning-new-open-access-journal-mode-5/

(I should note, too, that it was posted to multiple fora, and so may involve Dan's code)

Screen Shot 2017-04-25 at 10.54.08 AM.png (152 KB) Screen Shot 2017-04-25 at 10.54.08 AM.png Matt Gold, 2017-04-25 11:32 AM
email-outlook.png (108 KB) email-outlook.png Matt Gold, 2017-04-25 11:32 AM

History

#1 Updated by Raymond Hoh over 3 years ago

  • Subject changed from HTML markup in RBE notification to HTML markup in group forum notification
  • Category name changed from Reply By Email to Group Forums
  • Assignee changed from Raymond Hoh to Daniel Jones
  • Target version set to 1.10.18

It looks like it is a problem with the Multiple Forum Post plugin because the HTML markup works in one of the groups:
https://commons.gc.cuny.edu/groups/lacuny-scholarly-communications-round-table/forum/topic/reminder-meeting-fri-apr-28-3-5-pm-envisioning-new-open-access-journal-mode/

However, the markup is sanitized for the rest of the groups.

Dan, can I ask you to take a first look at this?

#2 Updated by Boone Gorges over 3 years ago

  • Target version changed from 1.10.18 to 1.10.19

#3 Updated by Boone Gorges over 3 years ago

  • Target version changed from 1.10.19 to 1.11.1

#4 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.1 to 1.11.2

#5 Updated by Daniel Jones about 3 years ago

Hey all - happy to work on this. Sorry about the delay. What is the expected/desired behavior for this? Should I never sanitize HTML, or just for certain users?

#6 Updated by Raymond Hoh about 3 years ago

Hi Dan,

The expected behavior is that HTML should be allowed in the forum post content.

This looks to be the same issue as:
https://github.com/cuny-academic-commons/bp-multiple-forum-post/issues/4#issuecomment-269796742

It looks like a pull request was made in the bp-multiple-forum-post repo, which should fix the issue:
https://github.com/cuny-academic-commons/bp-multiple-forum-post/pull/8

#7 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.2 to 1.11.3

#8 Updated by Daniel Jones about 3 years ago

Oh I see! Sorry I missed that thread when it was live. I've accepted the pull request.

#9 Updated by Raymond Hoh about 3 years ago

Thanks Dan! Can you merge the fix into the 1.11.x branch on the CAC repo?

I think once that is done, we can mark this as resolved.

#11 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.3 to 1.11.4

#12 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.4 to 1.11.5

#13 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.5 to 1.11.6

#14 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.6 to 1.11.7

#15 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.7 to 1.11.8

#16 Updated by Boone Gorges about 3 years ago

  • Target version changed from 1.11.8 to 1.11.9

#17 Updated by Boone Gorges almost 3 years ago

  • Target version changed from 1.11.9 to 1.11.10

#18 Updated by Boone Gorges almost 3 years ago

  • Target version changed from 1.11.10 to 1.11.11

#19 Updated by Raymond Hoh almost 3 years ago

  • Status changed from Assigned to Resolved

I think we can close this one out since the initial change was added to 1.11.3 and we haven't had any other follow-up reports.

I can't seem to change the target version to a prior version, so I left it at 1.11.11 for now. Feel free to change it to 1.11.3 if you can.

Marking as resolved.

Also available in: Atom PDF