Project

General

Profile

Bug #8150

PressForward pages not loading from followed streams & bookmarklet

Added by Paul Hebert almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Server
Target version:
Start date:
2017-05-15
Due date:
% Done:

0%

Estimated time:

Description

Today and last week I had some trouble with the Pressforward plugin. Today it occurs to me the problem may be related.

Last week when I used the bookmarklet the pop-up window refused to load. It would pop-up blank and the activity would stop (it didn't appear to be loading or hung-up). This happened again this morning.

This morning I also couldn't load a document from the stream view in the plugin. I opened an article from my stream, the pop-up window appeared and the loading text remained.

I'm not sure if this is an issue with my machine (I've used the same one both times I had the problem). But it's never happened before. I was also using Chrome both times. I was not using a VPN any of the times it happened, but that shouldn't affect it, I wouldn't think.

History

#1 Updated by Boone Gorges almost 2 years ago

  • Status changed from New to Reporter Feedback

It sounds like there may be a JavaScript conflict. You may be able to verify by opening your browser's JS console and watching for errors.

Could you please share the URL of an affected page, with specific steps to reproduce?

#2 Updated by Paul Hebert almost 2 years ago

I went to smfellows.commons.gc.cuny.edu and went to the All Content tab of PressForward. I clicked on the title of the first article and I got caught in a loop with "Attempting to load page" always showing in the pop-up window.

Console reads an unrelated jetpack syntax error (There are two main errors.

The first occurs on many pages and I don't think is related. It's a syntax error seemingly from jetpack.

Then this error starts and repeats. I can send a screenshot if it helps.

Object {pf_feed_id: 574, pf_feed_title: "PressForward", pf_last_key: 0, pf_feeds_iteration: "0", pf_total_feeds: 1…}
pf-heartbeat.js:37 574
pf-heartbeat.js:38 PressForward
pf-heartbeat.js:39 0
pf-heartbeat.js:40 0
pf-heartbeat.js:41 1
pf-heartbeat.js:57 100
pf-heartbeat.js:10 hb_send
pf-heartbeat.js:16 hb_tick

#3 Updated by Boone Gorges almost 2 years ago

Thanks for the details, Paul.

PressForward's HTTP requests were failing because of a set_time_limit() call that the server to fail. This is the second instance of this we've seen in the last week (#8131). I'll escalate to our IT department to get some help.

For the time being, I've disabled the problematic calls in PressForward, and pages appear to be loading properly again.

#4 Updated by Boone Gorges almost 2 years ago

  • Category name set to Server
  • Status changed from Reporter Feedback to Resolved
  • Target version set to Not tracked

Our IT contact was able to diagnose the underlying server issue, and it should be resolved in a less hacky way than my previous hotfix. Thanks again for the report, and please let us know if problems recur.

Also available in: Atom PDF