Project

General

Profile

Actions

Bug #8161

closed

Contact form info sent to Commons email

Added by Matt Gold over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
-
Target version:
-
Start date:
2017-05-17
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone,

FYI -- I received an email from a contact form on Luke's site. I think we set up contact forms to work in a custom way due to spam issues, so I'm not sure whether this is expected behavior or not. I will forward the email.

Actions #1

Updated by Boone Gorges over 5 years ago

  • Status changed from Assigned to Reporter Feedback

It looks like your email address is listed as the admin for this site. See https://vp.commons.gc.cuny.edu/wp-admin/options-general.php. This probably means you created it.

Swap it out with the intended address, and run another test. I'm pretty sure it'll work once the setting is updated.

Actions #2

Updated by Matt Gold over 5 years ago

Okay. It was the address rather than mine. I kind of doubt Luke set it up that way, though? Didn't we at one point -- in response to a request from IT -- set up some kind of override for forms on the Commons?

Luke, if you can let us know whether you entered Commons address into the form, that would be helpful.

Actions #3

Updated by Boone Gorges over 5 years ago

The header of the email that you forward to me included the following:

To: mattgold@gmail.com

Are you sure it was sent to ?

This contact form is explicitly set up to send emails to your Gmail address: https://vp.commons.gc.cuny.edu/wp-admin/admin.php?page=wpcf7&post=72&action=edit

We do some modification of Reply-To and other headers in outgoing emails, but we don't change recipients, as far as I can tell.

Actions #4

Updated by Luke Waltzer over 5 years ago

I'm guessing that CF7 defaults the site's creator into the to field. Matt, you created VP for us to bypass the minimum character requirement on site domains.

I think Elizabeth implemented the form but never verified where emails go.

Changing to Elizabeth's email, and recommending that we add a captcha to that form when we do some work on it this summer.

Actions #5

Updated by Boone Gorges over 5 years ago

  • Status changed from Reporter Feedback to Rejected

Sounds like this is a configuration issue, so I'm going to close the ticket. Thanks all.

Actions

Also available in: Atom PDF