Project

General

Profile

Bug #8386

Post by email did not include attachment

Added by Matt Gold about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Reply By Email
Target version:
Start date:
2017-07-01
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray--

I sent an email post to the CUNY DHI group. The post went through, but the attachment did not. Are attachments (PDF, in this case) supposed to be posted or are they routinely ignored?

Orignal message attached and here is the post -- https://commons.gc.cuny.edu/groups/digital-humanities-initiative/forum/topic/job-brooklyn-waterfront-research-center-project-coordinator/

original_msg (12).txt (175 KB) original_msg (12).txt Matt Gold, 2017-07-01 12:21 PM
original_msg (12).txt (175 KB) original_msg (12).txt Matt Gold, 2017-07-01 12:21 PM
Small document.docx (22.6 KB) Small document.docx Stephen Real, 2017-10-17 01:02 PM
email generated by post.png (113 KB) email generated by post.png Stephen Real, 2017-10-17 01:02 PM
RBE message with attachment.png (119 KB) RBE message with attachment.png Stephen Real, 2017-10-17 01:05 PM
gmail-web.png (8.03 KB) gmail-web.png Raymond Hoh, 2017-10-17 01:21 PM
Outlook RBE.png (74.7 KB) Outlook RBE.png Stephen Real, 2017-10-18 08:54 AM

History

#1 Updated by Raymond Hoh about 2 years ago

Hi Matt,

Attachments via RBE are currently not supported.

I can work on this for the next milestone if this is deemed important.

#2 Updated by Matt Gold about 2 years ago

Hi Ray,

I do think it would be a cool feature to add. Let's add it to the next milestone if you feel like it is doable.

#3 Updated by Boone Gorges about 2 years ago

  • Target version set to Future release

Ray - please drop into a milestone once you've done some initial work on feasibility. Thank you!

#4 Updated by Raymond Hoh about 2 years ago

  • Target version changed from Future release to 1.12

This is going to require a bit of work.

Moving to 1.12.

#5 Updated by Boone Gorges almost 2 years ago

  • Target version changed from 1.12 to 1.13

Hi Ray - I'm assuming that this won't happen for 1.12, but please feel free to move back if I'm wrong.

#6 Updated by Raymond Hoh almost 2 years ago

  • Target version changed from 1.13 to 1.12

I'm getting very close for this one. I hope to have this done by Friday.

If I can't get it done by then, will bump to 1.13.

#7 Updated by Raymond Hoh almost 2 years ago

  • Status changed from Assigned to Testing Required

Okay, I've added support to add attachments to group forum items when replying by email.

Related commits:
- https://github.com/cuny-academic-commons/cac/commit/ad3e1b7856c0d5fd6562074c25ded2feb9e20cd2
- https://github.com/cuny-academic-commons/cac/commit/1d41144b2b0a7ea4a8d22293fe6bfe1480e6df9a

It's a little late here, so I'll configure the development server tomorrow afternoon EDT. I'll update this thread with more info so we can get people to test this feature later next week.

#8 Updated by Matt Gold almost 2 years ago

Great -- thank you, Ray

#9 Updated by Raymond Hoh almost 2 years ago

This feature is ready to test on the development server.

To test:
1. Post a reply to a group forum thread to trigger an email notification.
2. Reply to that email from your email client and add an attachment.
3. If all goes well, you should see the attachments in the group forum thread as well as in group emails to anyone subscribed to the group.

I've tested with various image files and a PDF and this appears to be working.

Some caveats:
- We abide by the filesize restriction settings of the GD bbPress Attachments plugin. On the dev server, the max filesize is 3MB.
- We abide by the maximum number of attachments you can upload setting from GD bbPress Attachments. On the dev server, this is 4.
- You should be able to upload any file that you can upload into the WordPress Media library.
- Currently, no feedback email is sent back to the author if the attachment filesize is too big. This should probably be added, but I haven't done so yet.

#10 Updated by Stephen Real almost 2 years ago

My test with a small file did not work.
This is the link to the forum I tried to post to--
https://commons.gc.cuny.edu/groups/test-group-1761529915/forum/topic/testing-thread-for-rbe-attachments/

The post succeeded, but the attachment is missing.
I am including the small MS Word file I attached and screenshots of the RBE email that I sent plus the emai generated by the post.

#11 Updated by Raymond Hoh almost 2 years ago

Thanks for testing, Steve.

I tested with the same .docx file and it works for me. However, I used the Thunderbird email client for attaching. It looks like you are using GMail web. I'll do some further testing on GMail web to see if I can duplicate the problem.

#12 Updated by Raymond Hoh almost 2 years ago

I just tested attaching the .docx file in GMail web and I was able to see the attachment.

Steve, can I ask how you attached the file?

#13 Updated by Stephen Real almost 2 years ago

I used my Airmail email client. I will try with other email clients to see if I get different results.

#14 Updated by Stephen Real almost 2 years ago

At this moment, none of my RBE's from Outlook are going through--even those with no attachment.

#15 Updated by Stephen Real almost 2 years ago

OK. From Outlook, I am able to successfully send attachments RBE. However, the post is kind of funky including other (extraneous, imo) info from the message. See the screenshot. The same info appears on RBE posts from Outlook even when there is no attachment.

#16 Updated by Raymond Hoh almost 2 years ago

Hi Steve,

Glad to hear that the attachment works.

About the extraneous info, this is expected behavior and isn't due to the new attachment code. The extraneous info is due to the text just before the "--- Reply ABOVE THIS LINE to add a comment ---" line when you make a reply. This is created by certain email clients.

I've made some attempts at stripping this text in the past, but it's hard to accommodate for all email clients. In this case, the text block beginning with "From" and ending with the email's subject line is hard to do a match for.

#17 Updated by Stephen Real almost 2 years ago

I am getting very inconsistent results testing this. More details later.

#18 Updated by Stephen Real almost 2 years ago

I have gotten this to work with several clients, but it consistently fails when using Airmail desktop client with Exchange served email messages. The text of the reply posts successfully to the forum, but the attachment is lost. The Airmail client does work with Gmail served messages.

#19 Updated by Boone Gorges almost 2 years ago

  • Status changed from Testing Required to Resolved

Also available in: Atom PDF