Project

General

Profile

Bug #9570

Guest authors in Co-Authors Plus plug-in not working

Added by Gina Cherry over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2018-04-10
Due date:
% Done:

0%

Estimated time:

Description

The Co-Authors Plus plug-in allows you to create profiles for guest authors who do not necessarily have accounts on WordPress. I have used it successfully in the past on a site I created at Hunter, but found that it no longer works when I tried to incorporate in my BMCC site (http://bmcccetls.commons.gc.cuny.edu/). It allows me to create a guest author and to assign the guest as an author on a blog post, but does not display the guest author on the blog post page. We are about to launch a new blog with many guest authors, and this feature was critical to our design. Any insight or ideas for workarounds would be most appreciated.

Screenshot_2018-04-10_21-26-14.png (102 KB) Screenshot_2018-04-10_21-26-14.png 'Blog' listing Boone Gorges, 2018-04-10 10:26 PM
Screenshot_2018-04-10_21-10-59.png (178 KB) Screenshot_2018-04-10_21-10-59.png Single post page Boone Gorges, 2018-04-10 10:26 PM

Related issues

Related to CUNY Academic Commons - Bug #11488: Co-authors plus plug-inResolved2019-05-23

History

#1 Updated by Matt Gold over 3 years ago

  • Category name set to WordPress Plugins
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges over 3 years ago

Sorry to hear you're having trouble.

It's my understanding that Co-Authors Plus does not, by default, modify the appearance of your site. Your theme must be manually modified to support it. See https://vip.wordpress.com/documentation/incorporate-co-authors-plus-template-tags-into-your-theme/. In the past, it's possible that the plugin worked in a different way, or it's possible that your theme was built in such a way as to declare support for the plugin.

Co-Authors Plus does ship with some bare-bones theme support out of the box; this support is disabled by default, but I can enable it with a single line of code. At a glance, it appears that this may work for your site. But before moving forward, I will need a better sense from you of exactly where you expect co-authors bylines to appear. Where I'm seeing them is (a) just below post titles on the Blogs page, and (b) just below post titles on single-post pages. See screenshots. Is this it, or are there more places where I should check?

#3 Updated by Gina Cherry over 3 years ago

Thanks for the quick reply! It's possible that the plug-in has changed, because I'm pretty sure I used it out of the box on the Hunter site, and I'm using the same theme on my new site. We're still developing the final layout for our blog page and single-post pages, but for now, I think that the two places that you indicate are correct. The post in your second screen shot is the one I was having trouble with (the first post was written by someone with a WordPress account). I changed the author on the post to Adele Kudish, but it still displays as CETLS.

#4 Updated by Boone Gorges over 3 years ago

Thanks for the clarification, Gina.

I've just written a small plugin and activated it on your site. It's called 'Enable Co-Authors Filters'. Could you please have a look to see if it's solving your problem? If so, I'll add it to the codebase so that others using Co-Authors Plus can turn it on in the same way.

#5 Updated by Gina Cherry over 3 years ago

Thanks, Boone. It is for the most part. I get a "page not found" when I click on Adele's name. Could that be because the post has not been published yet? Also, I see now that the author is also listed at the bottom of the single post page. Sorry that I missed that before.

I also tested the co-authors functionality by temporarily adding myself as an author, and found that our two names were repeated twice: https://screencast.com/t/KoMspjiwgIjo

#6 Updated by Boone Gorges over 3 years ago

Thanks for the additional details.

Could that be because the post has not been published yet?

Yes, that sounds likely.

I also tested the co-authors functionality by temporarily adding myself as an author, and found that our two names were repeated twice

I see. It looks like this technique is not going to work, then.

At this point, the way forward is to create a custom child theme for the CETLS site. That child theme will have to override the relevant templates from the parent Canvas theme, in order to replace Canvas's default author functions with those from Co-Authors Plus (in accordance with https://vip.wordpress.com/documentation/incorporate-co-authors-plus-template-tags-into-your-theme/). See https://dev.commons.gc.cuny.edu/hosting-partner-handbook/ for a bit more detail on setting up a child theme.

Does your shop have the resources to create such a child theme, and maintain it as necessary once you're hosted on the Commons? As a rule, the CAC team doesn't offer the creation/maintenance of a child theme as a service, but given the nature of CETLS and its relationship with the Commons, we may be able to make an exception if you don't have the ability to do it in-house.

#7 Updated by Gina Cherry over 3 years ago

We don't have the resources to create a child theme at this time, but I think we would have the resources to maintain one. Owen Roberts, a faculty member from our Media Arts and Technology web site, has been helping me with the site. He has not yet had time to begin developing a child theme, but would be able to work with one that was set up for us. Is there a way to loop him in on this conversation?

Thank you again for your help with this. We really appreciate our relationship with the Commons!

#8 Updated by Boone Gorges over 3 years ago

  • Target version set to 1.12.13

This sounds good, Gina. We've got a release scheduled for April 24. I will write the child theme by then, and include it in the release for your use. I'll also share some information about what's in the theme, and some brief thoughts on what it means to maintain it over time (ensuring compatibility with new versions of the parent theme, new versions of WordPress, and so forth). I should be in touch, via this ticket, sometime next week.

#9 Updated by Boone Gorges over 3 years ago

Hi Gina -

I've got a first pass ready at implementing the child theme for the CETLS site. Here's the GitHub repo I've created: https://github.com/cuny-academic-commons/bmcc-cetls-theme Unfortunately, Canvas is a pretty bonkers theme, and Co-Authors itself is fairly bonkers, so that the mods necessary are not 100% easy to understand. Once your team is up and running with the maintenance of the theme, I can hand over the keys, and explain what's happening in functions.php.

If you've got the ability, I'd suggest installing it locally to ensure that it accomplishes what you need it to do. If you can't do that, I'll include it in the next release and you can test it on the Commons. Please let me know if there are sites other than the bmcccetls site where it should be enabled.

#10 Updated by Boone Gorges over 3 years ago

  • Status changed from Reporter Feedback to Resolved

In https://github.com/cuny-academic-commons/cac/commit/9bbcf6b2f136334d8ba6e17ee50f145003143300 I added the theme to the Commons. I've enabled it on the bmcccetls and bmcccetlsdev sites. I'm tentatively marking this item as resolved. Please let me know (here or in another ticket) if what you're seeing doesn't look right. And please get in touch when your team has had a chance to get up to speed on maintaining the theme over the longer run.

#11 Updated by Gina Cherry over 3 years ago

Thanks Boone. Unfortunately, the author that i added through Co-authors Plus is no longer being displayed, so it looks like something went wrong along the way.

Going forward, if Canvas is contributing to issues with the site, we're certainly open to using a different theme. I originally selected that theme for the Hunter site based on a recommendation from someone on the Commons team and continued to use it when I moved to BMCC. I like that it's easy for the end user to modify the look and feel. If there are other themes that do this well, please let us know.

#12 Updated by Boone Gorges over 3 years ago

Sorry to hear it's not working. If you can please give me some details about the nature of the issue - specific URLs, specific things you expect to see but are not seeing - I can have a look.

#13 Updated by Gina Cherry over 3 years ago

I'm looking at the same blog post by Adele Kudish that we were looking at before. When you first tested the new code, Adele's name was displayed correctly (though I noted that there was an error when I clicked on her name). Now the blog post displays CETLS as the author even though Adele was selected through Co-Authors Plus, just like it did before you tested the new code.

http://cetls.bmcc.cuny.edu/2018/04/27/follow-the-student-leader/

#14 Updated by Boone Gorges over 3 years ago

Thanks, Gina. The problem is that you have not activated the child theme that I created for you. It's at Dashboard > Appearance > Themes; search for 'CETLS' and you'll see it.

I switched the site temporarily to this theme, and it does appear to fix the Co-Authors Plus issues, though it also appears that certain Canvas settings are not maintained through the theme-switch - specifically, the blue BMCC bar near the top disappeared. It's likely that this is just a small theme setting that you'll need to reproduce after the switch, but I'm unsure where that setting lives, so I've switched back to Canvas. I'd recommend activating the BMCC CETLS theme on bmcccetlsdev and figuring out the necessary changes you'll need to reproduce on the production site before switching the theme on the main CETLS site.

Note that there appears to be a bug on the Commons right now that is making it impossible to reactivate the main Canvas theme after you've switched away from it. I had to do some manual intervention on the server to switch cetls.bmcc.cuny.edu back to Canvas. So please don't switch to BMCC CETLS theme until you've verified on the bmcccetlsdev that it is, indeed, working the way that you want.

#15 Updated by Gina Cherry over 3 years ago

Thanks, and sorry for the misunderstanding. When you said you had enabled the theme, I thought you meant that you had activated it, but now I realize that you meant that it was now available to activate. We will do the testing you suggested and let you know if we encounter any other issues. Hopefully it will be simple to make the BMCC bar reappear.

#16 Updated by Owen Roberts over 3 years ago

It looks like the custom CSS from the CETLS main site just needed to be copied over to the dev site, maybe installing the child theme cleaned out the custom CSS, though I wasn't able to recreate this so I'm not sure. There are also a couple of Mixed Content errors in Chrome that appear in the CETLS dev site that are not present in the main site, including the white BMCC logo, which is being served from the main site in both cases, although it is appearing on the dev site now.

Boone, could you send me a copy of the child theme to work with?

Thanks

#17 Updated by Boone Gorges over 3 years ago

Hi Gina - The child theme is at https://github.com/cuny-academic-commons/bmcc-cetls-theme. You can get a git clone, or download the zip for editing using the green 'Clone or download' button.

#18 Updated by Boone Gorges over 2 years ago

  • Related to Bug #11488: Co-authors plus plug-in added

Also available in: Atom PDF