Project

General

Profile

Feature #9719

BPGES async sending

Added by Boone Gorges over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2018-05-07
Due date:
% Done:

0%

Estimated time:

Description

I'd like to use the Commons as a testing ground for the latest changes in BuddyPress Group Email Subscription. It's likely that this is something we can do between releases. I'll put this ticket in the 1.13.2 milestone, but will probably do some of the work in the week before that release, so we can isolate any potential issues.

Ray, I know that we need a bump to RBE to make this work. Can you let me know whether it's feasible to do it sometime next week - say, around May 14 or 15 - and whether there's a specific changeset I should get, or if the master is ok. Thanks!

History

#1 Updated by Raymond Hoh over 3 years ago

RBE should be ready for BPGES now.

I've added compatibility for BPGES 3.9.0 to 1.13.x branch in the following commit:
https://github.com/cuny-academic-commons/cac/commit/319e16f80d7f0ea03425087481e9bd1d2ba09a79

And I've also updated the ACTION_REQUIRED list.

#2 Updated by Boone Gorges over 3 years ago

  • Status changed from Assigned to Staged for Production Release

Thanks, Ray!

I've bumped BPGES in the repo: https://github.com/cuny-academic-commons/cac/commit/6398c7a68b70f92c5c739a2446b40a35a8b0bd47

I'd feel more comfortable if I had the ability to bring the site down for a few minutes during the migration routine, so I'll hold off on pushing this until the release on the 22nd.

I'm marking this 'staged' as a reminder of the work I've got to do on release, which I've also marked here https://github.com/cuny-academic-commons/cac/wiki/Release-ACTION_REQUIRED-list. I'll follow up on this thread after I've done the migration and some initial tests.

#3 Updated by Boone Gorges over 3 years ago

  • Status changed from Staged for Production Release to Resolved

The migration in place and I've confirmed most basic pieces of functionality.

The subscription migration routine didn't seem to run completely when run from wp-cli. When launched from the Dashboard, it completed as expected (after about 3 minutes of background running). Just over 16000 subscriptions were moved over; we have about 17000 confirmed group memberships on the Commons, so this passes the sniff test (it's possible in GES to end up with no subscription in a group).

Immediate emails are working as expected, as are RBE responses to those emails. Digest queuing is working as well. We'll see tonight if those emails go out as expected. I've made myself a note to check the logs tomorrow.

Logging for outgoing emails is at wp-content/blogs.dir/1/files/bpges-debug.log.

Marking resolved. If there are continuing issues, I'll put them in a new ticket against another milestone.

#4 Updated by Boone Gorges over 3 years ago

  • Status changed from Resolved to Assigned
  • Target version changed from 1.13.2 to 1.13.3

Bumping to 1.13.3 so I can keep an ongoing record of troubleshooting.

Digests didn't go out properly. After debugging, appears to be related to https://github.com/boonebgorges/buddypress-group-email-subscription/issues/145. I've put a fix in place and manually triggered yesterday's digests. I'll check again tomorrow to see how things have gone.

#5 Updated by Boone Gorges over 3 years ago

  • Status changed from Assigned to Resolved

I've been monitoring over the last week and things have been going well.

- The logs show that digests have been going out as expected.
- Anecdotally, group forum posting seems to be meaningfully faster. I assume this is especially true in groups where there are large numbers of 'all email' subscriptions. For example, a recent (RBE) post in the cunydhi group was sent to over 350 users, which took three different batches, but since they were asynchronous, it wouldn't have slowed posting at all.

I'm tentatively closing this item as fixed. I'll continue to keep an eye out for potential issues.

#6 Updated by Matt Gold over 3 years ago

Great news! thanks for your continued work on this.

Also available in: Atom PDF