Project

General

Profile

Bug #9828

redirecting problem

Added by Marilyn Weber over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Domain Mapping
Target version:
Start date:
2018-05-24
Due date:
% Done:

0%

Estimated time:

Description

Sujatha Fernandes reports:
"I have a website hosted on the CUNY Commons. It is usually accessed via the domain name www.sujathafernandes.com. However, for some reason it is not working. I checked with the company who hosts the domain name and that is fine so it looks like the problem may be on your end."

I see the problem. This error message came up: "The page isn’t redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete. This problem can sometimes be caused by disabling or refusing to accept cookies."

My home computer is a Frankenstein's monster that is over a decade old, so it shows me its thinking. It goes back and forth from "Waiting for www.sujathafernandes.com" to "Waiting for sujathafernandes.commons.gc.cuny.edu" then resolves to that error.


Related issues

Related to CUNY Academic Commons - Bug #9735: Logged-in subdomain view of mapped sites can have SSL errors on assetsResolved2018-05-08

History

#1 Updated by Boone Gorges over 3 years ago

  • Assignee set to Raymond Hoh
  • Priority name changed from Normal to High

Thanks for passing this along, Marilyn.

Ray, could you please take a look? I have a hunch this has to do with disabling the "primary" mode in domain mapping.

#2 Updated by Raymond Hoh over 3 years ago

  • Category name set to Domain Mapping
  • Target version set to 1.13.3

The problem is we have two mapped domains for the same blog ID -- one with the www prefix and one without -- and the code I wrote to redirect subdomains to mapped domains seems to conflict with that.

I'm looking into this. Boone's hunch seems correct.

For now, the sujathafernandes.com domain (without the www) still works.

#3 Updated by Raymond Hoh over 3 years ago

  • Status changed from New to Resolved

Fixed in https://github.com/cuny-academic-commons/cac/commit/32c9814e42b45161c6d99324086641faa8c1672b

The problem was due to the object caching layer I added to the Domain Mapping plugin in #9735. Previously, the code only cached one mapped domain to a blog ID. However, as this ticket has pointed out, a single site can be mapped to multiple domains.

To ensure that the cache is dropped, I've also changed the cache group name.

This has been deployed as a hotfix on production. Tell Sujatha that the www.sujathafernandes.com domain should resolve again.

#4 Updated by Raymond Hoh over 3 years ago

  • Related to Bug #9735: Logged-in subdomain view of mapped sites can have SSL errors on assets added

Also available in: Atom PDF