Project

General

Profile

Bug #9894

Super Admin can't add user to site

Added by Matt Gold almost 4 years ago. Updated over 3 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Onboarding
Target version:
-
Start date:
2018-06-06
Due date:
% Done:

0%

Estimated time:

Description

Marilyn asked me to add her to this site -- https://sujathafernandes.commons.gc.cuny.edu/ (with the admin's permission). I can see the dashboard because I am a super admin. but clicking "add user" triggers the new invitation system, and I apparently can only invite users to sites on which I am a member.

Can you perhaps introduce some logic to the invitation system so that super-admins can add users to sites, whether or not the super-admins are members of those sites?

And if you do that but don't apply as a hotfix, can you please add Marilyn as an admin of that site?

History

#1 Updated by Boone Gorges almost 4 years ago

  • Status changed from Assigned to Reporter Feedback

The functionality is already there. Just visit https://sujathafernandes.commons.gc.cuny.edu/wp-admin/user-new.php directly (not by clicking Users > Add New).

#2 Updated by Matt Gold almost 4 years ago

  • Status changed from Reporter Feedback to Rejected

Aha -- okay, that worked. thanks for the heads-up and the quick response

#3 Updated by Matt Gold almost 4 years ago

Also -- Marilyn. I added you

#4 Updated by Marilyn Weber almost 4 years ago

Thanks, Matt and Boone. This may also explain why Sujatha couldn't do it.

#5 Updated by Boone Gorges almost 4 years ago

Marilyn Weber wrote:

Thanks, Matt and Boone. This may also explain why Sujatha couldn't do it.

Yes. By design, all site invitations triggered by non-super-admins go through the Onboarding modal.

#6 Updated by Matt Gold almost 4 years ago

but that wouldn't explain why Sujatha couldn't do it, would it? She is not a super-admin and but she is a member of the site (an admin)

#7 Updated by Boone Gorges almost 4 years ago

Matt Gold wrote:

but that wouldn't explain why Sujatha couldn't do it, would it? She is not a super-admin and but she is a member of the site (an admin)

It explains why Sujatha couldn't visit user-new.php. But it's not the case that Sujatha couldn't have sent an invitation herself. She could have used the modal.

#8 Updated by Marilyn Weber over 3 years ago

Sujatha wrote yestderday:

As of today I don't seem to be able to log in to my account anymore to make changes to my site. When I try to log in I get this message:

"You don't have permission to access /wp-login.php on this server."

#9 Updated by Boone Gorges over 3 years ago

Hi Marilyn - This sounds like a separate issue. Could you please get some more information from Sujatha? Exactly what URL did she first visit, what did she click to get to the login page, etc.

#10 Updated by Marilyn Weber over 3 years ago

She's fine now. I recommended that she try using https://sujathafernandes.commons.gc.cuny.edu/. She was going to the .com

#11 Updated by Marilyn Weber over 3 years ago

She writes "I'm having another problem now. Everytime I type the below commons address into my browser, it immediately reverts to sujathafernandes.com and I am therefore unable to log in and make changes to my page."

#12 Updated by Boone Gorges over 3 years ago

Marilyn - The redirect to the mapped domain is by design, and occurs for all logged out users.

However, this should not cause a problem with logging in. The user should be able to either (a) click Log In on the toolbar when viewing sujathafernandes.com, from which point she'll be led to the main Commons login page to authenticate, and then should be automatically redirected back to the wp-admin page of sujathafernandes.commons; or (b) go to the main Commons site, log in there directly, and then go to https://sujathafernandes.commons.gc.cuny.edu/wp-admin, either by entering it into the location bar of the browser, or by navigating through the My Sites list in the toolbar.

Also available in: Atom PDF