Project

General

Profile

Bug #10560

PressForward Feed Reader hung up on TLC feed; won't retrieve other feed items

Added by Lisa Rhody 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2018-10-18
Due date:
% Done:

0%

Estimated time:

Description

The PF Feed reader on the pftest.commons.gc.cuny.edu site seems to be hanging up on the TLC site and won't move on to retrieve items from feeds that have been added to the list of "subscribed feeds." From the user perspective, when I go to Dashboard -> PressForward -> Tools, and select the Retrieval Status tab, the status seems to hang at the TLC RSS feed item 3 out of 4. I've added other feeds, deleted feeds, and tried to interrupt the process, but nothing seems to have worked. Screenshot attached.


Related issues

Related to CUNY Academic Commons - Bug #10564: PHP 7.2 Incompatibility ProblemsResolved2018-10-19

History

#1 Updated by Lisa Rhody 7 months ago

Was finally able to interrupt the feed retrieval process and start over, but it ended up hanging on another feed.

#2 Updated by Boone Gorges 7 months ago

  • Status changed from New to In Progress

Thanks for the report and the screenshots, Lisa. It's hard to pin down what might be happening asynchronously, so I've enabled PressForward's debug log tools. This will allow us to gather some information over the next day or two, which should help collect info about what's happening. I'll check back tomorrow to see if there's more info available.

#3 Updated by Boone Gorges 7 months ago

For my own notes: wp-content/blogs.dir/3479/files/pressforward.log

#4 Updated by Raymond Hoh 7 months ago

I came across a fatal error while debugging some PHP 7.2 stuff on Friday, but forgot to mention it.

I opened an issue on the PF Github repo here. Perhaps it's related to this problem?

#5 Updated by Lisa Rhody 7 months ago

Thanks to you both, Ray and Boone, for following up! Let me know if I can help.

#6 Updated by Boone Gorges 7 months ago

  • Target version set to 1.13.13

Thanks, Ray. It looks very likely that the fatal error is related. I'll take a bit of time to dig into PF and maybe open a PR that, at the very least, makes the import process more resilient in case of failure.

#7 Updated by Boone Gorges 6 months ago

  • Related to Bug #10564: PHP 7.2 Incompatibility Problems added

#8 Updated by Boone Gorges 6 months ago

I was seeing lots of instances of this fatal in the error logs, so I've applied the fix from the PressForward repo as a hotfix in production https://github.com/cuny-academic-commons/cac/commit/e084a794a764b141988f4243e1a456b14e18f3d4 Let's see if this helps clear things up.

#9 Updated by Lisa Rhody 6 months ago

Thanks, Boone and Ray. We have a couple projects waiting on the fix, and I'm glad to hear that there's a short term solution! I think Aram updated the issue #1022 on GitHub here: https://github.com/PressForward/pressforward/issues/1022#issuecomment-437371935. I'm not able to test the changes without updating the PF plugin on the commons. Do you all have a work around for that? thanks!

#10 Updated by Boone Gorges 6 months ago

Hi Lisa - I've already ported the change to the Commons (that's what I meant in comment 8 above). Please let us know if this is enough to clear it up.

#11 Updated by Lisa Rhody 6 months ago

Oh! sorry... my misunderstanding!

#12 Updated by Boone Gorges 6 months ago

  • Target version changed from 1.13.13 to 1.14.1

Lisa, could you please check to see whether importing is working properly, and report back when you get a chance?

#13 Updated by Paul Hebert 6 months ago

It looks like it's working for me.

It's still incredibly slow, though.

#14 Updated by Boone Gorges 6 months ago

  • Status changed from In Progress to Resolved

Thanks, Paul. Not sure what I can do about the slowness of fetching. Latency is likely due to the slowness of fetching feeds, which is why it happens in the background - so you shouldn't notice the slowness in your everyday work.

As the immediate problem here appears to be solved, I'm going to close the ticket. Please report back if there are more reproducible problems.

#15 Updated by Lisa Rhody 6 months ago

Things seem to have cleared up for me as well. Apologies for the delay, and thanks, Paul for checking your feeds. Many thanks! Best, L

Also available in: Atom PDF