Project

General

Profile

Bug #10789

Forum Posts not generating email notifications

Added by Matt Gold 9 months ago. Updated 8 months ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2018-12-05
Due date:
% Done:

0%

Estimated time:

Description

I noticed that a recent post I made to a forum did not generate a notification -- https://commons.gc.cuny.edu/groups/ma-in-digital-humanities-cuny-graduate-center/forum/topic/ma-ms-digital-project-and-training-grants-2019-apps-due-1-25-18/

When I asked someone about this, he said that he had posted something recently that also did not generate an email notification -- https://commons.gc.cuny.edu/groups/ma-in-digital-humanities-cuny-graduate-center/forum/topic/end-of-semester-holiday-party/

My email subscription shows as All Email

Can you please look into this?

History

#1 Updated by Matt Gold 9 months ago

BTW, I think that posts sent by email are creating email notifications, but posts created through the web interface are not

#2 Updated by Boone Gorges 9 months ago

Posts are generally going out. It's not as systematic as RBE-yes, otherwise no. I'm looking into it.

#3 Updated by Matt Gold 9 months ago

thanks, Boone

#4 Updated by Matt Gold 9 months ago

I am starting to receive email notifications of the posts, so whatever you are doing is working. thanks!

#5 Updated by Boone Gorges 9 months ago

  • Status changed from Assigned to Resolved
  • Target version set to Not tracked

This was my fault. Yesterday morning, I added a clause to some debugging tools so that I would no longer be notified about long-running BPGES send-queue processes. However, there was a mistake in the logic that I introduced, which caused queued items not to be processed.

I've fixed the bug, and triggered a script that is crawling through the unsent notices, and sending them out. I've staggered it a bit, so as not to overwhelm the system (especially the outgoing email system). It should be done within the next hour or so.

#6 Updated by Matt Gold 9 months ago

cool -- thanks, Boone. I'm relieved that they were queued and still available to be sent out!

#7 Updated by Matt Gold 9 months ago

Hi Boone -- FYI -- this post did not generate an email notification during the fix -- https://commons.gc.cuny.edu/groups/ma-in-digital-humanities-cuny-graduate-center/forum/topic/end-of-semester-holiday-party/

#8 Updated by Boone Gorges 9 months ago

This appears to be due to a different cause, since the debug thing described above didn't take place until yesterday morning.

I have opened a ticket on the buddypress-group-email-subscription repo to track this and related issues https://github.com/boonebgorges/buddypress-group-email-subscription/issues/163

I also manually triggered notifications for that specific activity item.

#9 Updated by Matt Gold 9 months ago

Thank you!

#10 Updated by Anthony Wheeler 8 months ago

Hey Boone, I just informed Matt of this: I went to circulate our department holiday party invite to other groups on the CAC and found that email notification was interrupted again. I shared it via web interface on one of the groups and checked the boxes so that it would be shared with multiple groups. It's posted, just no notifications were sent out. I appreciate all of your help working through this issue. Here are the links to the posts:

https://commons.gc.cuny.edu/groups/itp-core-1-fall-2018-520829517/forum/topic/end-of-semester-holiday-party-2/

https://commons.gc.cuny.edu/groups/dhum-70000-introduction-to-digital-humanities/forum/topic/end-of-semester-holiday-party-3/

https://commons.gc.cuny.edu/groups/doing-things-with-novels/forum/topic/end-of-semester-holiday-party-4/

#11 Updated by Boone Gorges 8 months ago

  • Status changed from Resolved to New
  • Assignee changed from Raymond Hoh to Boone Gorges
  • Target version changed from Not tracked to 1.14.2

Anthony, thanks for sharing.

I don't understand why this has started happening all of a sudden, and I'm unsure how to debug root causes. As a stopgap, I've set up a health-check utility of the sort I suggested yesterday. https://github.com/cuny-academic-commons/cac/commit/611388827f93968ae428b258fc7919714bc5144c Every five minutes, the system will check to see if any 'immediate' emails are pending, and if so, it will trigger them to be sent. I'll monitor this in the upcoming days to see what happens.

#12 Updated by Boone Gorges 8 months ago

  • Status changed from New to Resolved

The "health check" tool that I created seems to have worked to send out the pending notifications. And there doesn't appear to have been any cases since then of activity notifications not being properly sent. So I'm going to close this one out as resolved.

#13 Updated by Matt Gold 8 months ago

great -- thanks, Boone

Also available in: Atom PDF