Project

General

Profile

Bug #12351

No email notification for forum post

Added by Matt Gold over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2020-02-01
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray,

I posted something to a CAC forum but did not see an email notification. can you please check to see if there is an unsent queue?

here's a link to the post (I made it through the website interface - https://commons.gc.cuny.edu/groups/cunydhi/forum/topic/nycdh-week-2020-feb-3-7/#post-83447 )


Related issues

Related to CUNY Academic Commons - Bug #10789: Forum Posts not generating email notificationsResolved2018-12-05

Related to CUNY Academic Commons - Bug #12499: no email notificationResolved2020-03-03

History

#1 Updated by Raymond Hoh over 1 year ago

  • Assignee changed from Raymond Hoh to Boone Gorges

Hi Matt, I can confirm that the queue for that forum post was not sent out.

Boone, there is a large number of items in the wp_bpges_queued_items DB table. It goes as far back as November.

I think the time window (date_recorded comparison) for the GES health check script might need to expand from 5 minutes to 30 minutes to ensure that large sendouts are accounted for.

Anyway, I just manually pushed out immediate emails for items sent since 2020-01-31 00:00:00 GMT. Matt, can you confirm that you received the email for your forum post?

Boone, for daily digests, I attempted to use the same logic for immediate emails to force a sendout, but the arguments are different. So my script ended up sending the same daily digest to the same 27 users about 80 times according to the GES logs (massive oops!). I also noticed that the health check only accounts for immediate emails not digests. Is there a way we can write some logic for digests into the health check as well?

#2 Updated by Matt Gold over 1 year ago

Thank you, Ray. Yes, I can confirm I received the email after you triggered this action

#3 Updated by Boone Gorges over 1 year ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.16.5

Thanks for looking into this, Ray.

Increasing the time-until-health-check-begins window seems OK to me. I've done so in https://github.com/cuny-academic-commons/cac/commit/9ff7d591e97a1698d49d438b95b5aa56d0f9381d.

It's also worth noting that the bpges_health_check cron event was not scheduled on the production site, and as such, the health-check code was doing nothing :) I've scheduled it, and will monitor changes.

Health check for digests is also a good idea, but it's not trivial to set up. See https://github.com/boonebgorges/buddypress-group-email-subscription/issues/163. Looking at the database, it looks like stalled digests are a very minor issue - immediates are more the problem. Let's see how the immediate health check works, now that it's actually running, and then evaluate further.

#4 Updated by Raymond Hoh over 1 year ago

  • Related to Bug #10789: Forum Posts not generating email notifications added

#5 Updated by Raymond Hoh over 1 year ago

  • Related to Bug #12499: no email notification added

Also available in: Atom PDF