Project

General

Profile

Actions

Bug #11209

closed

Activity timestamp errors

Added by Matt Gold over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2019-03-11
Due date:
% Done:

0%

Estimated time:

Description

I searched for Colin on the People page and it showed him as having been active 5 months ago. On his profile, I see he was active 3 days ago. I know we dealt previously with errors on the homepage activity timestamps; I'm not sure whether these are related. Screenshots attached


Files


Related issues

Related to CUNY Academic Commons - Feature #10687: Stop mirroring BP last_activity to usermetaResolvedBoone Gorges2018-11-08

Actions
Related to CUNY Academic Commons - Bug #11388: Rewrite member search queriesResolvedRaymond Hoh2019-04-23

Actions
Actions #1

Updated by Matt Gold over 3 years ago

BTW, Colin -- lest you think I was worried about your activity, I was just trying to find your profile page link so that I could update our staff page -- https://commons.gc.cuny.edu/about/project-staff/

Actions #2

Updated by Boone Gorges over 3 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, could you please bring your timestamp expertise to bear?

Actions #3

Updated by Boone Gorges over 3 years ago

  • Target version set to 1.14.10
Actions #4

Updated by Raymond Hoh over 3 years ago

  • Target version changed from 1.14.10 to 1.14.11
Actions #5

Updated by Raymond Hoh over 3 years ago

  • Status changed from Assigned to Staged for Production Release

The issue is we are using the legacy BuddyPress user query on the People page, which looks up the wrong last activity timestamp. The legacy query uses the timestamp from the user meta DB table instead of the activity DB table.

To fix this, we need to patch the legacy user query in BuddyPress. I've done so here - https://github.com/cuny-academic-commons/cac/commit/b6fca8943b14573c40bfcbea9e86c19ae55a34a2.

Boone, I'll open a ticket on BP Trac about this.

Actions #6

Updated by Raymond Hoh over 3 years ago

  • Related to Feature #10687: Stop mirroring BP last_activity to usermeta added
Actions #7

Updated by Raymond Hoh over 3 years ago

This bug popped up because we stopped mirroring last activity to user meta in #10687.

We might need to reinstate the user meta mirroring due to sorting by last active on the People page... the alternative is to rewrite the Members search to stop relying on the legacy user query.

Actions #8

Updated by Boone Gorges over 3 years ago

  • Status changed from Staged for Production Release to Resolved
Actions #9

Updated by Raymond Hoh over 3 years ago

The immediate timestamp display issue is resolved, but the sorting on the People page is incorrect due to stale last activity timestamps in usermeta.

Boone, can you let me know what you think about my last comment?

Actions #10

Updated by Boone Gorges over 3 years ago

Oh, sorry - I missed the question.

I'd say let's rewrite the query. I'll create a new ticket.

Actions #11

Updated by Boone Gorges over 3 years ago

  • Related to Bug #11388: Rewrite member search queries added
Actions

Also available in: Atom PDF