Project

General

Profile

Bug #11482

Page Authors on Sites create with template

Added by Laurie Hurson about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2019-05-21
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

When people select a site template (teaching, portfolio) during the creation process, the authors of the pages and posts on the newly created site are Luke, Paul Hebert, and I because we created the original templates. Is there a way to make the Commons Admin account the default author on the pages and posts of new sites that are created using the template?

Thanks!


Related issues

Related to CUNY Academic Commons - Support #11787: automated comments notifications on ZenDeskReporter Feedback2019-08-24

History

#1 Updated by Boone Gorges about 2 years ago

  • Status changed from New to Reporter Feedback
  • Target version set to 1.15.2

Changing post author on the template will change the name of the author on sites created in the future. I assume this is not something we have to fix retroactively, for already-created sites?

There is no 'Commons Admin' user that I'm aware of. If I'm wrong about this, please give me some information about the user (like a link to the profile). If I'm right, we could either:
a. Create a generic 'Commons Admin' for purposes like this, and ascribe the posts to that new user
b. Ascribe the posts to some other existing user (Matt?)
c. At the time of site creation, switch authorship of the cloned items over to the site creator.

Laurie, could you please chime in with your thoughts?

#2 Updated by Laurie Hurson about 2 years ago

I think it would be too cumbersome to fix the sites already created.

Options A or C would be fine, I think - whatever is easiest to set up.

Ascribing the pages/posts to a user "Commons Admin" or "Commons Template" would hopefully alert people to the fact that these pages were created with the site.

Reassigning the pages and posts to the creator of the site would be fine too. Though this might confuse very new users since they will see that they have created pages but not understand that those pages/posts were pre-populated.

#3 Updated by Matt Gold about 2 years ago

I lean towards solution A, but I guess one question is what people do with the draft content. If they will delete the pages/posts, I think it would be better for it to be authored by a generic commons user. If they will edit the page/post, I think that Option C would be best and better for the long run, as content created by users should be under their own names. Thoughts?

#4 Updated by Boone Gorges about 2 years ago

Thanks, all. I agree with Laurie that A is the best. It's technically easiest, and it makes clear that these are auto-generated posts.

I've created a user 'commonsadmin' and switched post_author for each post/page on the three template sites to this user. See eg https://academic-portfolio-template.commons.gc.cuny.edu/wp-admin/edit.php?post_type=page. If site admins want to change authorship of a post, they can do it themselves.

If others feel strongly that we need to do C instead, it's possible, but it will have to be a code-level change.

#5 Updated by Laurie Hurson about 2 years ago

Thanks Boone. This sounds like a good, quick fix (instead of changing the code).

Are Site creators/admins able to change the author on the pre-populated pages/posts (that will now be attributed to commonsadmin? That way, for example, professors could change the "syllabus" page so that it's authored by them (as Matt suggested).

#6 Updated by Boone Gorges about 2 years ago

Yup, you can do this on a post-by-post basis (look for the 'Author' dropdown on the Block or Classic editor screen) or as a bulk action (on Dashboard > Pages, check multiple boxes, then choose Edit from the Bulk Actions dropdown and change the Author).

#7 Updated by Laurie Hurson about 2 years ago

Okay, thats what i figured. Thanks, Boone

It might be worth adding directions on how to do that so folks can change the author if they want. I will work on adding that to our documentation.

#8 Updated by Matt Gold about 2 years ago

sounds good. thanks, Boone

#9 Updated by Boone Gorges about 2 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version changed from 1.15.2 to Not tracked

#10 Updated by Laurie Hurson almost 2 years ago

Circling back on this...I noticed on sites that use a template the back end author on pre-populated posts has been changed to "Commons Admin" as intended but on the front end it still says the post is by Paul Hebert (ex: https://authornametest.commons.gc.cuny.edu/)

This might be a function of the solution we chose for this issue and maybe the solution doesn't account for the display on the front end? Not sure, but I wanted to bring this up because I think the posts attributed to Paul (or Luke in the portfolio template) might confuse folks.

#11 Updated by Boone Gorges almost 2 years ago

Laurie, can you clarify where you're seeing "Paul Hebert" on the front end? Is it in the Recent Comments widget?

#12 Updated by Boone Gorges almost 2 years ago

  • Related to Support #11787: automated comments notifications on ZenDesk added

#13 Updated by Luke Waltzer over 1 year ago

On new sites launched from a template, default comments are attributed to Paul. Probably accounts for what Laurie notes above. Can we change this attribution to the generic Commons Admin account as well?

#14 Updated by Boone Gorges over 1 year ago

Thanks for the details. I've made the change to the following comment:

https://teaching-template.commons.gc.cuny.edu/wp-admin/#comment-4

The default comments on the other posts are already attributed to fake users, so I think we're good to go here.

Also available in: Atom PDF