Project

General

Profile

Bug #11512

Links not opening in new tab

Added by Gina Cherry over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
-
Start date:
2019-06-03
Due date:
% Done:

0%

Estimated time:

Description

I have set up several of the links on our BMCC Open Pedagogy site to open in new tabs, but they do not. I checked the html and target="_blank" is there, so not why sure this is happening. You can see it here: https://bmccopenpedagogy.commons.gc.cuny.edu/2019/05/31/what-is-open-pedagogy and here: https://bmccopenpedagogy.commons.gc.cuny.edu/2019/05/31/how-might-you-use-open-pedagogy-in-your-course/. Also in the twitter feed on the home page: https://bmccopenpedagogy.commons.gc.cuny.edu/. The rss widget is configured to open links in a new tab.


Related issues

Related to CUNY Academic Commons - Feature #11517: wp-accessibility plugin should not strip 'target="_blank"' by defaultAssigned2019-06-04

Is duplicate of CUNY Academic Commons - Support #11002: open link in a new tab not workingResolved2019-01-24

History

#1 Updated by Boone Gorges over 2 years ago

  • Status changed from New to Duplicate

#2 Updated by Boone Gorges over 2 years ago

  • Is duplicate of Support #11002: open link in a new tab not working added

#3 Updated by Gina Cherry over 2 years ago

Thanks for this information. I changed the plug-in settings and that solved the problem.

I am using the WP Accessibility plugin because it is part of the Teaching template. I was not aware of the kinds of changes it would make to my site. I see from the information in the other bug report that the accessibility issue is that users should be warned if a link will open in a new tab. Since the plugin appears to insert such a warning in the HTML, would it be possible to configure it so that it does not default to removing the target attribute from links? Removing the target attribute is likely to be confusing for other users of the Teaching template.

#4 Updated by Boone Gorges over 2 years ago

  • Related to Feature #11517: wp-accessibility plugin should not strip 'target="_blank"' by default added

#5 Updated by Boone Gorges over 2 years ago

I've opened https://redmine.gc.cuny.edu/issues/11517 to consider the suggestion.

Also available in: Atom PDF