Project

General

Profile

Bug #11836

Invite and "Claim Key" Confusion

Added by Laurie Hurson about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Onboarding
Target version:
Start date:
2019-09-09
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

A professor has reported confusion when students join the Commons. I am not exactly sure whats going on here...it might be that a student receives an email invite to join a site, clicks the link and registers for the Commons, and then goes back to the original email to try and join the course site? When the student checks their Profile>Invites there is an error message about a "claim key".

I'm not sure if this is a bug and/or how I should explain this situation to the professor. Any insight would be appreciated.

Excerpts from emails with the professor and student below:

Professor email: "So this is the 4th student who has contacted me about this exact issue. I think the invite link just no longer works once they've claimed it but they are all thinking there is something wrong or it didn't work, when it did."

Student email:
Good Evening professor,
I had some concerns regarding the CUNY commons website. I created an account however the invite link provided does not work. I can see this class listed under my "Sites" category which makes me wonder if it worked. I was just wondering if you could verify it for me. I attached the message that pops up when i try activating the invite link.

Screenshot from student email attached

claim key issue.png (637 KB) claim key issue.png Laurie Hurson, 2019-09-09 11:12 AM

History

#1 Updated by Boone Gorges about 2 years ago

  • Category name set to Onboarding
  • Target version set to 1.15.9

Thanks for the detailed report, Laurie.

I've just run through some tests with the Claim Key feature and I can confirm that it's generally working for both groups and sites. The fact that the users are, in fact, joined to the sites makes me think that it's working for them too. (If I had more details about the specific claim keys, users, sites, etc, I could verify, but perhaps this is unnecessary.)

The 'No invitation...' error is shown when the system cannot find a pending (ie, non-accepted and non-rejected) invitation corresponding to the claim key. My original thought was that this would only happen when inputting incorrect keys, in which case the 'No invitation...' error is appropriate. However, it'll also be shown if the claim key matches an already accepted invitation. I'm guessing this is what's happening here: the users click through the email the first time, register for the Commons (or accept the invitation directly via Claim Key, depending), and then go back to the email and click Claim again. In this case, 'No invitation...' is not an appropriate response - we should instead be showing a message along the lines of "You've already accepted this invitation". Let me take a look to see how hard this change would be, as maybe I can slip it into today's release.

#2 Updated by Matt Gold about 2 years ago

thanks so much, Boone -- that's a perfect solution

#3 Updated by Boone Gorges about 2 years ago

  • Status changed from New to Resolved

I've made the change. At the time of claim, I'm now saving the "accepter ID". Then, when an invitation is claimed:

- if the user claiming is not the same as the user who has previously claimed the invitation, a generic "That invitation has already been accepted" error is shown.
- if the user is the user who has previously claimed (this should be the vast majority of cases), the success message is shown again. I opted for this because (a) it shows links to associated groups/sites, and (b) it reduces UX overhead for the user - they don't need to know that they've accepted a second time, just that the acceptance was successful.

#4 Updated by Boone Gorges about 2 years ago

Laurie - Note that this change means that users who have already accepted will not have their "accepter ID" recorded, and as such they'll continue to see the generic "That invitation has already been accepted" error. Those users should be told that their acceptance was already successful. Future claimers (after today's release, in the next 30 minutes or so) will see the new messages.

#5 Updated by Laurie Hurson about 2 years ago

This is great, thanks for the quick fix Boone.

Also available in: Atom PDF