Project

General

Profile

Support #11869

Subscribing to a Commons Group Calendar

Added by Kristen Hackett about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Events
Target version:
Start date:
2019-09-17
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray,

I am writing in about the functionality of the Commons group calendar - which is in relation to this ticket: https://redmine.gc.cuny.edu/issues/4524 -- This is part a question about the intended function, and if it is supposed to function as described below, then we have a bug.

From this ticket and conversations with Matt, it seems like the expected functionality of the subscription feature below the calendar on Commons group (here: https://commons.gc.cuny.edu/groups/gcdi/events/) should allow me to download it one time and it should immediately add the existing events to a calendar on my local machine, and it should automatically be updated when future events are added.
Is this correct?

This is not the functionality I am getting. I downloaded the iCalendar file to my mac, added it to the iCal on my computer. Then I went back to the Commons group to create a new 'test' event for Nov 13th to see if it would automatically add it. I created the event 'silently' so it wouldn't notify other users (I say this because maybe this is interupting the intended functionality if as stated above). It does not show up on the calendar on my local machine. I tried again just now by creating a second "test 2" event on Nov 18th (again "silently"). Same outcome (it shows on the Commons group calendar, but not on the calendar on my local machine).

Please advise,
Thanks,
kristen

proposed.png (4.24 KB) proposed.png Raymond Hoh, 2019-09-24 03:52 PM

Related issues

Related to CUNY Academic Commons - Support #11884: Commons Group Calendar Functionality 2Duplicate2019-09-19

Related to CUNY Academic Commons - Bug #11891: Private group calendar iCal URLs should be accessible without logging inResolved2019-09-23

History

#1 Updated by Raymond Hoh about 2 years ago

  • Tracker changed from Bug to Support
  • Category name set to Events
  • Status changed from New to Reporter Feedback
  • Target version set to Not tracked

From this ticket and conversations with Matt, it seems like the expected functionality of the subscription feature below the calendar on Commons group (here: https://commons.gc.cuny.edu/groups/gcdi/events/) should allow me to download it one time and it should immediately add the existing events to a calendar on my local machine, and it should automatically be updated when future events are added.
Is this correct?

Hi Kristen,

This is not correct. If you downloaded the ICS file one-time and imported it, your calendar would only show those static changes and no updates.

Can you try using the iCal URL by right-clicking and copying the URL and then using that URL in your calendar app? I'm not familiar enough with iOS, but maybe this guide will help?
https://www.macrumors.com/how-to/subscribe-to-calendars-on-iphone-ipad/

Here's a guide for Mac OS:
https://support.apple.com/en-ca/guide/calendar/icl1022/mac

#2 Updated by Kristen Hackett about 2 years ago

Ok thanks.

I don't see an option to add a URL for a calendar on the iCal on my laptop, or on the calendar app on my phone so I can't test this, but is the idea that if you use the URL of the commons group event page (i.e. https://commons.gc.cuny.edu/groups/gcdi/events/) then you are subscribed in a way that offers the functionality described above (new events will automatically add to your calendar) or no?

#3 Updated by Raymond Hoh about 2 years ago

but is the idea that if you use the URL of the commons group event page (i.e. https://commons.gc.cuny.edu/groups/gcdi/events/) then you are subscribed in a way that offers the functionality described above (new events will automatically add to your calendar) or no?

No, you wouldn't use the group calendar permalink. You would right-click the link for "Download iCalendar file" in the Subscribe block on the events calendar page and copy that URL:

And use this URL in your calendar app.

The intention is this will auto-update the calendar in your app. There might be bugs and inconsistencies as this hasn't been fully tested in all calendar apps and operating systems.

I'll try my PC's calendar app a little later to see if newly-added events are detected.

#4 Updated by Raymond Hoh about 2 years ago

  • Status changed from Reporter Feedback to Rejected

I can confirm that the external iCal URL subscription feature is working quite well.

I copied the URL as per the instructions above, then I used the Thunderbird email client with the Lightning calendar addon and followed these instructions:
https://support.mozilla.org/en-US/kb/creating-new-calendars#w_icalendar-ics

First, I added an event to a group and synced the calendar in Thunderbird. Thunderbird picked up the event. Next, I edited the details of the event on the Commons and after syncing the calendar in Thunderbird, it was able to detect the change. Lastly, I deleted the event on the Commons and then synced the calendar and Thunderbird also removed the event.

One thing to note is the default synchronization time on Thunderbird is 60 minutes. So if you're testing with Thunderbird, you'll need to manually synchronize the calendars for each change you make. You also won't be able to edit the details of the event from the calendar app because the calendar is read-only.

Going to close this one for now, but if you encounter any bugs with other calendar apps, feel free to reopen.

#5 Updated by Kristen Hackett about 2 years ago

By "synced the calendar" which you say you did three times in your first point - do you mean you re-copied the URL link to your calendar or something else? And if something else, can you clarify please?

The goal functionality we're looking for is that any student of the GC will be able to copy that URL into their calendar app and stay up to date with GCDI's events and workshops. So its ok if the timing is delayed. And all events will be added and edited in the Commons group - no need to be able to edit from the calendar app. But we do want events to be added automatically to the students calendar if they have synced their calendar one time - a 60 min delay is not a big deal, but that it syncs up eventually is the point in question.

I will check again tomorrow, but right I was able to add the events to my google cal, but when i added additonal events to the Commons group cal, it did not show up on my google calendar - as of yet.

#6 Updated by Raymond Hoh about 2 years ago

By "synced the calendar" which you say you did three times in your first point - do you mean you re-copied the URL link to your calendar or something else? And if something else, can you clarify please?

I created the calendar just once in my calendar app. The calendar app will usually take care of synchronization.

I was manually synchronizing the calendar in my calendar app because I had to test each individual change like adding, editing and deleting events on the Commons and I didn't want to wait.

Like I mentioned above, each calendar app might work differently. For my testing with Thunderbird, it appeared to work fine. If you run into any problems with other clients, please let me know.

#7 Updated by Raymond Hoh about 2 years ago

  • Related to Support #11884: Commons Group Calendar Functionality 2 added

#8 Updated by Kristen Hackett about 2 years ago

thank you for clarifying. can we keep this ticket open until monday evening? I am waiting for the sync in google cal and we have fellows testing it on their own apps over the weekend. if its not any trouble on your end that would be good.

#9 Updated by Raymond Hoh about 2 years ago

  • Status changed from Rejected to Reporter Feedback

Yeah sure. Just commenting to reopen the ticket.

#10 Updated by Matt Gold about 2 years ago

Ray or Kristen, might you be wiling to test with GCal? Or I can. I think we should test that calendar for the syching functionality because it's a very popular calendar tool

#11 Updated by Kristen Hackett about 2 years ago

Thanks Ray - and for clarifying.

Matt - by GCal do you mean google calendar? if we're talking about the same thing, then I have/am testing with that one. The events have showed up using the link, I'm not getting the syncing/updates when new events are added to the Commons group calendar. I just published the event for today so I'm going to check in about an hour and will chime in if it is working. If I don't follow up, its because it is not working.

#12 Updated by Raymond Hoh about 2 years ago

Just wanted to note from Google's documentation that synchronization changes can take up to 12 hours to appear:
https://support.google.com/calendar/answer/37100?hl=en&ref_topic=1672445

Note: It might take up to 12 hours for changes to show in your Google Calendar.

#13 Updated by Raymond Hoh almost 2 years ago

  • Related to Bug #11891: Private group calendar iCal URLs should be accessible without logging in added

#14 Updated by Raymond Hoh almost 2 years ago

One bug I discovered is with private group iCalendar URLs.

Currently, when you try to fetch a private group calendar iCal URL like:
https://commons.gc.cuny.edu/groups/PRIVATE-GROUP/events/SOME-LONG-HASH/ical/

On the Commons, it will ask you to login.

This shouldn't happen as calendar apps like Google Calendar will need the iCal URL to be publicly accessible without logging in.

I believe this used to be working, but something might have changed upstream in BuddyPress to break this functionality.

I created a new ticket to track this bug - #11891.

#15 Updated by Matt Gold almost 2 years ago

Kristen Hackett wrote:

Matt - by GCal do you mean google calendar? if we're talking about the same thing, then I have/am testing with that one. The events have showed up using the link, I'm not getting the syncing/updates when new events are added to the Commons group calendar. I just published the event for today so I'm going to check in about an hour and will chime in if it is working. If I don't follow up, its because it is not working.

Yes, exactly -- I meant google calendar. thanks!

#16 Updated by Kristen Hackett almost 2 years ago

Great - thanks for clarifying Matt!

So it does seem to be working for me. I am waiting to see if deleted events also sync.. like Ray mentioned, it does appear there's a 24 hour lag time.

Its not intuitive to copy the link there (it is intuitive to click on the link and download the iCal file) so my other question if if there documentation about how to use this feature on the Commons somewhere? I took a look around (i thought maybe here: https://help.commons.gc.cuny.edu/events-calendar/), and didn't see anything.

Matt, I'm thinking maybe you know, or maybe there is someone else I should ask this question of.. just let me know.

#17 Updated by Matt Gold almost 2 years ago

Hi Kristen -- the best person to ask about documentation is Scott Voth. I've added him to this ticket. Scott, please see above - thanks

#18 Updated by Kristen Hackett almost 2 years ago

Thanks Matt!

Scott- any insight into documentation to use this feature of the groups calendar? If not, we can include some on our calendar page when we add the link. Thanks!

#19 Updated by Raymond Hoh almost 2 years ago

I found a decent documentation link about iCalendar URLs on this site:
https://mcb.berkeley.edu/academic-programs/seminars/ical-feed-instructions

We might want to use that as a guide. Screenshots and steps probably need to be updated though.


I've also mocked up some changes to the Subscribe block.

Previous:

Proposed:

I've changed the "Download iCalendar file" link text to something a little bit more accurate. "Subscribe to calendar" perhaps?

I've also added the following descriptive block:

You can copy and paste the following link into any calendar application that supports the iCalendar format.

Once the Help site is updated, we could also add that link to the Subscribe block as well.

#20 Updated by scott voth almost 2 years ago

Currently the documentation is pretty vague (or non-existent) about subscribing and syncing. It only focuses on the "Download ICal File" for a single event and it looks like the screenshot is slightly out of date. It doesn't mention that you can subscribe to a group's event calendar.

I will update the documentation.

Ray - Are you planning to implement your proposed changes in a maintenance release?

#21 Updated by Raymond Hoh almost 2 years ago

Ray - Are you planning to implement your proposed changes in a maintenance release?

Yes, but I wanted everyone's thoughts before I made them just in case anyone had any better ideas for the iCalendar link text and suggested description block.

#22 Updated by Kristen Hackett almost 2 years ago

This looks good to me! Thank you Ray! And thanks Scott for updating the documentation. When might these changes be implemented? I don't know the release schedule..

#23 Updated by Raymond Hoh almost 2 years ago

I don't know the release schedule

Updates are made every second Tuesday of each month. So the next update is October 8th.

If no one else has any other suggestions, I will make my proposed changes.

#24 Updated by Raymond Hoh almost 2 years ago

  • Subject changed from Commons Group Calendar Functionality to Subscribing to a Commons Group Calendar
  • Status changed from Reporter Feedback to Staged for Production Release
  • Target version changed from Not tracked to 1.15.11

I've added my proposed changes above to the next maintenance release:
https://github.com/cuny-academic-commons/cac/commit/ac3771ae57b772ec669124b0518b9c36dc2949a4

Boone: The change will require the bp-event-organiser submodule to be updated. I've added a note to the ACTION_REQUIRED wiki page.

#25 Updated by Boone Gorges almost 2 years ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF