Project

General

Profile

Support #11907

more publications problems (in profile)

Added by Marilyn Weber about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Public Portfolio
Target version:
Start date:
2019-09-25
Due date:
% Done:

0%

Estimated time:

Description

Jay Paul Gates reports
"I have been unable to get my CUNY Academic Commons profile to accept additional updates—I can’t add publications. However, when I deleted my publications entirely and tried to enter them anew, I lost my publications list entirely. Could you please look at this and tell me if I am doing something wrong? I have entered them, clicked okay within the Publications box and then saved changes."

This is related to https://redmine.gc.cuny.edu/issues/11811, where you asked for more info. Anticipating that you'll need that, I replied to him

The developer asks "Is it possible for the user to provide exact text that he's putting into the Publications field? If it's coming from an external document like Word, it would be helpful to have the original document - [to see] the root issue."

JGates_CV_Master10.docx (61.3 KB) JGates_CV_Master10.docx Marilyn Weber, 2019-09-26 02:10 PM

Related issues

Related to CUNY Academic Commons - Bug #12166: Profile changes not savingAbandoned2019-12-03

Has duplicate CUNY Academic Commons - Support #11811: Content of Publications widget on profile page being erased on saveDuplicate2019-08-30

History

#1 Updated by Boone Gorges about 2 years ago

  • Status changed from New to Reporter Feedback

Thanks. I can have a look once I have the original content.

#2 Updated by Marilyn Weber about 2 years ago

Word doc attached. LMK if you don't get it and I'll email it to you instead. Thanks!

#3 Updated by Boone Gorges about 2 years ago

  • Category name set to Public Portfolio
  • Target version set to 1.15.11

Thanks for this. There were a collection of problems preventing proper saving, and having the source text helped me address them. Please ask the user to try again.

#4 Updated by Boone Gorges about 2 years ago

  • Target version changed from 1.15.11 to 1.15.12

#5 Updated by Boone Gorges about 2 years ago

  • Has duplicate Support #11811: Content of Publications widget on profile page being erased on save added

#6 Updated by Boone Gorges about 2 years ago

  • Target version changed from 1.15.12 to 1.15.13

#7 Updated by Marilyn Weber almost 2 years ago

I never heard back from this person, but now there's another report:

"I wanted to report a potential bug with the profile pages. I used to have a list of publications separated by <p> tags under 'PUBLICATIONS' on my profile (https://commons.gc.cuny.edu/members/jbretmaney/).

Today, I noticed it is all jumbled into one paragraph. When I tried to modify the formatting, no changes are being accepted/saved."

I've asked him to send me the source file.

#8 Updated by Marilyn Weber almost 2 years ago

He writes:

"I wasn’t actually entering any new text into the Publications field. The publications field was previously formatted with <p> tags separating each publication. Then a couple of days ago I noticed it was all jumbled into one paragraph. Since I hadn’t made any edits to my profile in the interim, I thought it must have been a global change on your end.
Now, when I try to restore formatting to the text within the field (de-jumbling the paragraph so to speak), none of the formatting changes will save.
https://commons.gc.cuny.edu/members/jbretmaney/
The same behavior goes if I create a Free Entry box, name it “TEST,” and make the field contents also be “test.” I can save it and it will appear on my profile. But if I go back to edit my profile and then try to turn “test” into a bullet point and save again, the formatting change will not stick.
No one else has reported this?
I wonder if you could reproduce what I describe above with the Free Entry box in your own profile"

#9 Updated by Marilyn Weber almost 2 years ago

He reports:

"FYI, you can see the same thing (jumbled text) happening with the Publications field of Matt Gold’s profile -- https://commons.gc.cuny.edu/members/admin/ -- which makes me think this is a general issue."

#10 Updated by Boone Gorges almost 2 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks for passing this along, Marilyn. The specific issue described by the most recent user was caused by the BP 5.0.0 update during the last release. I've fixed it in https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/06e5a5bc89af1881fd8653358ff69032e5a2a875 and deployed as a hotfix to the production site.

The change required some minor, manual readjustment of the spacing on the reporter's profile. I've made these changes, but the user should of course feel free to adjust as needed.

I'm going to mark this issue as resolved. I believe that the issue with quotes was fixed several releases ago, and I believe that today's fixes address the second issue. For future reports, please open new tickets, as there are often different root causes that need to be handled separately. Thank you!

#11 Updated by Boone Gorges almost 2 years ago

  • Related to Bug #12166: Profile changes not saving added

Also available in: Atom PDF