Project

General

Profile

Support #11811

Content of Publications widget on profile page being erased on save

Added by Marilyn Weber about 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2019-08-30
Due date:
% Done:

0%

Estimated time:

Description

Anne Hays, http://cuny.is/annehays, a librarian at CSI, wrote via ZenDensk:

"Hello, every time I try to add my publications to my profile page, once I hit save the entire text is deleted. It's a weird bug! How do I add publications?"

I told her I couldn't replicate the problem, so she sent me the below and attached:

"Screenshot #1: I add the text

Screenshot #2, I push OK, then I click Save Changes

Screenshot #3, after doing that, it goes to this screen where now my publications are gone altogether"

She also wrote "I'm making a website instead, but thought you should know about the bug on the profiles page."

I vaguely remember someone having a similar problem when they were trying to add a lot of text. Does that ring a bell?

AH3.JPG (71.7 KB) AH3.JPG Marilyn Weber, 2019-08-30 10:25 AM
AH2.JPG (115 KB) AH2.JPG Marilyn Weber, 2019-08-30 10:25 AM
AH1.JPG (113 KB) AH1.JPG Marilyn Weber, 2019-08-30 10:25 AM

Related issues

Related to CUNY Academic Commons - Bug #12166: Profile changes not savingAbandoned2019-12-03

Is duplicate of CUNY Academic Commons - Support #11907: more publications problems (in profile)Resolved2019-09-25

History

#1 Updated by Boone Gorges about 2 years ago

  • Subject changed from publications widget on profile page to Content of Publications widget on profile page being erased on save
  • Status changed from New to Reporter Feedback

The prior ticket for a similar issue with #6101. The issue there was a specific kind of character in the pasted text, which needed to be sanitized. I'm guessing that something similar is happening here since, as you note, Publications saving is working more generally.

Is it possible for Anne to provide exact text that she's putting into the Publications field? If it's coming from an external document like Word, it would be helpful to have the original document - cutting and pasting the content here into Redmine might paper over the root issue.

#2 Updated by Boone Gorges almost 2 years ago

  • Status changed from Reporter Feedback to Duplicate
  • Target version set to Not tracked

I think this is probably a dupe of #11907, and should be fixed by the changes described there. Please reopen if the reporter lets us know that this is not the case.

#3 Updated by Boone Gorges almost 2 years ago

  • Is duplicate of Support #11907: more publications problems (in profile) added

#4 Updated by Boone Gorges almost 2 years ago

  • Related to Bug #12166: Profile changes not saving added

Also available in: Atom PDF