Project

General

Profile

Support #11986

Permitted file types for group vs. site upload

Added by Colin McDonald about 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2019-10-16
Due date:
% Done:

0%

Estimated time:

Description

Hello, I was looking at a separate project for Brooklyn College and noticed that in the Files area of a Group, media file types like .mp4 and .mp3 cannot be uploaded, while they go through just fine when uploading to the Media Library of a Site (provided it's under the 40MB threshold for each individual file). Is that by design? If so, I'm curious about the reasoning.

If it helps, the project I'm working on involves students uploading audio and video recordings from field work, and there was interest in a private area where the class could collect such files. I know that something like Dropbox or Google Drive would be a possible solution, but the Commons offers the ability to link directly to uploaded files in an external service like a podcast feed, which is also of interest.


Related issues

Related to CUNY Academic Commons - Feature #12091: Improved pre-upload file validation for bp-group-documentsNew2019-11-14

History

#1 Updated by Matt Gold about 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges about 2 years ago

  • Target version set to 1.16

The disparity is a historical accident, based on the respective limitations of the software powering the two different upload areas. Let's try to straighten it out.

#3 Updated by Colin McDonald about 2 years ago

Thanks, Boone. When you get a chance to look into it further, if you could post with the timeline/involvement it may take to get it sorted out, I can talk to the professor I mentioned about their uploading project and whether they might need another solution for now.

#4 Updated by Boone Gorges about 2 years ago

  • Status changed from Assigned to Reporter Feedback

Colin, how urgent is this? I can move it back to the 1.15.13 milestone, which is scheduled for Nov 12. The 1.16 release is slated for about four weeks after that. I can move to 1.15.13, but I'm concerned that even this timeline won't be good enough for an instructor who wants to do a project right now. Can you give your sense of this before I juggle milestones?

#5 Updated by Colin McDonald about 2 years ago

Hi Boone, at its most urgent, I believe that this could help one professor with their final projects in December, though I'm working on confirming this. If 1.15.13 on Nov 12 is doable, then we'd be covered just fine for that one case. But it's not essential to move mountains just for that. If we can do it then, great, otherwise feel free to slot it where you think it'd be best. Thanks!

#6 Updated by Boone Gorges about 2 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version changed from 1.16 to 1.15.13

Thanks for the context, Colin. I took the time to look over the history of the issue this morning. I can confirm that the mismatch is a historical accident. The buddypress-group-documents plugin has its own filetype whitelist, independent of WP's. I suppose this is a feature in some contexts, as you might reasonably want to limit the types of files that can be uploaded to groups beyond what's allowed for site admins. For the Commons, I've written a small filter that forces buddypress-group-documents to use WP's whitelist: https://github.com/cuny-academic-commons/cac/commit/a6aa5277da7e1ab5add321b21fe81dd744e10e97 The change will be in the 1.15.13 release.

There's room for UX improvement in buddypress-group-documents with respect to upload limitations. Things like size and file extension should be checked before submitting the file for upload, and there could be better inline documentation explaining the limitations. Let's not lump these improvements in with the current ticket. But I've copied Sonja on this update so that the issue is on her radar, and next time we touch group document uploads (maybe related to #3176?) we might think about this.

#7 Updated by Colin McDonald about 2 years ago

All sounds good to me Boone, on the short-term fix to clear up the historical accident for 1.15.13 and then for keeping bigger improvements in mind for a bigger feature release. Many thanks.

#8 Updated by Sonja Leix about 2 years ago

Boone Gorges wrote:

Thanks for the context, Colin. I took the time to look over the history of the issue this morning. I can confirm that the mismatch is a historical accident. The buddypress-group-documents plugin has its own filetype whitelist, independent of WP's. I suppose this is a feature in some contexts, as you might reasonably want to limit the types of files that can be uploaded to groups beyond what's allowed for site admins. For the Commons, I've written a small filter that forces buddypress-group-documents to use WP's whitelist: https://github.com/cuny-academic-commons/cac/commit/a6aa5277da7e1ab5add321b21fe81dd744e10e97 The change will be in the 1.15.13 release.

There's room for UX improvement in buddypress-group-documents with respect to upload limitations. Things like size and file extension should be checked before submitting the file for upload, and there could be better inline documentation explaining the limitations. Let's not lump these improvements in with the current ticket. But I've copied Sonja on this update so that the issue is on her radar, and next time we touch group document uploads (maybe related to #3176?) we might think about this.

Thanks Boone, maybe we should move this into it's own ticket so we keep track of it?

#9 Updated by Boone Gorges about 2 years ago

  • Related to Feature #12091: Improved pre-upload file validation for bp-group-documents added

#10 Updated by Boone Gorges about 2 years ago

Thanks, Sonja. I've opened #12091 to track this.

Also available in: Atom PDF