Project

General

Profile

Support #12156

My Sites list (Commons Profile or Sites directory) doesn't match toolbar dropdown

Added by Marilyn Weber almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Blogs (BuddyPress)
Target version:
Start date:
2019-12-01
Due date:
% Done:

0%

Estimated time:

Description

Syelle Graves opened a complicated ticked via ZendDesk:

(1) I tried to put in a ticket for what seems like two bugs, but I no longer see a way to log in to Redmine (I did once: https://redmine.gc.cuny.edu/issues?author_id=1457&set_filter=1&status_id=%2A, but I am unable to log in now). Has that changed, or is there still a way for me to put a ticket in directly?

(2) I see what looks like a bug when I hover over my icon > hover over my sites. The list is overlaid with triangle bullets. It has done this consistently for a few months. I tested it on a PC, in Firefox 70.0.1, and in Chrome 78.0.3904.108. A colleague at BMCC found the same issue in his account. See screenshot:

(3) A second issue with my icon > my sites: When I click on My Sites, it shows me 12 sites:
Teleplaza (https://teleplaza.commons.gc.cuny.edu/)
I L E T C (https://iletc.commons.gc.cuny.edu/)

BMCC Open Pedagogy Seminar (https://bmccopenpedagogy.commons.gc.cuny.edu/)

ILLC site design (https://linglangculture.commons.gc.cuny.edu/)

Advanced Research Collaborative Commons (https://arc.commons.gc.cuny.edu/)

Brooklyn College Linguistics Program (https://brooklyncollegelinguistics.commons.gc.cuny.edu/)

Computer-Mediated Communication (https://sociocmc.commons.gc.cuny.edu/)

Syelle Graves (https://syellegraves.commons.gc.cuny.edu/)

Brooklyn College Linguistics Lab (https://brooklyncollegelinglab.commons.gc.cuny.edu/)

Analyzing Discourse Data (https://discourse2018.commons.gc.cuny.edu/)

WAC at Bronx Community College (https://bronxwriting.commons.gc.cuny.edu/)

But when I hover, I see 21 sites, including one I've never heard of and don't seem to belong to, "Free Queer CUNY" https://freequeercuny.commons.gc.cuny.edu/wp-admin/ .

So,
(3a) Should the hover My Sites and the click My Sites match?
(3b) Why is it showing Free Queer CUNY in one of the My Sites list? (I don't see any way to remove myself.)

Apologies if these questions are something simple that I'm missing. Happy to put a ticket in for one or both if I have Redmine access.

Thank you!
Syelle
--
Syelle Graves, PhD

Assistant Director, ILETC

Syelle my sites problem.jpg (175 KB) Syelle my sites problem.jpg Marilyn Weber, 2019-12-01 10:45 AM
Marilyn my sites problem.docx (488 KB) Marilyn my sites problem.docx Marilyn Weber, 2019-12-01 10:48 AM
Syelle free queer quasi-dashboard.PNG (88.3 KB) Syelle free queer quasi-dashboard.PNG Syelle Graves, 2019-12-02 11:40 AM
Syelle - did my sites vanish.PNG (179 KB) Syelle - did my sites vanish.PNG Syelle Graves, 2019-12-02 04:51 PM

Related issues

Related to CUNY Academic Commons - Bug #12158: My Sites toolbar flyout contains caret characters that overlay site titlesResolved2019-12-02

History

#1 Updated by Marilyn Weber almost 2 years ago

Here's my reply:

1) When you try to log into Redmine, what happens? Are you able to try via Forgot password?

2 and 3) I am having the same problems, but I thought it was just me as I am the temporary admin of many sites as I offer help. I will report this to Boone.

#2 Updated by Marilyn Weber almost 2 years ago

So this is not the same as, but is related to https://redmine.gc.cuny.edu/issues/11977

#3 Updated by Boone Gorges almost 2 years ago

  • Related to Bug #12158: My Sites toolbar flyout contains caret characters that overlay site titles added

#4 Updated by Boone Gorges almost 2 years ago

(1) I tried to put in a ticket for what seems like two bugs, but I no longer see a way to log in to Redmine (I did once: https://redmine.gc.cuny.edu/issues?author_id=1457&set_filter=1&status_id=%2A, but I am unable to log in now). Has that changed, or is there still a way for me to put a ticket in directly?

There is a Sign In link at the far upper-right when viewing that URL.

(2) I see what looks like a bug when I hover over my icon > hover over my sites. The list is overlaid with triangle bullets. It has done this consistently for a few months. I tested it on a PC, in Firefox 70.0.1, and in Chrome 78.0.3904.108. A colleague at BMCC found the same issue in his account. See screenshot:

I've opened #12158 to track this. Let's use the current ticket to investigate the remaining issue.

#5 Updated by Marilyn Weber almost 2 years ago

Syelle let me know she's now able to log in.

#6 Updated by Boone Gorges almost 2 years ago

  • Subject changed from MySites problems to My Sites list (Commons Profile or Sites directory) doesn't match toolbar dropdown
  • Category name set to Blogs (BuddyPress)
  • Status changed from New to Reporter Feedback

The freequeercuny.commons problem is related to #12105. At some point in the past, this site had enabled the bbPress "auto role" featured, meaning that every Commons user who visited the site received the bbp_participant role. See also #9211 and https://bbpress.trac.wordpress.org/ticket/2210. After #12105, user should no longer be added in this way. I've just finished running a script that removed this site from the 'My Sites' list of all users who were added to freequeercuny.commons in that way, so Syelle should no longer see it in her list. This should resolve the "unknown site" issue.

As for the "My Sites" discrepancy: https://commons.gc.cuny.edu/members/syellegraves/blogs/ (or commons.gc.cuny.edu/sites > My Sites, which is powered in the same way) only lists items that are tracked by BuddyPress. BuddyPress only tracks public sites. This means that the My Sites list only shows public sites. I feel like this is a problem we've discussed directly before, but I can't find references to it - #8075 and #5691 are peripherally related. (Ray, can you help connect the dots?) The 'My Sites' item in the toolbar works differently. It's built by WP, and fetches all sites, whether they're public or not. This explains the discrepancy between the two lists.

I'm unsure whether we need or want to fix this discrepancy. In theory, it'd be nice if users saw the exact same list of items on the toolbar My Sites as at Commons Profile > My Sites. But the contexts are different: the toolbar is only visible to the logged-in user, so it's natural that it'd include non-public sites. Commons Profile > Sites is public, so it cannot always include non-public sites, and it may be confusing to display different results when viewing your own profile than when viewing someone else's. Sites > My Sites is only visible to the logged-in user, so in this case it's perhaps more confusing to show only public items; but because it's powered by the same back-end as Commons Profile > Sites, it'd take a decent amount of retooling to make it match.

Do others have thoughts about the ideal behavior for the three areas? (toolbar, Sites > My Sites, Commons Profile > Sites)

#7 Updated by Syelle Graves almost 2 years ago

Boone Gorges wrote:

The freequeercuny.commons problem is related to #12105. At some point in the past, this site had enabled the bbPress "auto role" featured, meaning that every Commons user who visited the site received the bbp_participant role. See also #9211 and https://bbpress.trac.wordpress.org/ticket/2210. After #12105, user should no longer be added in this way. I've just finished running a script that removed this site from the 'My Sites' list of all users who were added to freequeercuny.commons in that way, so Syelle should no longer see it in her list. This should resolve the "unknown site" issue.

Thanks, Boone. I do still see it on my list as of now, even after logging out and back in, and refreshing. Perhaps it's just updating in cyberspace, but I thought I'd add a detail to this, because I still see the link in my list: the link from my list takes me to a quasi-dashboard, which does not show any link to the site, or even the site's name. Maybe this is expected behavior though. Screenshot attached.

#8 Updated by Syelle Graves almost 2 years ago

Edit: It seems I may have a new mystery site, and I see more than 21 sites there now: The Center on Philanthropy and Civil Society? Link: https://cpcs.commons.gc.cuny.edu/wp-admin/

#9 Updated by Boone Gorges almost 2 years ago

Thanks, Boone. I do still see it on my list as of now, even after logging out and back in, and refreshing.

Looks like the way I removed users was not aggressive enough. A second script is currently running that should clean this up. Please check again momentarily.

Edit: It seems I may have a new mystery site, and I see more than 21 sites there now: The Center on Philanthropy and Civil Society? Link: https://cpcs.commons.gc.cuny.edu/wp-admin/

Can't say anything about the "more than 21 sites" issue without more details, but the cpcs issue is exactly the same: you were once auto-added because of bbPress. I have removed you from this site, so you should no longer see it in your list.

I am unsure about running a similar script that removes all auto-role users from cpcs or any other site. It's labor-intensive for me to do so, and is prone to errors: presumably some people who were added to a site by bbPress went on to create content, and would not want to be removed, or perhaps they expect the link in My Sites for other reasons. Given that individuals can leave sites #9651, my inclination is to do nothing and let people handle it themselves if it bothers them to see it in their list.

#10 Updated by Syelle Graves almost 2 years ago

Thanks again, Boone--below are points of clarification and updates:

Boone Gorges wrote:

(1) I tried to put in a ticket for what seems like two bugs, but I no longer see a way to log in to Redmine (I did once: https://redmine.gc.cuny.edu/issues?author_id=1457&set_filter=1&status_id=%2A, but I am unable to log in now). Has that changed, or is there still a way for me to put a ticket in directly?

There is a Sign In link at the far upper-right when viewing that URL.

Just to explain: At the time I opened the ticket, Redmine did not accept my login credentials, and did not recognize my email address (or any of my CUNY email addresses) when I tried the "forgot password" link. Today, it accepted my old login credentials. Don't know why it's fixed/moot now, that I'm in, but just wanted to clarify that.

Boone Gorges wrote:

Thanks, Boone. I do still see it on my list as of now, even after logging out and back in, and refreshing.

Looks like the way I removed users was not aggressive enough. A second script is currently running that should clean this up. Please check again momentarily.

Edit: It seems I may have a new mystery site, and I see more than 21 sites there now: The Center on Philanthropy and Civil Society? Link: https://cpcs.commons.gc.cuny.edu/wp-admin/

Can't say anything about the "more than 21 sites" issue without more details,

Sorry. I was referencing my original ticket; I wrote "But when I hover, I see 21 sites, including one I've never heard of and don't seem to belong to." This contrasted to the 12 in profile > my sites. The significance was that it seemed that even more mystery sites had been added to the list, after Marilyn and I created the ticket.

Update: I am now successfully removed from both Queer Cuny and Philanthropy/cpcs, thank you, though other sites that I visited recently but do not belong to are in that list. If it's helpful, I can send you a list of those? It might not seem like the biggest deal, but it's a bit confusing because I have some BMCC faculty who add me to their sites as admin, and others whom I thought added me, because their sites appeared in My Sites dropdown. Now, now I realize I was ghost-added, because I looked at their site, I suppose; I don't have any access to the real dashboard/it only links me to that quasi dashboard I mentioned (screenshot). I know a few faculty here at BMCC were using the bbpress plugin (#9211), so though I can't see these dashboards, I bet that's causing me to be added to those.

I am unsure about running a similar script that removes all auto-role users from cpcs or any other site. It's labor-intensive for me to do so, and is prone to errors: presumably some people who were added to a site by bbPress went on to create content, and would not want to be removed, or perhaps they expect the link in My Sites for other reasons. Given that individuals can leave sites #9651, my inclination is to do nothing and let people handle it themselves if it bothers them to see it in their list.

Well, the whole issue was that I was not able to leave those sites (Free Queer CUNY, Center of Philanthropy/cpcs) myself, which is why I put in the ticket (in my original correspondence, shown above, I wrote "I don't see any way to remove myself.") I tried to find the Free Queer group, for example, to attempt to leave the site that way, but there was no group by that name when I searched. I'd be happy to handle it myself, if there is a way that I'm missing?

Finally, as of a few minutes ago, Profile > My sites shows all 12 of my sites are gone--not sure if this is temporary, or some kind of glitch? Eeps! Attached screenshot.

Thanks for you help! Sorry if any of this is redundant/not helpful/has too much boldface. Just wanted to be thorough.

~Syelle

#11 Updated by Matt Gold almost 2 years ago

Boone Gorges wrote:

I'm unsure whether we need or want to fix this discrepancy. In theory, it'd be nice if users saw the exact same list of items on the toolbar My Sites as at Commons Profile > My Sites. But the contexts are different: the toolbar is only visible to the logged-in user, so it's natural that it'd include non-public sites. Commons Profile > Sites is public, so it cannot always include non-public sites, and it may be confusing to display different results when viewing your own profile than when viewing someone else's. Sites > My Sites is only visible to the logged-in user, so in this case it's perhaps more confusing to show only public items; but because it's powered by the same back-end as Commons Profile > Sites, it'd take a decent amount of retooling to make it match.

Do others have thoughts about the ideal behavior for the three areas? (toolbar, Sites > My Sites, Commons Profile > Sites)

Hi Boone,

My thought is that the logged-in user should always see both public and private sites in all three of these areas, and that non-logged in users or people looking at the profiles of others should only see public sites. That, at least, is what makes the most sense to me.

#12 Updated by Boone Gorges almost 2 years ago

Responding to Matt:

My thought is that the logged-in user should always see both public and private sites in all three of these areas, and that non-logged in users or people looking at the profiles of others should only see public sites. That, at least, is what makes the most sense to me.

On further review, my analysis above was incorrect. Non-public sites are tracked by BuddyPress, and are visible to logged-in users when viewing the My Sites sections of the Commons. So no further action is needed here.

Responding to Syelle:

Well, the whole issue was that I was not able to leave those sites (Free Queer CUNY, Center of Philanthropy/cpcs) myself, which is why I put in the ticket (in my original correspondence, shown above, I wrote "I don't see any way to remove myself.") I tried to find the Free Queer group, for example, to attempt to leave the site that way, but there was no group by that name when I searched. I'd be happy to handle it myself, if there is a way that I'm missing?

At https://commons.gc.cuny.edu/members/syellegraves/sites you should see a 'Leave Site' button (perhaps in the '...' More Actions section; see screenshot) that you are allowed to leave.

Finally, as of a few minutes ago, Profile > My sites shows all 12 of my sites are gone--not sure if this is temporary, or some kind of glitch? Eeps! Attached screenshot.

Yes, I accidentally removed/rearranged some data yesterday in my attempts to remove you and others from the sites in question. I'm working with IT to restore any corrupted data. In the meantime, you should see these sites again on your profile.

If it's helpful, I can send you a list of those?

If it's helpful for you to be removed from these sites, and you're unable to do it yourself, then send me the list. (I can't do anything without a list, as it's not possible for me to tell for sure which sites you don't want to be a member of.)

#14 Updated by Syelle Graves almost 2 years ago

Responding to Syelle:

Well, the whole issue was that I was not able to leave those sites (Free Queer CUNY, Center of Philanthropy/cpcs) myself, which is why I put in the ticket (in my original correspondence, shown above, I wrote "I don't see any way to remove myself.") I tried to find the Free Queer group, for example, to attempt to leave the site that way, but there was no group by that name when I searched. I'd be happy to handle it myself, if there is a way that I'm missing?

At https://commons.gc.cuny.edu/members/syellegraves/sites you should see a 'Leave Site' button (perhaps in the '...' More Actions section; see screenshot) that you are allowed to leave.

On the live Commons, I do know and see the '...' More Actions > Leave Site (I can't seem to see any screenshot except for mine and Marilyn's--apologies--but no matter!) The problem is that the 'Leave Site' only shows for the sites in Commons Profile > My sites. Those aren't the sites I need to leave. The "ghost sites" that I never joined and don't see a way to leave only show in the drop-down menu, when I [hover over] my icon > [hover over] my sites (the my sites/dropdown mismatch). I couldn't leave Free Queer because it only showed in the hover/drop-down list.

If it's helpful, I can send you a list of those?

If it's helpful for you to be removed from these sites, and you're unable to do it yourself, then send me the list. (I can't do anything without a list, as it's not possible for me to tell for sure which sites you don't want to be a member of.)

Sorry, Boone; I was unclear! I meant "helpful" because of #9211. I thought it could have been of interest to check the list of "ghost sites" (that I've been added to without knowing about it, am not really in anyway, and can't leave), to see if they are all using the BBPress plugin. Disregard if that is not right.

And sure, It would be great if you could remove me from these "ghost sites"--thank you. Here they are:

Asian Art History (Art 251) https://bmccart251.commons.gc.cuny.edu/wp-admin/
BMCC Music Theory I https://mus117bmcc.commons.gc.cuny.edu/wp-admin/
English 201 Gold https://english201gold.commons.gc.cuny.edu/wp-admin/
Intro to Literature https://scribes201.commons.gc.cuny.edu/wp-admin/
Podgurski MUS102 https://podgurskimusic.commons.gc.cuny.edu/wp-admin/
Share-Ling https://shareling685568822.commons.gc.cuny.edu/wp-admin/
The Teaching and Learning Center https://tlc.commons.gc.cuny.edu/wp-admin/

But will I be auto-added back to these sites, any time I view them in the future?

Thanks very much for your help.

#15 Updated by Boone Gorges almost 2 years ago

  • Status changed from Reporter Feedback to Resolved
  • Target version set to Not tracked

Thanks, Syelle. I'm unsure why you are unable to see the Leave Site link - it probably has to do with the fact that these are "ghost" sites.

I've removed you from the sites you've listed.

But will I be auto-added back to these sites, any time I view them in the future?

No, you should not be. See #12105.

Thanks for your patience. I think this ticket can be closed out.

#16 Updated by Syelle Graves almost 2 years ago

Thank you very much. As of today, the my sites drop-down menu again includes sites Asian Art History, English 201 Gold, and Podgurski MUS102, so it's possible that the issue is re-occurring. I am happy to ignore them, but I wanted to send this update.

#17 Updated by Boone Gorges almost 2 years ago

Thanks, Syelle. There may have been instances where the block added in #12105 was happening too late to be effective. I've moved it in https://github.com/cuny-academic-commons/cac/commit/d3a3079536c3f8bd376fa36dfa8c2581a0fb700d and deployed it as a hotfix. You have also been removed from the three sites in question. Please let me know if this happens again.

Also available in: Atom PDF