Project

General

Profile

Feature #13371

Show item folders in Library list

Added by Colin McDonald about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Library
Target version:
Start date:
2020-09-24
Due date:
% Done:

0%

Estimated time:

Description

Breaking this off of #12821 and our Sept group meeting discussion of the importance of being able to see item folders in the main/list Library view. Professors want students to be able to see at the top level how items are organized, and the folders that are active. Potentially one could click on the folder name to go into that folder's contents as well. Could this be a separate column in the list view, or something else? Sonja is a watcher here and said she had ideas about this.


Related issues

Related to CUNY Academic Commons - Bug #13640: Attachments from deleted forum posts still appear in the LibraryResolved2020-12-01

History

#1 Updated by Sonja Leix about 1 year ago

Thanks Colin for breaking this out. I do not recommend to add another column to the library since we'll run into space issues on smaller screens and I don't believe having that column will help the user identify in a succinct way what contents live in each "folder".

Here is a mockup executing an initial thought and I'd love to get the team's feedback. It basically removes the folder dropdown and replaces it with a row of folder "labels" that help the user to switch between folder contents. It provides an overview of all folders, though we'll have to work on a solution in case there are a lot of folders and how to truncate them or display all in multiple rows.

The first label will toggle to see all items across all folders and we can adjust the wording there too to make it clear.

Looking forward to your feedback.

#2 Updated by Matt Gold about 1 year ago

Thanks, Sonja. I think this is a promising direction. I do worry a bit about how to handle long label names, but I like this direction.

#3 Updated by Colin McDonald about 1 year ago

I like this, too. I think that the "Items in all folders" button could actually just say "All items" -- it seems that default view should be all items whether they're in a folder or not. Many items won't be, and some Libraries may not have folders at all -- in which case perhaps this bar disappears entirely?

#4 Updated by Sonja Leix about 1 year ago

Thanks for the feedback Colin and Matt, let's discuss today to move forward

#5 Updated by Colin McDonald about 1 year ago

After our discussion on the call today, I'm wondering if the next incremental step with this is for Sonja to revise her initial folder "buttons" mockup and also include what it would look like if you hit "Expand all" and can then see underneath each item title what folder it's in (if any).

Part of this is because I realized that right now when you hit "Expand all" and there are no item descriptions in your chosen Library (which I think is fairly common), nothing happens. That's not very desirable behavior anyway, so maybe that coupled with the folder visibility function is enough to recommend this, along with the buttons visual upgrade we discussed on the call with general approval.

But what do others think, especially Sonja?

#6 Updated by Matt Gold about 1 year ago

Sure, that sounds like a fine way forward to me.

#7 Updated by Sonja Leix about 1 year ago

Here is the latest mockup of the changes.

#8 Updated by Laurie Hurson about 1 year ago

Hi All,

I really like the folder names added to the expanded view. It definitely helps clarify how the items are organized. Since the folder for the item is only visible when item is expanded, do we want to make the expanded view default, or consider adding more descriptive language ("Expand for more info" or something) to the expand link, and/or make "Expand/Collapse All" a more obvious button?

I also really like the item counts on the folder names/buttons.

#9 Updated by Colin McDonald about 1 year ago

Thanks for this, Sonja. I think we initially defaulted to the collapsed view because it's hard to say what items across all Commons libraries will have long description fields that obscure the main library list when expanded. Perhaps a good compromise is making the Expand/Collapse button more clear or prominent as Laurie suggests (defer to Sonja on final look if others agree) while retaining the consistency and minimalism of the collapsed view by default. Maybe instead of Expand/Collapse we go with Show/Hide Details?

I like being able to see each item's folder in the expanded view as well -- perhaps we could even make those live links into the folder if not too big a lift? Then you don't have to go up and find it in the button list above, though that's not a big extra step.

I think it's also good to show the number of items to incentivize cleaning up those with zero or low numbers for decluttering the top buttons.

#10 Updated by Matt Gold about 1 year ago

Hi All -- I like all of these changes, too.

#11 Updated by Sonja Leix 12 months ago

Thanks for all the feedback. I've implemented the following changes and made a few more adjustments to make it cleaner and information more contextual and in proximity of the related information:

- Changed the label of the expand/collapse feature to "Show Details" and "Hide Details" – agreed, that is a lot clearer
- Showing folder item count on all mockups now (we haven't heard from Boone how much lift this would be to implement)
- I changed the "Folder" label to an icon in the expanded list and linked the folder name – this will help guide the user visually to find this information easier since some of the list items have a lot of content (we haven't heard from Boone how much lift this would be to implement)
- I adjusted the order of things above the list a little: list of folders first with "edit folders" option, type dropdown, folder title if folder is selected (see page 3), pagination text "Viewing item 1 to 50 (of 79 items)", Show/Hide Details feature >> then we show the list, and below the list we repeat the pagination text and pagination links (if more than one page)
- On page 3 of the PDF you will also see what multiple rows of folder will look like and what empty folders will look like ("0" zero item count)

Looking forward to some final feedback so we can hand it over to development.

#12 Updated by Boone Gorges 12 months ago

Thanks, Sonja. This all looks good to me.

- I changed the "Folder" label to an icon in the expanded list and linked the folder name – this will help guide the user visually to find this information easier since some of the list items have a lot of content (we haven't heard from Boone how much lift this would be to implement)
- Showing folder item count on all mockups now (we haven't heard from Boone how much lift this would be to implement)

These shouldn't be a problem.

#13 Updated by Matt Gold 12 months ago

this all looks great to me. thank you, Sonja!

#14 Updated by Sonja Leix 12 months ago

Hi team,
as per our conversations during Friday's meeting, the attached mockups include the following change:
- changed "Edit folders" link to "Manage folders"

In addition to that, I've also mocked up two options for the mobile version.
- v1 has a dropdown for the folders on mobile, which goes against the purpose of this ticket, but i think would be more user-friendly on mobile
- v2 exposes all folders like the desktop version on mobile. This option would be problematic for groups with lots of folders, as this will push down the list of items possibly beyond the fold.

Let me know which version speaks to you more and why. I hope we can come to a consensus during our call tomorrow morning.

#15 Updated by Matt Gold 12 months ago

Hi Sonja -- thanks for this. I see your rationale for using v1 on mobile, and I think it is a good direction for us here.

#16 Updated by Boone Gorges 12 months ago

  • Category name set to Group Library
  • Target version set to 1.18.0

#17 Updated by Colin McDonald 12 months ago

We concurred on the dev call just now to go with v1 for mobile and take advantage of the screen real estate savings of the folder drop-down there. Thanks!

#18 Updated by Boone Gorges 12 months ago

Thanks all. I've made a first pass at implementing these changes. A couple of questions and thoughts that came up as I built:

1. On mobile, the 'current' dropdown item in the Folder dropdown has gray background and white text. In this way, it matches the desktop "button" view. But it creates a mismatch with the "kind" dropdown. The nature of dropdowns (where the item you see is always the one that is selected) means that Folder will always look gray, while Kind will always be white. Maybe that's OK since they do different things, but I thought it was worth noting.

2. When viewing a folder, the 'Show Details' area doesn't show folders. You only see folders listed in the Details area if you are in the 'ALL ITEMS' view.

3. Folder list (button or dropdown) is alphabetical.

4. The comp moves the 'Show Details' link so that it's in line with the 'Viewing...' pagination text. This means that we eliminate the pagination links. On mobile, this doesn't matter because we replace the pagination links with a Load More button anyway. On Desktop, however, the change means that there's no way to navigate to the second page of results. On desktop, I decided to add a second pagination area at the bottom of the list, with 'Viewing...' on the left and the existing pagination links at the right.

This is ready to test on cdev.

#19 Updated by Boone Gorges 11 months ago

  • Status changed from New to Testing Required

#20 Updated by Colin McDonald 11 months ago

Hello, here are a few points from our testing thread in the forum:

- Could we add a default "Not in a Folder" folder/button that contains only items, well, not in a folder? And perhaps this could only appear once a Library has at least one folder set up, so as not to be identical to the All Items view if there are no folders at all. It could also disappear if every item is in a folder, though I don't think that's essential or all that likely.

- Might we add a Delete link to the right of Edit in the right-hand column, to remove the step of going into the Edit screen and then pressing Delete? We should still show the delete confirmation screen if we do this of course, so you don't inadvertently delete something in one click.

#21 Updated by Boone Gorges 11 months ago

- Could we add a default "Not in a Folder" folder/button that contains only items, well, not in a folder? And perhaps this could only appear once a Library has at least one folder set up, so as not to be identical to the All Items view if there are no folders at all. It could also disappear if every item is in a folder, though I don't think that's essential or all that likely.

This seems OK to me, but it's a bit clunky. Is "Not in a Folder" the label that we'll use? It'd be nice if there was a folder-specific version of the word "Uncategorized". Should we put this label in brackets or something, to indicate that it's not a regular folder? It would be helpful to have Sonja's feedback here.

- Might we add a Delete link to the right of Edit in the right-hand column, to remove the step of going into the Edit screen and then pressing Delete? We should still show the delete confirmation screen if we do this of course, so you don't inadvertently delete something in one click.

This is a question about item deletion, not folder deletion - is that right? I'm against this change. It would cause layout problems on mobile. And IMO it's a feature and not a bug that you need to click several times to delete. If this is too much work, we should work on bulk delete tools rather than adding new actions to each row.

#22 Updated by Colin McDonald 11 months ago

Thanks, Boone. Happy to loop in Sonja on the "Not in a Folder" designation. I'd like to try to make it happen best we can based on the testing feedback, even if we have to use a longer phrase like that to make sure it's clear what the button represents.

That's fine with me about forgoing the item-level Delete link due to the layout and potential user-error issues. I agree that bulk deletion would help solve this and more. I'll keep ticket #13370 in our queue.

#23 Updated by Sonja Leix 11 months ago

- Might we add a Delete link to the right of Edit in the right-hand column, to remove the step of going into the Edit screen and then pressing Delete? We should still show the delete confirmation screen if we do this of course, so you don't inadvertently delete something in one click.

This is a question about item deletion, not folder deletion - is that right? I'm against this change. It would cause layout problems on mobile. And IMO it's a feature and not a bug that you need to click several times to delete. If this is too much work, we should work on bulk delete tools rather than adding new actions to each row.

I agree with Boone's feedback here 100%. Let's keep it as is and if there is a need for bulk delete, we should work on a feature of that nature.

- Could we add a default "Not in a Folder" folder/button that contains only items, well, not in a folder? And perhaps this could only appear once a Library has at least one folder set up, so as not to be identical to the All Items view if there are no folders at all. It could also disappear if every item is in a folder, though I don't think that's essential or all that likely.

Not ideal, but I guess it makes sense to add. Let's add it preferably directly after "All" or at the very end of the list of folders. If I could design the library all over again with everything we know today, I'd find a different solution, the folders structure feels like a bit of a can of worms. But I think this final solution is usable. Maybe there is an opportunity during the redesign to rethink the Groups UI structure with the left sidebar to open this up more. I'll keep this in mind.

#24 Updated by Boone Gorges 11 months ago

Thanks, all. I've implemented this and it's ready for a test on cdev.

#25 Updated by Colin McDonald 11 months ago

Thanks all, this is looking good (at least for now, as Sonja says) to me on cdev, with a couple of notes:

- If I put all of a Library's items in a folder, the button says "Not in a folder (0)" which I think is fine, but I wanted to make sure that was right. I'd mentioned we could consider just hiding that button if all items are in a folder, but maybe there is something to the confirmation that you've organized every last item.

- Only somewhat related, but is there any way to put an item from a forum attachment into a folder? I couldn't find one. And then when I deleted the forum post containing an attachment, it was still showing up in the Library. Clicking on the item itself opened it up still, but clicking on its Edit link pulled up an error page: "Oh, bother! No topics were found here."

#26 Updated by Boone Gorges 11 months ago

- If I put all of a Library's items in a folder, the button says "Not in a folder (0)" which I think is fine, but I wanted to make sure that was right. I'd mentioned we could consider just hiding that button if all items are in a folder, but maybe there is something to the confirmation that you've organized every last item.

Yeah, I could personally go either way on this one. Having the button there doesn't really hurt anything, so I'd argue in favor of leaving it.

- Only somewhat related, but is there any way to put an item from a forum attachment into a folder? I couldn't find one. And then when I deleted the forum post containing an attachment, it was still showing up in the Library. Clicking on the item itself opened it up still, but clicking on its Edit link pulled up an error page: "Oh, bother! No topics were found here."

No, there's no way to put a forum attachment into a folder. The deletion behavior is an unrelated bug (good catch) and I'll open a separate ticket for it.

#27 Updated by Boone Gorges 11 months ago

  • Related to Bug #13640: Attachments from deleted forum posts still appear in the Library added

#28 Updated by Colin McDonald 11 months ago

Thanks Boone, all sounds good to me.

#29 Updated by Boone Gorges 10 months ago

  • Status changed from Testing Required to Resolved

Also available in: Atom PDF