Project

General

Profile

Feature #13993

Conference Site template

Added by Colin McDonald 4 months ago. Updated about 1 month ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2021-02-16
Due date:
% Done:

0%

Estimated time:

Description

Let's collect ideas here about a possible conference Site template to offer alongside our default, teaching and portfolio templates. This template likely won't involve custom design as much as custom content and plugins. We've already discussed going with a newer default Wordpress theme, like Twenty Twenty, and focusing on what basic pages/text to include with this template, along with functionality for scheduling, collecting attendee info, etc.

Laurie has offered to collect some model conference sites here from which we might pull elements, perhaps on the Commons already or elsewhere, and we can build out content and requirements from there.

Screen Shot 2021-04-27 at 12.38.28 PM.png (878 KB) Screen Shot 2021-04-27 at 12.38.28 PM.png Laurie Hurson, 2021-04-27 12:46 PM
Screenshot_2021-04-27_13-20-41.png (74.8 KB) Screenshot_2021-04-27_13-20-41.png Boone Gorges, 2021-04-27 02:21 PM
Screenshot_2021-04-27_13-29-30.png (120 KB) Screenshot_2021-04-27_13-29-30.png Boone Gorges, 2021-04-27 02:30 PM
conf screen 2.png (710 KB) conf screen 2.png Laurie Hurson, 2021-05-13 03:30 PM

History

#1 Updated by Laurie Hurson 4 months ago

Thanks for getting this going Colin.

A few examples of conference websites on the Commons:

Digital Sociology -- https://digsoc.commons.gc.cuny.edu/

CUNY Games 2019 -- https://gamesconf2019.commons.gc.cuny.edu/

CUNY CUE 2019 -- https://cue.commons.gc.cuny.edu/

Performing Pedagogy -- https://theatrepedagogyconf.commons.gc.cuny.edu/

Language society and culture-- https://lscconf.commons.gc.cuny.edu/

More collected here:
https://docs.google.com/spreadsheets/d/1mcG6KqGGaRtNE0hE4cLeZOjGK4Pe-J9lApaPlyJ7k_k/edit?usp=sharing

My initial read is that the following topics should be included somewhere in the template's info architecture:

About
Call for Proposals

Schedule
Register
Contact

Keynote
Presentations
Organizers
Participants

Location (or, at this time -> Logistics?)

#2 Updated by Laurie Hurson 4 months ago

In terms of a plugin package for conferences, we could consider adding

- Academic Citations
- Category Sticky Post
- Google Shortcode Embed (for google form registration, abstract submission)
- Gravity Forms ( for more customizable registration needs? abstract submission)
- Tiny letter (I think that is what we are using now for newsletters but I do not know much about it. Would it be helpful here? Community team will know more.)
- Jetpack (for subscription, twitter, simple site analytics)

We may want to discuss other plugins such as Google Analytics and an Event plugin. Google Analytics has a lot of set up overhead so we might not add it automatically. If people want it, they can install. Events plugins tend to add a lot of dashboard areas and might confuse people but we may want to consider installing one that we deem most user friendly and/or popular on the Commons

Since many people are now using eventbrite to manage conference and event registration, we might also consider installing an eventbrite plugin that links the commons to the eventbrite event:
https://wordpress.org/plugins/widget-for-eventbrite-api/

#3 Updated by Marilyn Weber 4 months ago

A big NO to TinyLetter, or even any mention of newsletters. The problem is precisely that there is no newsletter plugin for the Commons. Our Tinyletter advice essentially instructs users to copy their posts from the Commons and then create a newsletter which is sent via Tinyletter. It's not integrated at all.

I think I'd suggest Jetpack and its subscription service. The organizers can them post updates which would go to subscribers.

#4 Updated by Boone Gorges 4 months ago

  • Target version set to 1.19.0

I'm tying this to the 1.19.0 milestone, because we may need to make some code-level changes to support the new template. (Though mostly we shouldn't; see https://commons.gc.cuny.edu/wp-admin/edit.php?post_type=cac_site_template.)

#5 Updated by Laurie Hurson 4 months ago

Good to know about Tiny Letter, thanks Marilyn. We will not add this.

Jetpack with the subscription option in the pre-set in a widget sidebar is a good workaround.

I think Colin or Luke may have a said this the other day, but it might make sense to make the conference template pretty simple and let folks build from there, rather than trying to add to many plugins, pages, etc from the outset.

#6 Updated by Colin McDonald 4 months ago

I'd like to push back just a bit on the Tinyletter aspect of this. Tinyletter offers a Mailchimp-like service for composing custom email sent out to a managed email list (for free, up to 5000 emails). Jetpack offers automatic notifications of your new posts to those who sign up. You can't alter what's emailed; it's just the post or an excerpt of it, from what I can tell. I believe importing/managing subscribers in Jetpack is also limited.

Jetpack may be fine for some users, for conferences or otherwise, but others will be looking for more control over what emails go out and to whom. I don't think it is a bad idea to make people aware of both solutions. We don't necessarily need to promote or tightly integrate either one since email newsletters aren't a universal need, though for conferences it may be a more regular desire.

We've discussed this a bit before, but a key here may be managing user expectations on what the Commons is and can reasonably provide, especially since it's free. As a Wordpress platform for creating sites and groups, providing email newsletter services is outside of a core feature set. Choosing to only offer and maintain certain plugins helps us keep the Commons stable and free.

But we can still help people use the Commons alongside other, recommended (to a point) services, emphasizing what is available for free and what will likely cost money. Absent a true, reliable newsletter integration, TinyLetter still seems like one of the least-bad options, with Jetpack as an alternative. I'm definitely open to hearing about other options, too. Things may have changed since I was deep into #11878 (see also #12065).

#7 Updated by Matt Gold 4 months ago

Hi All -- sorry for weighing in late here, but I misunderstood the context of our discussion about TinyLetter in the last community team call (I didn't realize it was in connection with the conference template).

I definitely agree with Marilyn that we should not include newsletter info with the conference template -- it has just caused too many headaches for our team, and raising it as an option seems likely to lead to more issues.

I do think that the key functionality people will need here is to 1. Keep track of registrations/registrant emails (which could be done through gravity forms?) and to export them. And it's likely that conference organizers will want to export registrant info so that they can send messages/announcements to conference registrants. In our documentation, I think we can just suggest that they a) download names/emails from gravity forms, and then b) use a service like MailChimp/Tiny Letter to send messages to people. I don't think we need to connect that to the idea of sharing content from the site itself in a newsletter.

#8 Updated by Laurie Hurson 4 months ago

I also agree with not including tinyletter because of past confusion and support required for the tool.

I do think we will want to include both gravity forms and Google Doc shortcode embed in order to provide options for running registration.

Gravity forms provides a lot of functionality but also takes quite a bit of work to set up the forms, whereas Google forms and spreadsheets are easy to setup and manage for registration purposes (I know this is what the TLC does). So providing both options would be important, I think.

#9 Updated by Colin McDonald 4 months ago

Thanks everyone for the discussion on this. Sounds good to me for conferences about emphasizing Google Docs first, then Gravity forms, by including these as part of the template package and framing them for registration purposes. We could also include steps for exporting registrant info.

Then other options like Tinyletter, perhaps Jetpack, and perhaps others would be documented elsewhere as ways email people using contact info collected via the Commons in some way, for a conference or otherwise. And the emailing could be about content on your Commons site or messages totally separate from your posts/content.

The first part we can work on as part of how we're going to introduce and guide people through this new template, and the second would be more of a standard documentation project for Scott and the community team.

#10 Updated by Colin McDonald 3 months ago

Hi Laurie, since we didn't get to this ticket during the team meeting on Friday, perhaps we could talk about next steps on a call this week? I think we have a good picture of what plugins we want to mention/feature after the above conversation.

Should there be a Google doc next to start writing out the content for the default pages, perhaps based on some of the examples you compiled? We could also start working on the documentation (which might also include examples), so we know how we'll be framing this to new users of the template.

I assume we'll also need a paragraph or two introducing the template on the "create" flow.

#11 Updated by Laurie Hurson 3 months ago

Hi Colin,

Yes hopefully we can catch up about this this week. Unfortunately I have to miss friday's community call but maybe we can collaborate online?

For the past templates I just went ahead and made a template site and worked out copy there. Do you want me to begin making this site and add you as an admin?

I can also start working out copy for the create page (and for the site if you'd prefer to do all the site copy that way).
GDoc: https://docs.google.com/document/d/1gV7_y4a623YAsslj0fCAjf_5PzBkDHsrkw3SsrRhNKg/edit?usp=sharing

A side note: I also noticed the copy for the teaching template advises faculty not to change the theme and I think we should reconsider this advice.

#12 Updated by Laurie Hurson 3 months ago

Hi Colin,

I started building out the Conference template here. https://conftemplate.commons.gc.cuny.edu/

This is the site that would act as the "original" and would be cloned when people selected this template. I am going to work on the copy a bit more so it is more educational but would appreciate any feedback you have. I don't want to make the template too complicated by embedding shortcode or using other plugins too actively on the template since I think this may confuse people if they see shortcode embeds on their new conference site when they create a site from this template.

I am working on building out a fake conference "demo" site that will have a working registration form, etc. so that people can view as a guide when putting together their own conference site. This is similar to how we did the other templates - there is the template that is the cloned site and then there is a more built out demo as an example. Ill share the demo site soon.

Any other feedback you have- about theme, colors, graphics (there are none right now...) - would be great!

Thanks!

#13 Updated by Laurie Hurson 2 months ago

Hi All,

A request for feedback on the following sites for the conference template...

The Template site will be the site that is copied to create each new conf site: https://conftemplate.commons.gc.cuny.edu/

Questions:
- Theme: What do we think about this theme? It is new but most conferences do not use this full-width, central text type template. Interested to know what others think
- Any other pages/categories, etc. that should be included that are not there?
- Layout and copy - any edits?

Conference showcase page will be linked from creation portal so users can get an ideas of how other conferences have been built and hosted on the commons.
https://commons.gc.cuny.edu/conferences-on-the-commons/

Questions:
- Copy on the page, any edits needed?
- Variety of conferences - a lot of the conferences I found on the Commons were teaching-oriented but I tried to make this showcase page a mix of recent academic and teaching conferences. Feedback on the conferences included here?

Thanks all!

#14 Updated by Matt Gold 2 months ago

I really love your work here, Laurie!! Thanks for you work on this. Here are some thoughts:

1. I really love the information architecture here and think it is right on target. A few minor suggestions:
-- under presenter guidelines, we have an opportunity to encourage people to suggest best practices for accountability. I wonder whether you could suggest that in the sample text and perhaps even include a link to a resource for creating accessible conference presentations

2. I wonder whether there should be a page for sponsors. Maybe under "About"?

3. Re the template, I agree that most conferences are likely to want a sidebar. And I have to say that I don't love the aesthetics of this theme -- the blue background doesn't look great with white logos (like the GC's) on top, and I'm also worried about the accessibility of light blue over darker blue text. Are there other themes you considered?

Huge thanks for your work on this. I really think that overall, the work is great.

#15 Updated by scott voth 2 months ago

Hi Laurie - I agree with Mattt - this looks great!

There is a Help page here: https://help.commons.gc.cuny.edu/conferencesevents-2/ which covers some of the info on the new conference showcase page. If you want to incorporate any of this, feel free. I think once the showcase is live we can change the Help page to reflect the new content.

#16 Updated by Laurie Hurson 2 months ago

Thanks Matt and Scott for this feedback. I have changed the theme to sydney since it has sidebars, clear main nav, and various theme options for customization.

Scott, I think the help page you created is great and I linked to it from the home page so users can go there for more detailed information about domain mapping. We might also think about adding some content there about best practices for building a conference site, including some of the accessibility language from the template (in presenter guidelines).

#17 Updated by Matt Gold 2 months ago

Looks good! Thank you, Laurie.

#18 Updated by Colin McDonald 2 months ago

Sorry about my belated feedback here, but I agree that this is looking great, especially with the latest clear and well-structured theme.

Perhaps this is more for the documentation, but I'm wondering if we can encourage more uses for the sidebar. I tend to look there even before the main nav sometimes, especially because that's a good place to put visual elements like a Register button and a map embed for a non-remote conferences. Those elements are good to carry through every page in the sidebar as well. Perhaps also the default sidebar search widget?

Maybe this is overly ambitious, but so many conference have social media components now, at least hashtags for participants to use, that we could suggest an embed or nod to that in the sidebar, or perhaps a separate About section or sub-menu item for social engagement.

Perhaps some of this could be part of the footer too, especially if users find their sidebar getting cluttered. The footer is also a little bland right now. Maybe an inset for contact/copyright is good down there?

#19 Updated by Laurie Hurson about 2 months ago

Thanks for this feedback Colin.

Look forward to catching up at the meeting today.

#20 Updated by Laurie Hurson about 2 months ago

Hi All,

Turns out cloning a site with jetpack installed and activated moves over the activated account to the cloned site. I have deactivated jetpack on the conference template site so my account is not activated on all cloned sites.

I updated the jetpack documentation here to reflect the new process of activation and new jetpack pages. https://help.commons.gc.cuny.edu/jetpack/

I finished the presenter guidelines to include info about accessibility and added sidebar an widget information on the template. https://conftemplate.commons.gc.cuny.edu/

I think this is pretty ready to go but please let me know if any more edits or additions are needed.

Thank you!

#21 Updated by Laurie Hurson about 2 months ago

Hi All,

Creation portal info is in this google oc and pasted below.
https://docs.google.com/document/d/1gV7_y4a623YAsslj0fCAjf_5PzBkDHsrkw3SsrRhNKg/edit


Conference Template

[Screenshot]

View the Template (link to https://conftemplate.commons.gc.cuny.edu/)

Browse Past Conferences on the Commons (link: https://commons.gc.cuny.edu/conferences-on-the-commons/
)

The Conference Template launches a WordPress site pre-configured for conference organizers who want to host their outreach on the Commons. The Conference Template comes with pages for proposal submission, presenter guidelines, registration, and more. The site is fully customizable and site admins and conference organizers can use, edit, and add new pages, posts, and plugins as needed.

The template also comes with several plugins activated to support hosting a conference website on the Commons. Gravity forms, Google Doc Shortcode Embed, and Eventbrite plugins can help streamline registration. Jetpack offers a suite of tools, including site analytics, Twitter integration, and a “subscribe” feature which allows attendees to sign up to receive updates from the site.
-----

#22 Updated by Boone Gorges about 2 months ago

Thanks for this, Laurie. Could we clarify exactly how you want this to appear during site creation? I've attached a screenshot of the current format, which is like this:

-SCREENSHOT-   |   [Academic Portfolio Template demo (opens in new window)]
               |
               |   Description

I'm assuming you want the 'demo' link replaced with your two links, but using that same style? My second attachment is a mockup (ignore the screenshot, which I didn't swap out)

#23 Updated by Colin McDonald about 2 months ago

This all looks great to me! Thanks for jazzing up the sidebar and footer Laurie, for my eye that I guess tends to wander to the margins of the page. Looking forward to seeing this in the list of templates.

#24 Updated by Laurie Hurson about 2 months ago

Hi Boone and Colin,

Thanks for the feedback.

I'm assuming you want the 'demo' link replaced with your two links, but using that same style? My second attachment is a mockup (ignore the screenshot, which I didn't swap out)

Yes, this is exactly what I was thinking. Though for the sake of continuity of having a single link at the top, should we have the "view the template" link before the description and the "Browse Past..." at the end of the description? I am fine with either option.

Everything else looks good to me.

Thanks again!

#25 Updated by Boone Gorges about 2 months ago

  • Status changed from New to Reporter Feedback
  • Target version changed from 1.19.0 to 1.18.10

Thanks, Laurie. I'll have to make some minor modifications to the codebase in order to launch this, so I'll do it as part of the 1.18.10 release.

Can you confirm where you'd like Conference Template to appear in the list of available layouts? Should it be last?

#26 Updated by Laurie Hurson about 2 months ago

Hi Boone,

Thanks for this!

Yes, I think it makes sense if this conf template is added as the last in the current list.

Thanks again!

#27 Updated by Boone Gorges about 2 months ago

  • Status changed from Reporter Feedback to Assigned
  • Assignee changed from Laurie Hurson to Boone Gorges

Thanks for confirming!

#28 Updated by Boone Gorges about 1 month ago

  • Status changed from Assigned to Staged for Production Release

I've made the necessary changes to the cac-site-templates plugin and I've staged the content so that I can press Publish after tomorrow's release: https://commons.gc.cuny.edu/wp-admin/post.php?post=114737&action=edit&classic-editor

#29 Updated by Laurie Hurson about 1 month ago

thanks Boone!!

#30 Updated by Boone Gorges about 1 month ago

  • Status changed from Staged for Production Release to Testing Required

The template is now up and running. Laurie, can you give it a test run-through to make sure everything's cloning as you'd expect?

#31 Updated by Laurie Hurson about 1 month ago

Thanks for this Boone!

I created clones using the template and all looks good.

For the template listing in the creation portal, the dimensions of conference template screenshot seem a bit off. I have attached another screenshot- this one might be better? If it's not too much trouble can we update the image?

And I know I previously said both links (view template and browse) could be at the top. Again, if not too much trouble, for consistency can we shift the "browse" link to under the text paragraph description?

#32 Updated by Boone Gorges about 1 month ago

Sure, I've made the changes.

#33 Updated by Laurie Hurson about 1 month ago

Thanks Boone! Looks good.

#34 Updated by Boone Gorges about 1 month ago

  • Status changed from Testing Required to Resolved

Great, thanks for confirming!

#35 Updated by Laurie Hurson about 1 month ago

Hi Colin,

Dropping a few links here for blog post about conference template:

Template: https://conftemplate.commons.gc.cuny.edu/

Template help page: https://help.commons.gc.cuny.edu/conference-template/

Conference help page: https://help.commons.gc.cuny.edu/conferences-events/

Conference showcase page: https://commons.gc.cuny.edu/conferences-on-the-commons/

Also available in: Atom PDF