Project

General

Profile

Feature #140

Create search for forums

Added by Maura Smale over 9 years ago. Updated about 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2009-12-11
Due date:
% Done:

0%

Estimated time:
8.00 h

Description

This is probably already under development as part of the global site search, but the LILACers would very much like to be able to search through forum posts for our group. Not urgent at all. Thanks!

Forum-Search.jpg (40 KB) Forum-Search.jpg Samantha Raddatz, 2015-04-14 09:37 AM
Screen Shot 2015-05-11 at 3.07.15 PM.png (297 KB) Screen Shot 2015-05-11 at 3.07.15 PM.png Samantha Raddatz, 2015-05-11 03:08 PM

Related issues

Related to CUNY Academic Commons - Feature #102: Latest Forum Topics shows only public groupsRejected2009-12-03

Related to CUNY Academic Commons - Feature #1615: Forum searchDuplicate2012-02-04

Related to CUNY Academic Commons - Feature #3002: Overhaul CAC search by using external search applianceAssigned2014-01-30

Related to CUNY Academic Commons - Feature #3177: Upgrade bbPress to 2.xResolved2014-05-02

History

#1 Updated by Boone Gorges about 9 years ago

Maura, does the forum search in the new version of BP work? More specifically, does it work for the content of a non-public group like LILAC?

#2 Updated by Maura Smale about 9 years ago

Hi Boone, I haven't been able to get it to work for a private group. You're talking about the forum search box here: http://commons.gc.cuny.edu/forums/, right?

Actually, further weirdness: even when I'm logged in I don't see my private groups on that forums page, only the public ones.

#3 Updated by Boone Gorges about 9 years ago

Thanks for the feedback, Maura.

The behavior you're seeing is by design. At this moment, BP search does not index private or hidden group forum content, and does not display private or hidden groups on the main Forums tab. This might change at some point in the future.

#4 Updated by Maura Smale almost 9 years ago

Sure thing. Thanks Boone!

#5 Updated by Boone Gorges over 8 years ago

  • Target version set to Future release

#6 Updated by Matt Gold almost 7 years ago

  • Category name set to Group Forums
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Low to Normal
  • Target version changed from Future release to 1.4

I'm finding this to be an increasingly needed feature the longer the Commons is in existence. If you go to one of your private groups and want to find a forum topic that addressed a specific issue, there is no way to find it. As forums grow, this will become a more pressing issue for our members.

Moved this to the 1.4 milestone; Boone, please let me know whether that is impossible.

#7 Updated by Boone Gorges almost 7 years ago

  • Target version changed from 1.4 to 1.5
  • Estimated time set to 10.00 h

Boone, please let me know whether that is impossible.

Nothing's impossible, but it will take a lot of work. I would rather not delay the 1.4 release any more than it already has been. I'd like to move forward under the assumption that this will not go into 1.4, but if 1.4 is held up for some independent reason, and we have time to move it back into the milestone, we'll do so.

#8 Updated by Matt Gold almost 7 years ago

Okay. 1.5 is fine -- just don't want the ticket to be lost in the purgatory of "future release."

#9 Updated by Boone Gorges almost 7 years ago

the purgatory of "future release."

When everything is important, nothing is! But OK.

#10 Updated by Matt Gold almost 7 years ago

  • Category name changed from Group Forums to BuddyPress (misc)
  • Severity set to High impact

I think we should consider making this a more general Group search that would search not just through forums, but also docs. It can be hard to remember whether a conversation happened in a forum thread or under a doc. This feature is particularly important for private groups, I think, since they're not (to my knowledge, at least) covered by the google search.

#11 Updated by Boone Gorges over 6 years ago

  • Target version changed from 1.5 to 1.6
  • Estimated time changed from 10.00 h to 2.00 h

We'll get this for free when we move to bbPress 2.x. I'm hoping that this'll come in CAC 1.6.

#12 Updated by Boone Gorges over 5 years ago

  • Category name changed from BuddyPress (misc) to Group Forums

#13 Updated by Boone Gorges about 5 years ago

  • Status changed from Assigned to Testing Required

A first pass at a sort of groups "omnisearch" is now running on cdev. Use the "search groups" box at the upper right of http://cdev.gc.cuny.edu/groups/.

It's currently searching the following:
- group names and descriptions
- forum posts and topic names
- Docs content

Results are limited to those items that your user has access to. So you will see results from hidden groups that you're a member of, etc.

In cases where you match a Doc or Forum post/topic, excerpts are displayed inline, where you'd normally see the group description. Only the first three matches in a given group are displayed.

Results are currently expressed in a very group-centric way. That is, you search for "boone", and you are shown a list of groups that match "boone" in one way or other, with a gloss as to what the matches are. This may not be the way that people want this to work. Instead, they may want a results-centric results page, where the associated group is merely a piece of metadata associated with results. However, this introduces a number of questions regarding how the results should be sorted and displayed. (By focusing on groups, we can use the existing groups directory template, along with the "Order By" dropdown. If we switch to focusing on results, we'll have to sort by date or relevance or something else complicated).

Thoughts are welcome.

#14 Updated by Matt Gold about 5 years ago

Hi Boone,

This seems like a very useful feature, but one that it doesn't quite meet the need described in this particular ticket. My understanding of the original request is that the use case is a group with a huge number of posts -- say, a group like our Commons team group. Someone wants to find a particular post, but the only way to find it is to look manually through individual threads to try to find it.

If we were to have a search feature within groups (rather than a global search feature on the group directory), I think that would come close to meeting the need described here, since the goal is to search the forums of a particular group.

#15 Updated by Boone Gorges about 5 years ago

  • Status changed from Testing Required to Assigned
  • Assignee changed from Boone Gorges to Chris Stein
  • Target version changed from 1.6 to 1.7
  • Estimated time changed from 2.00 h to 8.00 h

Thanks for the feedback.

Chris, I'm reassigning this to you for the time being. We don't currently have a place in the group UI for search. We'll need to have an interface for entering search requests, and an interface for displaying the results. What should this look like? Should Search be a separate group "tab", alongside Files, Members, etc?

#16 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.7 to Future release

#17 Updated by Raymond Hoh over 4 years ago

Thought I'd add a first pass at this on cdev since bbPress has some functionality built for this and we will be using bbPress for 1.7.

To flesh out bbPress' functionality for single forum search, I wrote a custom plugin to ensure that bbPress can indeed filter search terms for a specific forum.

To test, go to cdev and navigate to a group's "Forum" tab. You should see a search form aligned to the right. Type in a search term and the results should be displayed on the next page.

I know this needs some UX feedback and isn't slated for 1.7, but thought I'd give it a go.

Feedback welcome.

Update

To test, cdev has to switch to the 140-forum-search branch. At the moment, cdev is not on this branch as we are testing the Personal Homepage. However, if you want to test out forum search, let me know.

#18 Updated by Raymond Hoh over 4 years ago

  • Assignee changed from Chris Stein to Raymond Hoh
  • Target version changed from Future release to 1.8

Moving this to 1.8 as I've already done most of the work for this.

#19 Updated by Boone Gorges about 4 years ago

Hi Ray - You have an update on this? If it's mostly done, maybe you can go ahead and merge it into the 1.8 branch for testing.

#20 Updated by Raymond Hoh about 4 years ago

The plugin is up on cdev now.

To test, navigate to a group's "Forum" page and type a search term in the new Search text field box.

#21 Updated by Matt Gold about 4 years ago

Wow -- I am so psyched about this. Seems to work very well!

My only questions is about the positioning/styling of the search box. Samantha, what do you think?

#22 Updated by Samantha Raddatz about 4 years ago

We don't have much of a standard for search boxes, but I do think we should copy the search box from the People tab and include the help-text "Search forum posts..." so that it's clear that this is for the forum only. Moving it closer to the actual forum listing, rather than above the 'Post New Topic' area would be great too. See attached mock-up.

#23 Updated by Matt Gold about 4 years ago

Agreed. Thanks, Samantha.

#24 Updated by Raymond Hoh about 4 years ago

cdev is updated so the search form is aligned to the right and adds a placeholder.

Also, I've added access control. Let's say a user attempts to make a search on a hidden forum that the user does not have access to, the search will now return an empty result. Previously, it was possible to manually search for terms for a hidden or private forum.

#25 Updated by Raymond Hoh about 4 years ago

Samantha, when you have a chance, can you take a look and see if anything else needs to be done for the UI regarding group forum search?

#26 Updated by Samantha Raddatz about 4 years ago

Looks great, Ray!

It would be nice if the search results could be displayed within the group environment (with the group title and left menu still visible), rather than taking the user out into a general Forms area (see attached for results example).

If that's a large ask, I can create a new ticket for that request and we can mark this as resolved for this release. Definitely not a deal breaker.

#27 Updated by Raymond Hoh about 4 years ago

If that's a large ask, I can create a new ticket for that request and we can mark this as resolved for this release. Definitely not a deal breaker.

Would be nice to do this, but it does require some dev time to get it working correctly. Especially with pagination and URLs. Will look into this in the next release.


Thanks to Marilyn and Sarah for uncovering a bug when searching private and hidden group forums. This is now fixed and is available for testing on cdev.

#28 Updated by Raymond Hoh about 4 years ago

  • Status changed from Assigned to Resolved

Going to mark this as resolved.

I've created a new ticket for group forum search to display within the group layout - #4073.

Thanks everyone!

Also available in: Atom PDF