Project

General

Profile

Bug #14095

Ensemble Plugin not updating URL

Added by Laurie Hurson 7 months ago. Updated 6 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2021-03-02
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

SPS faculty are redesigning their Faculty Community site: https://spsfaculty.commons.gc.cuny.edu/

They use the tool Ensemble video to make and host videos and would like to pull their videos into their Commons site via the Ensemble Video Responsive Plugin.

Videos are pulled by adding their ensemble URL to the Ensemble Video setting area (screenshot)
https://spsfaculty.commons.gc.cuny.edu/wp-admin/options-general.php?page=ensemble_video

Whenever they add their own URL on this page and attempt to update, the url is not saved; it is stripped out and replaced with "demo", as seen in screenshot.

They have reached out to the Ensemble plugin team to check if this issue might be a problem with the plugin but I also told the SPS team that I would check with our dev team. The SPS team said that"If you need more information or need to connect the Commons developers with our Ensemble plugin vendor, let me know. The Ensemble folks would be open to this."

Can we check on possible reasons this url may not be updating or if the commons system is stripping the url upon saving?

Thanks,
Laurie

History

#1 Updated by Laurie Hurson 7 months ago

The SPS Ensemble URL is https://cunysps.ensemblevideo.com

It looks like this redirects to their single sign on page and maybe this is the cause of the issue?

#2 Updated by Boone Gorges 7 months ago

  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges

I found a bug in the plugin, which I've reported to the author at https://wordpress.org/support/topic/plugin-setting-initialization-is-incorrect-on-multisite/. For now, I've got a hotfix in place that makes it possible to save the options.

#3 Updated by Laurie Hurson 7 months ago

Thanks Boone!

I'll relay this to the SPS team.

#4 Updated by Boone Gorges 6 months ago

  • Status changed from Reporter Feedback to Staged for Production Release
  • Target version set to 1.18.7

#5 Updated by Boone Gorges 6 months ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF