Project

General

Profile

Feature #14731

Whitelist .ics files for forum/library?

Added by Colin McDonald 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress - Media
Target version:
Start date:
2021-08-27
Due date:
% Done:

0%

Estimated time:

Description

I just tried to include some .ics file attachments to a forum post to distribute meeting calendar items to the Commons team, and after I pressed submit I was told that they were disallowed for security reasons. I then tried to post them to the Library instead but it wouldn't allow me to select that type of file on my computer.

Is there a specific security risk for uploaded .ics files? If so I'm happy to work around this, but I wasn't sure if they were just part of a blanket blocking and we'd never examined them specifically.

History

#1 Updated by Raymond Hoh 2 months ago

  • Category name changed from Group Files to WordPress - Media
  • Status changed from New to Assigned
  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.18.18

Hi Colin,

Only certain file types are allowed to be uploaded to WordPress by default. .ics files are not part of this internal allowed list, so I've manually added support for it in https://github.com/cuny-academic-commons/cac/commit/8298f02cabd6ad7c7f22dd897d885276129b84ef.

I haven't pushed this as a hotfix to production yet, but I can if you need to attach the .ics files before your next forum post.

#2 Updated by Matt Gold about 2 months ago

also, in the interest of time, Colin, you could put the ICS files in a google drive folder or dropbox folder and just post a link in the forum post

#3 Updated by Colin McDonald about 2 months ago

Thanks Ray, and no need for a hotfix -- I've taken Matt's suggestion and just published a forum update with the ICS files in a Dropbox folder.

#4 Updated by Boone Gorges about 1 month ago

  • Target version changed from 1.18.18 to 1.18.19

#5 Updated by Raymond Hoh about 1 month ago

  • Status changed from Assigned to Resolved

Following today's maintenance release, I've just tested uploading an .ics file to a forum post and this is now working.

Also available in: Atom PDF