Project

General

Profile

Bug #14951

Commons down

Added by Matt Gold 3 months ago. Updated 2 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2021-11-09
Due date:
% Done:

0%

Estimated time:

Description

I emailed Boone about this, but I'm creating this ticket to document the outage


Related issues

Related to CUNY Academic Commons - Bug #14987: Elementor update causes database freeze-upNew2021-11-23

History

#1 Updated by Raymond Hoh 3 months ago

FYI, I noticed the Commons maintenance page was displaying on production just now. At the same time, cdev was functional, but was referencing a stale object cache that I previously reported in #14908.

I ran wp cache flush in WP-CLI and that appears to have fixed things.

#2 Updated by Boone Gorges 3 months ago

Thanks, Ray.

I was able to determine that the Elementor update was the source of the problem. Here's the original update: https://github.com/cuny-academic-commons/cac/commit/a5015ca4e134a8310fdcc01ad64ad35688b22f66 and the revert https://github.com/cuny-academic-commons/cac/commit/abbf0061f153fa32d32954f30b138775714a84e4

I looked through the Elementor changeset and I don't understand what could be causing the problem. It's indicative of either (a) some sort of database upgrade/migration, or (b) a self-request loop. But I didn't see anything of that sort in the update.

I couldn't reproduce the problem locally, but I also don't have a full clone of the production site, and even if I did, it doesn't get the traffic of the production site. I'll take more time in the upcoming days to try to make an educated guess at what's going on.

#3 Updated by Boone Gorges 2 months ago

  • Status changed from Assigned to Resolved
  • Target version set to Not tracked

The site is back up. See #14987 for ongoing discussion.

#4 Updated by Boone Gorges 2 months ago

  • Related to Bug #14987: Elementor update causes database freeze-up added

Also available in: Atom PDF