Project

General

Profile

Bug #15136

Main menu nav items are incorrect

Added by Boone Gorges 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Home Page
Target version:
Start date:
2022-01-04
Due date:
% Done:

0%

Estimated time:

Description

As noted in #15135, something happened in the 1.19 launch that caused the nav menu to be displayed incorrectly.

History

#1 Updated by Boone Gorges 6 months ago

  • Status changed from New to Resolved

I'm not sure why this happened, but I have fixed it.

In the case of Privacy Policy and Terms of Service, the links went to non-existent pages. I couldn't find evidence of the pages even in the trash. I'm not sure what happened here or why, so I restored the pages to what's found on cdev and added them into the About submenu where they appear on that site.

#2 Updated by Colin McDonald 6 months ago

Thanks for working on this, Boone. I was just taking a look and those links seem good, but I clicked on the Image Credits and Contact Us links right next to them and both seem broken too. Credits gives a 403 errors, seems to want to redirect

https://commons.gc.cuny.edu/about/images

to

https://commons.gc.cuny.edu/images/

And for Contact Us, this is the broken link:
https://commons.gc.cuny.edu/about/contact-us

Maybe something on CDEV for these too?

#3 Updated by Boone Gorges 6 months ago

"Image Credits" used to point to this page https://commons.gc.cuny.edu/images-credits/ but I'm unsure that it's relevant anymore, since we don't use the slider. I'm removing it from the menu.

Likewise, I don't see evidence of a 'Contact Us' page anywhere, and I don't recall one ever existing. I've removed it.

#4 Updated by Matt Gold 6 months ago

Hi Boone -- I'd like to bring Scott into this conversation before removing image credits. We should be crediting people for the images we use. Scott, in the new setup, do you foresee ways that you will be using photos that need attribution?

#5 Updated by Boone Gorges 6 months ago

The specific focus of that page was for slider images on the main site. We don't have a slider anymore.

Posts on the News site and elsewhere may have images, but it seems that the image credits should go in those posts instead.

#6 Updated by scott voth 6 months ago

Yes, I think we could have a page on both the News site and the InCommon site for attributions. I usually put the attributions in the caption field of the images. However, it is not evident where the images are coming from when looking at home page.

#8 Updated by Raymond Hoh 6 months ago

Just spotted that the sitewide footer still contained the "Contact Us" and "Image Credits" links. I've just removed them in https://github.com/cuny-academic-commons/cac/commit/661945ab6a4625ce67c2c221d7dbcfd6bd5ea3f0 and deployed the commit as a hotfix.

Also available in: Atom PDF