Project

General

Profile

Bug #1543

Spacing on "My Groups" Dropdown

Added by Matt Gold over 7 years ago. Updated over 5 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
Toolbar
Target version:
-
Start date:
2012-01-13
Due date:
% Done:

0%

Estimated time:

Description

The spacing on the "My Groups" drop-down looks to be a little screwed up, with some group names overlapping; please see the attached screenshot. I know we discussed this during the bug-testing phase, but I'm not sure where we left things.

Mac OS X 10.7.2, Chrome 16.0.912.63


Related issues

Related to CUNY Academic Commons - Bug #2765: Scrolling/layer issue on admin barResolved2013-08-30

History

#1 Updated by Matt Gold over 7 years ago

Actually, in addition to the problem of spacing of group names, there's also the fact that I'm a part of so many groups that the dropdown only goes to from A-P. Don't know how many users this will affect given that most people haven't joined as many groups as I have, but there should some way to scroll through the listings if they all can't fit on the drop-down.

#2 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.3.5 to Future release

Your dropdown does contain P-Z. That's the column appearing over the top of the others. So this is only a problem for people whose group lists extend into more columns than their browser window can handle.

FWIW, you have the most group memberships on the site, with 79. In second place is Sarah, with 70. George has 50. Only an additional 8 members have more than 30 groups. Thus this will be a problem for an extremely small subset of our users - probably only you, Sarah, and anyone who views the site with a very small browser window. While it's true that these are probably the most active users of the site, it's also true that they are small in number, and likely to be understanding of a glitch with a huge blog list.

Given these observations, I'm suggesting that this ticket be put off. At its root, it is a WordPress issue. See http://core.trac.wordpress.org/ticket/15317. The multiple columns bit is a hack by me to make it more workable, and it does for 99.9% of our users. If and when WP fixes this bug for the My Sites list, we can apply the same fix to My Groups.

#3 Updated by Matt Gold over 7 years ago

Fair enough. But since we are able to identify users whom this might effect, and since they are power users, I wonder whether we should consider reaching out to them. Would you be able to provide me with a list, via email of users who might be affected by this?

#4 Updated by Sarah Morgano over 7 years ago

Yay, I'm in second place!

Not sure if it matters, but I can access all of "my blogs" via the drop-down using FireFox (not IE). However, I cannot access all of "my groups" using IE/FF. I also noticed that with IE everything is listed in 1 column only.

Best,
Sarah

#5 Updated by Boone Gorges over 7 years ago

I also noticed that with IE everything is listed in 1 column only.

Yes. That was a concession made during development, because nothing was working correctly in IE, and I didn't know how to fix it. So IE users just get the WP default, which is a single unscrollable column.

Not sure if it matters, but I can access all of "my blogs" via the drop-down using FireFox (not IE). However, I cannot access all of "my groups" using IE/FF.

Probably because your number of groups is above the threshhold necessary to go to a number of columns greater than your screen width.

#6 Updated by Matt Gold over 7 years ago

Boone, if I'm going to email people whom this might affect, what is your best guess for a threshold at which to start (ie, is this likely to affect people with over, say, 25 groups? 20? 30?)

#7 Updated by Boone Gorges over 7 years ago

I have about 35 groups and I can't reproduce the overlap issue (though I can make the groups cascade off the screen if I make the window really really small). Based on that, I'd say 30+ will easily catch everyone.

If it were me, I wouldn't send an email. I'm not sure what it's going to accomplish - if anything it seems like it would confuse people more, and draw their attention to something they may not otherwise notice.

#8 Updated by Matt Gold over 7 years ago

Thanks, Boone. What does the community team think?

#9 Updated by Sarah Morgano over 7 years ago

I think we should let them know...

#10 Updated by Chris Stein over 7 years ago

It seems in the spirit of the Commons to let people know how might be affected. But Boone makes a good point that the informing should not make things more confusing. However the solution is relatively simple, just click on the main My Groups or My Blogs link and then you can access all of them from those pages. Maybe we can do a couple of things:

Create the Troubleshooting section we've been talking about and add a quick item on this.

Figure out exactly how many people we think may be affected by this.

If the number is small enough then send them an email that explains the issue and solution and points them to the troubleshooting page.

If the number of people is really small we may take the opportunity to ask them for general feedback on the site as these are clearly power users who have invested in the Commons (the email may recognize and thank them as such too).

#11 Updated by Boone Gorges over 5 years ago

  • Category name changed from BuddyPress (misc) to Toolbar
  • Status changed from Assigned to Rejected
  • Target version deleted (Future release)

The display issues that are described in the original bug report are no longer relevant, due to recent changes in the way we handle the My Groups toolbar item.

For a broader discussion of this feature, let's use #2765.

Also available in: Atom PDF