Project

General

Profile

Actions

Bug #19998

closed

Hypoths.is not working on media Library PDF

Added by Laurie Hurson 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Plugins
Target version:
Start date:
2024-03-18
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Hi All,

A user today alerted me that hypothesis is not working on a pdf they uploaded to a public commons site:

https://socialannotation.commons.gc.cuny.edu/annotating-a-pdf/

I was able to recreate the issue here:

https://classtestbmcc.commons.gc.cuny.edu/2024/03/18/testing-hypothesis-on-pdf-commons/

The expected behavior of a public Commons site running hypothes.is plugin with annotation on media library PDFs enabled would be:

1. user uploads PDF to site media library
2. Insert PDF on page or post
3. Site visitor clicks PDF link from page/post
4. When PDF from media library opens, plugin adds "https://via.hypothes.is" prefix to PDF view and visitor is able to annotate.

I believe something might be going wrong in step #4. Is it possible the Commons is blocking the addition of the via prefix?

Thanks for looking into this!

Actions #1

Updated by Raymond Hoh 3 months ago

  • Category name set to WordPress Plugins
  • Status changed from New to Staged for Production Release
  • Target version set to 2.3.5

For step 3, the Hypothesis plugin is supposed to alter the PDF link so it points to via.hypothes.is. Then for step 4, when you click on the PDF link, Hypothesis will load. However, an update to the Hypothesis plugin broke how we detected Hypothesis before loading our custom PDF handler (see #9120).

I've just addressed this in https://github.com/cuny-academic-commons/cac/commit/c014555787a3d7fcc8d7309b12ffc5e13fa034b8 and pushed the fix to production.

Laurie, now when you go to the sample page -- https://classtestbmcc.commons.gc.cuny.edu/2024/03/18/testing-hypothesis-on-pdf-commons/ -- click on the "Observational Learning (Modeling)" PDF link and that should open Hypothesis.

Actions #2

Updated by Laurie Hurson 3 months ago

Thanks so much for looking into this, Ray.

I can see that it is working now -- great! Very important since many faculty are using this tool now.

Actions #3

Updated by Boone Gorges 3 months ago

  • Status changed from Staged for Production Release to Resolved
Actions

Also available in: Atom PDF