Project

General

Profile

Actions

Bug #2034

closed

Spacing issue on reply-by-email

Added by Matt Gold over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2012-08-10
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Please see the attached screenshots: the email I sent had a space between two words ("you're ready"), while the posted/emailed version did not.


Files

cac-rbe-original-email-sent.png (21.9 KB) cac-rbe-original-email-sent.png Matt Gold, 2012-08-10 05:44 PM
cac-rbe-posted-version.png (20.7 KB) cac-rbe-posted-version.png Matt Gold, 2012-08-10 05:44 PM
cac-rbe-emailed-notification.png (80.2 KB) cac-rbe-emailed-notification.png Matt Gold, 2012-08-10 05:44 PM
Actions #1

Updated by Boone Gorges over 10 years ago

Happened with me too, this time on hyphen-separated words.

I send all plain-text email, if it makes a difference.

Ray - let me know if you need to get the RBE log up and working to debug something like this.

Actions #2

Updated by Raymond Hoh over 10 years ago

This is probably happening because I try to get rid of line wraps caused by plain-text emails.

The character limit for that line must have been at the end of the word "you're". But when I strip the line wrap, I don't add back the space. Hence, the one-word discrepency.

Will look into it.

Actions #3

Updated by Matt Gold over 10 years ago

  • Priority name changed from Normal to Urgent
  • Severity changed from Normal to High impact

Thanks, Ray. I'm escalating this issue because it's really affecting the way that posts show up on the site. A message I just sent to a group comes out pretty garbled because of the spacing issue. Not sure why this didn't happen in all of our tests! Maybe because we didn't write long posts as tests?

Actions #4

Updated by Raymond Hoh over 10 years ago

Not sure why this didn't happen in all of our tests! Maybe because we didn't write long posts as tests?

We did use rather short sentences as tests. The other thing is I added the line-wrap stripping at the very last minute without asking the team to test!

This is to prevent posts like this:

It is a long established fact that a reader will be distracted by 
the readable content of a page when looking at its layout. The 
point of using Lorem Ipsum is that it has a more-or-less normal 
distribution of letters, as opposed to using 'Content here, 
content here', making it look like readable English.

So it looks like this:

It is a long established fact that a reader will be distracted by the readable content of a page when looking at its layout. The  point of using Lorem Ipsum is that it has a more-or-less normal distribution of letters, as opposed to using 'Content here, 
content here', making it look like readable English.

I've added a potential fix for the space issue on cdev. Please test on there and try to break it!

Boone, if you want to follow along, the issue on Github is here. Implementation is a little hacky and I'm thinking of removing it altogether.

Also I've noticed on the live site that email signatures are still leaking through. If you guys ever experience that, just forward the sent email to me or CC me on future responses so I can debug. Thanks!

Actions #5

Updated by Boone Gorges over 10 years ago

  • Target version changed from 1.4.1 to 1.4.2
Actions #6

Updated by Boone Gorges over 10 years ago

Just wanted to throw out a suggestion that, at least in the interim, we don't do anything about plain-text line breaks. If experience serves, most plaintext emails are going to come through at 80 or 100 characters wide, which may not be beautiful when it posts to forum, but won't be illegible. (FWIW, I think Github handles it this way.)

Actions #7

Updated by Matt Gold over 10 years ago

That makes sense to me, Boone, especially as a short-term, "good enough" solution. I'm worried about letting this problem go on for too long because I don't want people to lose confidence in RBE.

Ray, what do you think?

Actions #8

Updated by Raymond Hoh over 10 years ago

  • Status changed from Assigned to Resolved

Commit 81527f8 removes line-wrap stripping from plain-text emails.

Boone: RBE should be deactivated and reactivated on the next CAC version upgrade. I'll add the tidbit to the "ACTION_REQUIRED" wiki entry on CAC's Github repo. Is there anything special I should be doing in commit messages about this?

Actions #9

Updated by Matt Gold over 10 years ago

Thanks so much, Ray!

Actions #10

Updated by Boone Gorges over 10 years ago

Whoop, thanks a million, Ray!

I'll add the tidbit to the "ACTION_REQUIRED" wiki entry on CAC's Github repo. Is there anything special I should be doing in commit messages about this?

The wiki page is the main document I use when releasing. I usually cross reference against the commit log, grepping for the term ACTION_REQUIRED, so you're welcome to add the phrase (along with a description of the action) to the commit message for good measure. But it's redundant, as long as it's in the wiki page.

Actions

Also available in: Atom PDF