Project

General

Profile

Bug #2220

Spacing error on BP Doc comments

Added by Matt Gold almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority name:
Low
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-10-26
Due date:
% Done:

0%

Estimated time:

Description

Please see the attached screenshot, which shows a number of linked options under a comment made on a BP doc. They're all scrunched together with no spaces between words. Not sure whether regular users see this or only admins.


Related issues

Has duplicate CUNY Academic Commons - Bug #2221: Spacing error on BP Doc commentsDuplicate2012-10-26

History

#1 Updated by Boone Gorges almost 9 years ago

  • Target version set to 1.4.10

#2 Updated by Boone Gorges almost 9 years ago

  • Target version changed from 1.4.10 to 1.4.11

#3 Updated by Dominic Giglio almost 9 years ago

Matt,

I created a new group in my local env, then created a test doc so I could comment on it as the admin of both the group and doc.

I've attached a screenshot of what I see on my machine. It appears that these editing links actually get styled by some jQuery (technically Ajax Edit Comments). Can we confirm that this was a one-time error? Or is this happening repeatedly to one of our members (or you)?

If it happened only once, I would argue that there was a network error while loading the Ajax Edit Comments code. Which would prevent those links from being styled properly. If this is happening consistently then I can take a deeper look into Ajax Edit Comments to make sure there isn't a deeper issue at work.

#4 Updated by Matt Gold almost 9 years ago

Thanks, Dom. I can kind-of confirm this. Please see attached screenshot. Maybe I clicked "less options" (which should be "fewer options"!!) at one point?

#5 Updated by Dominic Giglio almost 9 years ago

That screenshot looks like you're viewing the comments for a doc on which you are not the "admin" or "creator."

You don't see the edit links unless you have the permissions to edit the doc. That's why I created a new group and a new doc so I knew that I'd be the owner of everything involved.

That link to more or less options is just a toggle that turns the dropdown on and off. It isn't a setting that determines what edit options will or will not be seen. Are you the creator of the doc in the most recent screenshot?

#6 Updated by Matt Gold almost 9 years ago

No, I'm not the creator of the doc but I am the admin of the group in which it was created.

#7 Updated by Dominic Giglio almost 9 years ago

Then I assume only the creator of the doc can see the edit links.

I'm gonna create a new doc in my local env as a different user and see if I can confirm this.

#8 Updated by Dominic Giglio almost 9 years ago

OK, here's what it comes down to.

As the admin of the group I can see the large grey edit button and the edit links on any and all comments across all docs. Which kinda makes sense for an admin. I'm not sure why, as an admin, you aren't seeing the edit links on the comment in your last screenshot.

When logged in as a "normal" test user I can't see any edit links or buttons on any docs at all.

So there is definitely some Roles and Capabilities code involved here. I jumped on this issue cause I thought I could help Boone out and take some more off his plate. But since he's the author of this plugin I think we should wait to hear what he thinks once he's got a chance to look at his CAC issues again.

#9 Updated by Matt Gold almost 9 years ago

okay. Just looked at a doc with comments in another group and can confirm that I see what's in the other screenshot -- just an edit button.

#10 Updated by Boone Gorges almost 9 years ago

  • Assignee changed from Boone Gorges to Dominic Giglio
  • Severity set to Low impact

The problem doesn't seem to have anything to do with roles. It appears that AEC is loading its js from a blank js file http://commons.gc.cuny.edu/files/aec/ajax-edit-comments.js?ver=5.0.7.0 (it exists, but is empty). I don't know why it has put its assets into the uploads folder instead of serving them out of wp-content/plugins like every other plugin in the world. In any case, it's having the practical effect of disabling the plugin on the production site.

Since it's not being used anyway, and since AEC is so old and buggy and unmaintained, let's go ahead and remove it.

#11 Updated by Matt Gold almost 9 years ago

Hi Boone - does that mean that users will no longer be able to edit their comments? I'm not sure that the issues I've identified here warrant the loss of that useful functionality.

#12 Updated by Boone Gorges almost 9 years ago

I think they'll still be able to edit the comments, but it will happen in the dashboard instead of the front end. But, as I note above, this is happening now anyway, because the plugin is broken.

If we really need the front-end comment editing functionality back, we will have to find a new plugin or write it ourselves.

#13 Updated by Matt Gold almost 9 years ago

Okay. Can you create an action reminder to check this functionality after the change is made on production? I don't think we need to worry about front-end editing, just that people do have the ability to edit.

#14 Updated by Boone Gorges almost 9 years ago

OK, I've made a note: https://github.com/castiron/cac/wiki/Release-ACTION_REQUIRED-list But again, I should underscore that removing the plugin will not affect normal WP comment editing one way or the other, since the plugin is currently non-functional.

#15 Updated by Matt Gold almost 9 years ago

Okay -- got it. thanks.

#16 Updated by Dominic Giglio almost 9 years ago

Boone, Matt,

Just wanted to update here quickly before I remove Ajax Edit Comments.

Aside from the Commons, there are 3 sites that have the plugin enabled:

http://globalization.gc.cuny.edu/
http://sciencestudies.gc.cuny.edu
http://keithmiyake.commons.gc.cuny.edu/

All three sites are running JetPack for commenting. I don't even see the Ajax Edit Comments script being loaded on their pages. Which leads me to believe that they've got the plugin enabled but aren't using it.

I wanted your feedback before yanking the plugin out from under them.

#17 Updated by Boone Gorges almost 9 years ago

Thanks for checking, Dom. Sounds like the plugin's not doing anything on their sites, so we're clear to remove it.

#18 Updated by Dominic Giglio almost 9 years ago

Thanks, removing now for 1.4.11 release.

#19 Updated by Dominic Giglio almost 9 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF