Project

General

Profile

Bug #2958

Commons Erroneous New Post Alert

Added by Marilynn Johnson almost 8 years ago. Updated almost 8 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2014-01-12
Due date:
% Done:

0%

Estimated time:

Description

Hi Commons Team,

The Philosophy EO pointed out to me that the Commons is automatically generating emails (below) indicating new posts when I edit posts or take them off the slider. I know I posted on Redmine about this a while ago and something was done but it seems to be cropping up again. Do you think there is anything that can be done to remedy this?

Thanks & Happy 2014!
Marilynn

---------- Forwarded message ----------
From: Vasiliou, Iakovos
Subject: FW: Philosophy Editor wrote a new blog post Noam Chomsky at Columbia 12/4-12/6 in the group Philosophy [CUNY Academic Commons]

By the way this sort of thing often happens with blog posts: they get resent out weeks or months after you originally posted them.

------ Forwarded Message
From: "Program in Philosophy Graduate Center, CUNY Commons" <>
Date: Sat, 11 Jan 2014 19:41:59 -0500
Subject: Philosophy Editor wrote a new blog post Noam Chomsky at Columbia 12/4-12/6 in the group Philosophy [CUNY Academic Commons]

Philosophy Editor wrote a new blog post Noam Chomsky at Columbia 12/4-12/6 in the group Philosophy

"NOAM CHOMSKY (MIT)
“What Kind of Creatures Are We?”

COLUMBIA UNIVERSITY
Department of Philosophy
DEWEY LECTURES
2013
Lecture One: “What is Language?”
December 4, 6:15-8:15pm
Faculty house

Lecture Two: “What Can We Understand?”
December 5, 6:15-8:15pm
Davis Auditorium, Schapiro Hall

Lecture Three: “What is the Common Good?”
December 6, 4:15-6:00pm
501 Schermerhorn

Reception to follow after each lecture."

To view or reply, log in and go to:
http://philosophy.commons.gc.cuny.edu/noam-chomsky-give-dewey-lectures-columbia-124-126-2/

---------------------
Your email setting for this group is: All Email
To change your email setting for this group, please log in and go to: http://philosophy.commons.gc.cuny.edu/wp-login.php?action=bpnoaccess&auth=1&redirect_to=http%3A%2F%2Fcommons.gc.cuny.edu%2Fgroups%2Fphilosophy-562225957%2Fnotifications%2F

To disable all notifications for this group, click: http://commons.gc.cuny.edu/members/ivasiliou/?bpass-action=unsubscribe&group=0&access_key=d6d67cfe5eea0cf8de07e8911af0f13b

------ End of Forwarded Message


Related issues

Related to CUNY Academic Commons - Bug #2564: Editing blog posts connected to groups creates activity item/notificationResolved2013-05-06

Related to CUNY Academic Commons - Support #5877: Group Sites -> Activity Stream LimitsResolved2016-08-08

History

#1 Updated by Matt Gold almost 8 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Matt Gold almost 8 years ago

#3 Updated by Boone Gorges almost 8 years ago

Adding Ray as a watcher. Ray, do you have any ideas about how to troubleshoot this, or any ideas about why this might be causing problems? Could it have something to do with the way that bp-groupblog changes the activity parameters of a groupblog activity item (groupblog_new_post, setting the component to 'groups', changing the item_id to the group id), so that the activity lookup in RBE fails?

#4 Updated by Raymond Hoh almost 8 years ago

I can only think of one scenario of how this could occur.

If the activity entry is deleted for the corresponding blog post in the BuddyPress group, but the blog post still exists. Then if someone edits the same blog post, a new activity entry is created in the BuddyPress group, hence creating a new activity entry and a new group email is sent via the Group Email Subscription plugin.

So let's say I created a new Noam Chomsky post on the groupblog, it created a corresponding activity entry in the Philosophy Commons group. For whatever reason, I did not like this activity entry in the Philosophy group, so I delete it. A few days later, I need to edit the Chomsky post and update the post. This will create a new activity entry into the Philosophy group and those subscribed to "All Mail" in the group will receive an email about this.

Does this sound like what happened?

#5 Updated by Matt Gold almost 8 years ago

Marilynn, have you, at any point in time, manually deleted activity items from the group activity feed?

#6 Updated by Marilynn Johnson almost 8 years ago

Hi Matt,

I think we may have figured it out! Yes, I have done sometimes deleted posts on the group page because I thought that maybe more people would post if it looked like a higher percentage of people who weren't me were posting. If you think this is the cause, I will not do it anymore. Should I just adopt this no-delete policy for now and let you know if this pops up still?

Thanks!
Marilynn

#7 Updated by Matt Gold almost 8 years ago

  • Status changed from Assigned to Rejected

Aha. Okay -- thanks for letting us know that, Marilynn. It sounds like this should not happen again if activity items are not deleted from the group feed. Can you please let Iakovos know that we think this is resolved?

Thanks, Ray, for helping us figure this one out!

#8 Updated by Marilynn Johnson almost 8 years ago

I emailed Iakovos. Thanks all for your help in solving this mystery.

Also available in: Atom PDF