Project

General

Profile

Bug #2686

Replying to Group Announcements

Added by Sarah Morgano almost 9 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2013-07-30
Due date:
% Done:

100%

Estimated time:

Description

I'm receiving forwarded messages from people who are replying to group announcements via email. I didn't think this was possible and just tested -- it isn't. It looks like you can't even reply to group announcements when you are logged into the Commons (I thought you used to be able to do that). That being said, our documentation says otherwise:

I'm not sure if announcements were originally set up for users to reply by email and directly through the group or if perhaps something changed along the way. I'd be happy to update the post/FAQ above, but first just want to clarify what is supposed to happen.

noreply.jpg (135 KB) noreply.jpg Sarah Morgano, 2013-07-30 06:55 PM

Related issues

Related to CUNY Academic Commons - Feature #3175: Replace Announcements with a force-email option on new forum postsResolved2014-04-25

History

#1 Updated by Raymond Hoh almost 9 years ago

Part of the problem of why the address is receiving a bunch of replies is related to #2685.

As for being able to reply to group announcements via email, this has always been the case. However, if we are stringent that group announcements shouldn't be replied to, we do need to fix this.

It also does sound like RBE should check the activity comment status before manipulating the email headers. So this is a legitimate bug for RBE.

Thanks for reporting, Sarah!

#2 Updated by Sarah Morgano almost 9 years ago

Wait, now I'm super confused! Are users supposed to be able to RBE to group announcements? Because right now they can't. They also can't reply when they are logged in to the group (screenshot attached).

#3 Updated by Matt Gold almost 9 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#4 Updated by Raymond Hoh almost 9 years ago

Just going to quote myself from my previous comment:

As for being able to reply to group announcements via email this has always been the case.

Users can't reply to group announcements on the website, but it's technically feasible for a user to reply to one via email if the user is subscribed to the "All Mail" option in the Group Email Subscription plugin. A group announcement is technically just a group status update so if a user is subscribed to "All Mail", RBE will kick in and manipulate the email.

#5 Updated by Sarah Morgano almost 9 years ago

Thanks for clearing that up for me, Ray. I think I was mostly confused by the fact that you could RBE, but not when you're logged in to the site.

#6 Updated by Boone Gorges almost 9 years ago

What do we want to be the case? It seems to me that, since we block activity comments on group announcements through the UI, we should also block RBE for this activity type as well. Ray, is that something we can easily do?

#7 Updated by Matt Gold almost 9 years ago

Boone Gorges wrote:

What do we want to be the case? It seems to me that, since we block activity comments on group announcements through the UI, we should also block RBE for this activity type as well.

Agreed

#8 Updated by Boone Gorges almost 9 years ago

  • Target version set to 135

#9 Updated by Sarah Morgano almost 9 years ago

Do you think we might be limiting group conversation by not having this feature through the UI? I'm not sure if it was decided at a certain point for members not to be able to reply to group announcements to keep conversations in the forums, but at one point we did allow this and IMO it makes sense to members to reply to announcements from group admins. That being said, I'm totally open to what the group wants.

#10 Updated by Matt Gold almost 9 years ago

the problem is that you then have conversations taking place in the activity stream and in the forum, which can be confusing -- people can remember that they replied to something but not where they did. I think our strategy is to channel everything to the forums. I hear you, though, that it's not a perfect solution, but I'm not sure that there is one here.

#11 Updated by Raymond Hoh almost 9 years ago

I just looked into this issue a bit more and it appears as though CAC has some custom code that disables commenting on group announcements.

In actuality, there are two Group Announcement plugins:

  1. The one used on CAC - there is custom code in the activity entry template that restricts group members from replying using a customized permissions function - cac_activity_can_comment(). This function shouldn't be used in the template, but rather we should hook onto the 'bp_activity_can_comment' filter instead
  2. The one available on CBOX - we do not restrict group members from commenting on group announcements

For the purposes of this ticket, I will do the recommendation I set out in point 1 and patch up RBE to check the activity comment status with bp_activity_can_comment().

However, what should we do for the group announcements plugin bundled with CBOX? Should we also restrict replies there as well?

#12 Updated by Boone Gorges almost 9 years ago

Thanks for digging deeper, Ray.

Your course of action for CAC sounds good. As for cbox, I think that since that functionality is meant to parallel the Commons, we should do the same there too.

#13 Updated by Matt Gold almost 9 years ago

I agree. Thanks, Ray.

#14 Updated by Boone Gorges almost 9 years ago

  • Target version changed from 135 to 1.5.1

#15 Updated by Boone Gorges almost 9 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

#16 Updated by Boone Gorges almost 9 years ago

  • Target version changed from 1.5.1 to 1.5.2

#17 Updated by Boone Gorges almost 9 years ago

  • Target version changed from 1.5.2 to 1.5.3

#18 Updated by Boone Gorges almost 9 years ago

  • Target version changed from 1.5.3 to 1.5.4

#19 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.4 to 1.5.5

#20 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.5 to 1.5.6

#21 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.6 to 1.5.7

#22 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.7 to 1.5.8

#23 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.8 to 1.5.9

#24 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.9 to 1.5.10

#25 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.10 to 1.5.11

#26 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.11 to 1.5.12

#27 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.12 to 1.5.13

#28 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.13 to 1.5.14

#29 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.14 to 1.5.15

#30 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.15 to 1.5.16

#31 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.16 to 1.5.17

#32 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.5.17 to 1.6

#33 Updated by Boone Gorges about 8 years ago

  • Target version changed from 1.6 to 1.7

#34 Updated by Raymond Hoh almost 8 years ago

  • % Done changed from 0 to 100

Boone, for 1.7.x, I've made the decision to remove the older cac-group-announcements plugin in favor of the one created for CBOX.

Check out these commits:
  • b10ac07 - Brings back bp_activity_can_comment for use in bp-nelo
  • dd72f9a - Adds the BP Group Announcements plugin

I haven't removed the older cac-group-announcements plugin yet, but it should be deactivated for 1.7 and later removed for 1.7.1.

#35 Updated by Boone Gorges almost 8 years ago

Awesome, thanks, Ray!

Can you say a little more about this? I assume that the important bit related to the above is bpga_can_post_group_announcements(). Is that new here, or does that exist in the cbox plugin? Just want to be clear how the problem is being solved here, and whether it needs to trickle elsewhere too.

#36 Updated by Raymond Hoh almost 8 years ago

bpga_can_post_group_announcements() already exists in the BP Group Announcements plugin.

The main decision for removing cac-group-announcements in favor of bp-group-announcements was to centralize the group announcement code into one place on CAC. Previously, I didn't know we had another group announcement plugin and had to do some backtracing to find out about cac-group-announcements.

Also, bp-group-announcements has more recent updates to it.

#37 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Resolved

Awesome. It sounds like this is done, then. Thanks, Ray.

Also available in: Atom PDF