Project

General

Profile

Actions

Bug #2728

closed

Positions Widget save problem

Added by Chris Stein almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2013-08-23
Due date:
% Done:

0%

Estimated time:
1.00 h

Description

When I try to add the Education widget there is a problem when saving the changes. See attached Screenshot for the error. Have tried three times and received it each time. I got the attached error Chrome on OSX. On Safari and Firefox the page just goes blank.


Files


Related issues

Related to CUNY Academic Commons - Bug #2730: Limits on Publications Entry FieldDuplicateBoone Gorges2013-08-24

Actions
Actions #1

Updated by Matt Gold almost 9 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Normal to High
  • Target version set to 1.5.1
  • Severity set to High impact
Actions #2

Updated by Boone Gorges almost 9 years ago

  • Target version changed from 1.5.1 to 1.5.0.2
  • Estimated time set to 1.00 h
Actions #3

Updated by Boone Gorges almost 9 years ago

  • Status changed from Assigned to Reporter Feedback

Chris, I'm unable to reproduce this. I've tried with a number of different browsers/OSes, a couple different users, and a variety of types of input for the education widget.

Can you give more details about what you're doing? During your edit session, are you attempting to edit anything aside from adding a new Education widget? How much text are you entering? If you could share the exact text you're attempting to enter, it might help to rule some things out.

Actions #4

Updated by Boone Gorges almost 9 years ago

  • Target version changed from 1.5.0.2 to 1.5.1

Moving to the next scheduled maintenance release pending feedback.

Actions #5

Updated by Chris Stein almost 9 years ago

Hi Boone,
I did a screencast of the problem. OSX 10.7.5, Chrome 29.0.1547.57

https://vimeo.com/73231530

Let me know if you need more. I will try to do it on windows later today.

Actions #6

Updated by Matt Gold almost 9 years ago

looks like the video may be private, Chris. Can you reset permissions? Thanks.

Actions #7

Updated by Chris Stein almost 9 years ago

Sorry, used to doing it for student videos. Public now

Actions #8

Updated by Matt Gold almost 9 years ago

So glad you reported this. I watched Steve Brier have this exact problem yesterday but haven't had a chance to report it. Think it may not be related only to the Education field (I believe Steve was trying to edit Publications)

Actions #9

Updated by Chris Stein almost 9 years ago

I have some updates on this problem.
  • I tried on a windows machine and had the same problem.
  • I tried with the teststudent account on my mac and did not have the problem.
  • So it appears that the problem is in the commons code and profile specific and not related to OS/browser.
  • I tried adding Publications and got the same problem
  • Then I noticed that College was still an option when I clicked Edit (screenshot attached) even though I had positions.
  • On a hunch I tried to add a position to test student (where education was already added). Positions did not work for teststudent (when you click Save Changes the screen goes blank).
  • Perhaps the issue is actually in the logic in the Positions widget? I haven't had time to look into the code but maybe the code that checks Position against College and Title is causing errors with saving the Profile.
  • To test out that assumption I removed Positions from my profile and then tried to add Education. I was able to do it without a problem.
Actions #10

Updated by Boone Gorges almost 9 years ago

Thanks for the additional testing, Chris.

I'm still not able to reproduce. You said that teststudent was not working - and I assume you're using cdev.gc.cuny.edu - but when I tried saving the profile with the Positions widget, it worked fine. Maybe I'm misunderstanding?

Actions #11

Updated by Boone Gorges almost 9 years ago

Not sure how much this has to do with it, but IE was having problems with much of the CSS and JS because I hadn't forced it into standards mode with a doctype. I've fixed it in https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/8184b154fa3a6085df167d9a9a9a0ae84dd65636

Actions #12

Updated by Chris Stein almost 9 years ago

Hi Boone,
I didn't use cdev, I was on the live site.

The problem exists with other widgets after you add the positions widget. So make sure there are no positions,education or publications widgets. THen add the positions and then try adding education or publications and you will have problems with those widgets. If you remove the positions widget you should be able to add them again without problem.

So the presence of the positions widget seems to be causing the problems with the other widgets.

Actions #13

Updated by Chris Stein almost 9 years ago

Just to be sure I went of cdev and when I had positions I could not add education. I removed positions and then was able to add education.

Actions #14

Updated by Boone Gorges almost 9 years ago

Hi Chris. I'm afraid I still can't reproduce. Steps:

1) As teststudent, go to commons.gc.cuny.edu/members/teststudent and click edit
2) Remove Positions and Education widget and save
3) Add Positions widget. Save. (no problem)
4) Add Education widget. Save (no problem)
5) Remove Positions and Educations widgets again, and save
6) Add both Positions widget and Education widget. Save. (no problem)

I've tried this on four different OS/browser combos, but still haven't made the problem happen. Am I misunderstanding your report?

Actions #15

Updated by Chris Stein almost 9 years ago

OK, I think I finally figured it out. It's input dependent. The official title of my department is "Media Arts & Technology" with the ampersand (we're designers OK). The ampersand is what causes the problem. I tried entering it as "Media Arts and Technology" and when I did that everything worked fine.

I tried the same thing with teststudent and had the same issue, once the department (forgot to try title too) had the ampersand, there were problems saving after editing other widgets.

Hopefully that's the problem as it should be easier to fix.

Actions #16

Updated by Boone Gorges almost 9 years ago

  • Subject changed from Profile Education Widget Problem to Positions Widget save problem

Thanks for the diligence, Chris. I think that's it.

If you care about the gory details, here's my comment on an existing WP ticket: http://core.trac.wordpress.org/ticket/11311#comment:14

Should be fixed by https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/398836301551a7a205de5ee44dd099c9d016f9f6 https://github.com/castiron/cac/commit/1e33b63bff33f99a8350cef4dbe95fb51b51ef16

Chris, can I ask you to give it another test on cdev?

Actions #17

Updated by Chris Stein almost 9 years ago

Great Boone, I tested on cdev and had no problems. It's interesting that it was a WP quirk that was the root cause. I agree with your comment that it's odd others haven't reported more similar issues. I guess it shows both that your code is still awesome and we're on the bleeding edge.

Not to be a downer after that, but should we do a separate ticket on College still appearing in the edit mode when position is present?

Actions #18

Updated by Boone Gorges almost 9 years ago

  • Status changed from Reporter Feedback to Resolved

Well, the WP bug was only part of the problem - I wasn't doing totally correct error handling, because I wasn't expecting WP to return such a dumb value :-/ In any case, glad to hear it's fixed, as it's definitely the most severe of the issues for this round.

Yes, let's do another ticket for the College thing. Would you mind opening it? Thanks again.

Actions #19

Updated by Matt Gold almost 9 years ago

Huge thanks to you both for your sustained work on this.

Boone, do you think that this is worth a hotfix? I do, but I defer to you.

Actions

Also available in: Atom PDF