Project

General

Profile

Bug #2792

.mp3 audio files not displayed in Jetpack

Added by Marilynn Johnson almost 6 years ago. Updated over 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2013-09-13
Due date:
% Done:

0%

Estimated time:

Description

Hello Commons Team!

I'm having issues with my .mp3 audio files again. I think this is a Jetpack related issue. Normally audio files display as a gray play button within the text but now it either shows "<a" or "download file". It is an issue that is cropping up across themes - on both my philosophy commons website and on faculty websites I helped make. I'm asking because I also had a student ask me about posting .mp3s of some radio shows he'd recorded on the commons and when I went to show him how easy it was I encountered this problem. Please check this out when you get a chance. Thanks! Marilynn

Example of problem on Philosophy Commons: http://philosophy.commons.gc.cuny.edu/godfrey-smith-podcast-how-do-octopuses-think/
Example on faculty website (below videos): http://neale.commons.gc.cuny.edu/media/

History

#1 Updated by Matt Gold almost 6 years ago

  • Category name set to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges almost 6 years ago

  • Target version set to Not tracked

Hi Marilynn. A couple things are happening here.

First, it looks like you were copying a hyperlink into the [audio] shortcode, rather than a plain URL. So the shortcode ended up looking like this

[audio src="<a href="http://traffic.libsyn.com/philosophybites/Stephen_Neale_on_Meaning_and_Interpretation.mp3" target="_blank">http://traffic.libsyn.com/philosophybites/Stephen_Neale_on_Meaning_and_Interpretation.mp3"</a>]

rather than the correct

[audio http://traffic.libsyn.com/philosophybites/Stephen_Neale_on_Meaning_and_Interpretation.mp3]

It'd be nice if WP were smarter about how this works, but in the meantime, just be careful about your copying and pasting - and maybe consider using the HTML rather than the Visual tab for creating theses shortcodes.

The other issue - of the "Download File" link appearing rather than the player - appears to be browser-related. If you're using an unaltered version of Firefox, files that use proprietary codexes (like mp3) do not play natively; Mozilla does not include these drivers because of their licenses. So you see the Download File link instead. The player seems to be working fine in the case of other browsers (Chrome, Safari, etc).

Have a look around and see if it's working correctly for you.

#3 Updated by Marilynn Johnson almost 6 years ago

Hi Boone,

Thanks for getting back to me on these questions. The strange thing about this issue is that both audio files displayed properly when I first posted them (until a few weeks ago). The Neale one is working now -- were you able to change the code for me? I am using Firefox to view the Site -- and the audio files were working fine in this browser until recently. Is there another option I can try for audio files that will work in all browsers? I think a good number of visitors to my site use Firefox.

Thank you!
Marilynn

#4 Updated by Marilynn Johnson almost 6 years ago

Hi Boone,

Sorry I also am not understanding why the audio file with the same coding works on the Neale page but not on the Commons page (in Firefox). Can you help me understand this?

Thanks for your help!
Marilynn

#5 Updated by Boone Gorges almost 6 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, could I ask you to take a look at this? I have spent a bunch of time trying to figure out the difference between the embeds on the two pages above, but I keep hitting a wall. It seems to me that Firefox should be falling back on the Flash player when the native .mp3 codec is not present, but that doesn't seem to be happening.

#6 Updated by Raymond Hoh almost 6 years ago

The Philosophy page fails for me because the link to the media item appears to be incorrect.


The Neale page works on Firefox for me, but that's b/c my OS (Windows 8) supports playing MP3s natively. As of Firefox 21, MP3 audio will play using HTML5 if your OS already supports the format. I think this is for Windows and Linux only, but I might be wrong.

From looking at the mediaElement JS page, it sounds like the JS should provide MP3 fallback support to Firefox with Flash 9+. If there's no Flash though, the link to the media item will be served.

So the first thing to check is the version of Firefox that you're using. If you're using an older version of Firefox, upgrade to the newest version.

Secondly, check if Flash is enabled on Firefox.

Also, test the audio demo on the mediaElement JS site. (The audio demo should be the one below the video.)

#7 Updated by Boone Gorges over 5 years ago

  • Status changed from Assigned to Reporter Feedback

Hi Marilynn - Just circling around to this old ticket. Are you or your users still having difficulties with these embedded files? I wonder if it was just a quirk of the particular computer you were using (which perhaps had neither the mp3 codec nor Flash). Or can we close this issue as resolved for the moment?

#8 Updated by Marilynn Johnson over 5 years ago

Hi Boone,

Thank you for checking in on this. The issue is not resolved -- at least not as I can see on my computer. I tried the following page in Firefox (recently updated) and Internet Explorer and it did not work still. http://philosophy.commons.gc.cuny.edu/audio-stephen-neale-metaphysics-aphonics-implicit-reference-institute-philosophy/ I got a little lost in the jargon above -- it would be nice to get it working. Does the link above work for you (to stream in the page)?

Thanks,
Marilynn

#9 Updated by Boone Gorges over 5 years ago

Thanks, Marilynn. I noticed that, at least on my machines, the player was appearing for a moment before being replaced with the 'Download File' link. After some digging, it turned out that the Mediaelement.js WP plugin was causing some sort of conflict. I disabled it, and now the player is loading properly in most browsers (the exception being FF when I don't have Flash or MP3 support). Can you have another look please?

#10 Updated by Marilynn Johnson over 5 years ago

Hi Boone,

It works perfectly for me now! Thanks for the fix!

Marilynn

#11 Updated by Boone Gorges over 5 years ago

  • Status changed from Reporter Feedback to Resolved

Woo hoo! Thanks, Marilynn.

Also available in: Atom PDF