Project

General

Profile

Design/UX #3843

My Commons Tab Color

Added by Samantha Raddatz about 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Design
Target version:
Start date:
2015-02-26
Due date:
% Done:

0%

Estimated time:

Description

The My Commons tab color being blue does help differentiate it from the other tabs, but makes it unclear to users if it's part of the navigation or a label/header. It's also unclear to users when they're within the MyCommons tab because the color of the tab doesn't change.

I recommend changing the tab color to match the others, both in general and when user is using the My Commons section.

History

#1 Updated by Matt Gold about 4 years ago

Maybe we should go from blue/black to white and gold

#2 Updated by Matt Gold about 4 years ago

Bad #TheDress jokes aside, I'm fine with what you suggest here, Sam

#3 Updated by Boone Gorges about 4 years ago

  • Category name set to Design
  • Assignee changed from Boone Gorges to Daniel Jones

#4 Updated by Daniel Jones about 4 years ago

So I can turn off the blue color pretty easily, but it'll be a little more work to get it to behave like the other tabs when it's the page users are on. It doesn't get the "current-menu-item" class added to it right now when it's the current menu item. Best I can tell it's because Buddypress uses 'actions' to figure out what the current menu item is, and My Commons isn't hooked up to an 'action'.

Is that right Boone? I think I could handle this with some of my own PHP but want to check to see if there's a way you think would be best.

#5 Updated by Daniel Jones about 4 years ago

Oh wait! I'm also just realizing that My Commons doesn't work on my local install, which might actually be the issue. I get a "Page not found" error when I go to it. Maybe if I was actually on the page it would work. I committed the simple CSS change I made now in case it's enough: https://github.com/cuny-academic-commons/cac/commit/fae6215c0f9d6776d38910b85e7b8ad4c8dbd025

#6 Updated by Boone Gorges about 4 years ago

  • Status changed from New to Assigned

Thanks, Dan. This doesn't appear to work, though - current state highlighting ('current-menu-item') is not working. You may need to filter something to make it work. Check out `wp_nav_menu()` for appropriate filters (and `cac_is_my_commons()` for a reliable way to check).

If you're not seeing My Commons on your installation - or really anytime you see a mismatch between your local and production that's related to the database state - you may want to check https://github.com/cuny-academic-commons/cac/wiki/Release-ACTION_REQUIRED-list. This is a list of database tasks I perform on releases. In this case, there is a task under 1.7 that you shoudl be able to reproduce locally to get things up and running.

#8 Updated by Daniel Jones about 4 years ago

Thanks for pointing me in the right direction, you two! Here's the changeset: https://github.com/cuny-academic-commons/cac/commit/3bbd2f08341152e529aad96e44bb818d6a2c2b3f

#9 Updated by Boone Gorges about 4 years ago

  • Status changed from Assigned to Resolved

Looks great - thanks!

Also available in: Atom PDF