Project

General

Profile

Bug #3892

The given object ID is not that of a menu item.

Added by Gina Cherry almost 4 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2015-03-09
Due date:
% Done:

0%

Estimated time:

Description

I attempted to add an item to my site menu. When I saved the menu, the system generated a series of the error message, "The given object ID is not that of a menu item." and wiped out almost my entire site menu (everything except the About Us menu and one of the blog categories). I have successfully reconstructed part of the menu and continue to work on it this afternoon.

History

#1 Updated by Matt Gold almost 4 years ago

  • Category name set to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

Hi Gina -- can you please let us know the site involved and what theme you are using? Thanks.

#2 Updated by Gina Cherry almost 4 years ago

Matt Gold wrote:

Hi Gina -- can you please let us know the site involved and what theme you are using? Thanks.

This is the ACERT site: acert.hunter.cuny.edu. We are using the Canvas theme.

#3 Updated by Boone Gorges almost 4 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, have you seen this problem before? Could I ask you to try to reproduce? It could have something to do with some theme/plugin combo in use on acert.hunter.cuny.edu.

#4 Updated by Boone Gorges almost 4 years ago

  • Target version set to 1.7.17

#5 Updated by Raymond Hoh almost 4 years ago

I did some research and it looks like this bug can be triggered when editing a menu that already has a ton of items in it.

This WP ticket is the one to keep an eye on:
https://core.trac.wordpress.org/ticket/14134#comment:149

I would suggest deferring this ticket until the WP issue is resolved.

#6 Updated by Boone Gorges almost 4 years ago

  • Status changed from Assigned to Hold

Ugh, one of my least favorite WP bugs. I agree with Ray's suggestion. Let's hold on this to see what comes out of the WP discussion.

#7 Updated by Boone Gorges almost 4 years ago

  • Target version changed from 1.7.17 to Future release

#8 Updated by Raymond Hoh over 2 years ago

  • Status changed from Hold to Reporter Feedback
  • Assignee changed from Raymond Hoh to Gina Cherry

Looks like the WP bug I referenced in comment 5 was fixed in WP 4.5, which we currently have installed on the Commons.

Gina, are you still able to duplicate this bug?

#9 Updated by Gina Cherry over 2 years ago

I only encountered the issue the one time that I reported it. Then again, I have not been making many changes to the navigation menu.

#10 Updated by Raymond Hoh over 2 years ago

  • Status changed from Reporter Feedback to Resolved

I only encountered the issue the one time that I reported it. Then again, I have not been making many changes to the navigation menu.

Thanks for replying, Gina.

I'm going to close this one for now. If the problem persists, feel free to reopen.

Also available in: Atom PDF