Project

General

Profile

Actions

Bug #3926

closed

White screen after publishing post

Added by Sarah Morgano over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2015-03-19
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Luke Waltzer just reported that after he published http://dhpraxis14.commons.gc.cuny.edu/2015/03/19/state-of-your-projects/ he got a white screen.

He said that the post published okay, but he had to back out of the screen to get back into his admin. Not sure if this is a bug or caching issue.

Computer details attached.


Files

export.pdf (14.3 KB) export.pdf Sarah Morgano, 2015-03-19 11:40 AM

Related issues

Has duplicate CUNY Academic Commons - Bug #3935: Member consistently gets blank page.php when saving postsDuplicateBoone Gorges2015-03-20

Actions
Actions #1

Updated by Matt Gold over 7 years ago

  • Category name changed from Blogs (BuddyPress) to WordPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
Actions #2

Updated by Matt Gold over 7 years ago

I've made Luke a watcher here

Actions #3

Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Not tracked

Thanks for the report. A fatal error is being caused by the fact that the BP Widget Cache plugin was deactivate (http://redmine.gc.cuny.edu/issues/3917#note-2) but is called directly from our Recent Blog Posts widget code. In the future, we should probably convert this to a hook, but in the meantime I've reactivated the plugin so there are no more errors of this type.

Actions #4

Updated by Matt Gold over 7 years ago

Thanks for fixing this, Boone and thanks for the report, Luke!

Actions #5

Updated by Raymond Hoh over 7 years ago

  • Target version changed from Not tracked to 1.7.16

In the future, we should probably convert this to a hook, but in the meantime I've reactivated the plugin so there are no more errors of this type.

The future is now :) Forgot to add a check for BP Widget Cache in our custom cache invalidation code. This was my fault when I initially wrote the code to invalidate the widget cache for blog posts.

Fixed in commit 70f4195.

Actions

Also available in: Atom PDF