Project

General

Profile

Bug #3964

"There was a problem..." error when posting Group Announcement

Added by scott voth over 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Announcments
Target version:
Start date:
2015-04-01
Due date:
% Done:

0%

Estimated time:

Description

Hi - Commons member Shawn McGinniss reports an issue with posting group announcements: "I encountered an error today while trying to post an announcement which reads, 'There was a problem posting your update, please try again' in a red bar above the text entry box on the Announcements page. The error is the same across browsers and occurs whether or not the box is checked to email the announcement to all members of the group. "

This is Zendesk issue #257 which also includes a screenshot. Thanks.

shawn.jpg (133 KB) shawn.jpg scott voth, 2015-05-10 12:39 PM

Related issues

Related to CUNY Academic Commons - Bug #3856: Admin can't post announcementResolved2015-02-27

History

#1 Updated by Boone Gorges over 6 years ago

  • Subject changed from Possible problem with Group Announcements to "There was a problem..." error when posting Group Announcement
  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, could you have a look to see if you could reproduce?

#2 Updated by Matt Gold over 6 years ago

Just want to note that this is the second report of this error. Please see http://redmine.gc.cuny.edu/issues/3856

#3 Updated by scott voth over 6 years ago

Hi -
Shawn experienced this issue again. See attached screenshot.

#4 Updated by Raymond Hoh over 6 years ago

  • Target version set to 1.8.1

I could not duplicate the problem.

However, I do see one potential issue. If Shawn had a ton of browser cookies when attempting to post the group announcement, this could have led to the error. (This is similar to a bug I reported to BuddyPress, which was fixed awhile ago.)

Our custom email announcement code has a similar problem. I've added a commit to fix this, but am unsure if this will address this issue 100%.

If someone encounters this problem again, can the person to do the following?

In Firefox:
1. Before posting the announcement, open up the Web Console (the easiest way to do this is by right-clicking on the page and selecting "Inspect Element")
2. Next, click on the "Network" Tab.
3. Click on the "Post Update" button to attempt to post the announcement. An entry will be listed in the "Network" tab. Click on it.
4. This will open a side window with a bunch of information. Click on the "Params" tab and list the information.

I've attached an animated GIF detailing this process in Firefox as well:

I can write up a similar tutorial for Chrome if needed.

#5 Updated by Boone Gorges over 6 years ago

  • Target version changed from 1.8.1 to 1.8.2

#6 Updated by Boone Gorges over 6 years ago

  • Target version changed from 1.8.2 to 1.8.3

#7 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.8.3 to 1.8.4

#8 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.8.4 to 1.8.5

#9 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.8.5 to 1.8.6

#10 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.8.6 to 1.8.7

#11 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.8.7 to 1.8.8

#12 Updated by Boone Gorges about 6 years ago

  • Status changed from New to Resolved

Given the number of punts here, and the lack of further reports, I'm going to mark this one resolved. Please reopen if there are still problems.

#13 Updated by Boone Gorges almost 6 years ago

  • Status changed from Resolved to Assigned
  • Assignee changed from Raymond Hoh to Boone Gorges
  • Target version changed from 1.8.8 to 1.8.17

I got a private report from another user about this. The user provided me with details about the content of the announcement, and I was able to reproduce the issue. It turns out that including too many links trips the bp_core_check_for_moderation() flag (first time I have ever seen this function!!)

I'm going to disable the max_links check for the Commons, as I think we trust our users not to be link farmers.

#14 Updated by Boone Gorges almost 6 years ago

  • Category name changed from BuddyPress (misc) to Group Announcments
  • Status changed from Assigned to Resolved

It turns out not to be easy to disable the max_links check alone for a given type of activity, so I've disabled all automated moderation for group announcements https://github.com/cuny-academic-commons/cac/commit/d52bd5213bae2f1c807349dc5fd232ad1d616193 It's not a very good feature of BP anyway.

This is deployed as a hotfix, as it was easiest to debug there.

#15 Updated by Raymond Hoh almost 6 years ago

It turns out that including too many links trips the bp_core_check_for_moderation() flag (first time I have ever seen this function!!)

Related: https://buddypress.trac.wordpress.org/ticket/6719 :)

Also available in: Atom PDF