Project

General

Profile

Bug #4011

Captcha Loop

Added by Marilynn Johnson over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2015-04-21
Due date:
% Done:

0%

Estimated time:

Description

Hi Redminers,

I am currently trying to log in to edit my commons page and am stuck in a loop where I am shown the message 'Please solve this math problem to prove that you are not a bot. Once you solve it, you will need to log in again.' After I do this, the whole process repeats, without me ever succeeding in logging in. I've gone through this five or six times, doing the math problem, trying to log in again, and getting the math problem again. How can I end this loop?

I am trying to edit information about the philosophy graduate conference which begins on Friday so really want access to my site asap.

Thanks for your attention to this!

~Marilynn
Philosophy Social Media Fellow


Related issues

Has duplicate CUNY Academic Commons - Bug #4013: Math question?Duplicate2015-04-22

History

#1 Updated by Matt Gold over 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges over 6 years ago

  • Status changed from Assigned to Reporter Feedback

Hi Marilynn,

Can you please give more details, including URLs, about exactly what you're doing? The Commons does not have any general CAPTCHA enforcement anywhere that I know of, so this must be something that you've put in place with a plugin. But it's not clear to me how or why a plugin would require a CAPTCHA for a logged-in administrator who is editing a page through the admin interface.

#3 Updated by Matt Gold over 6 years ago

Hi Boone --

This might not be relevant, but aren't we now enforcing CAPTCHA on forms through Daniel's code?

#4 Updated by Boone Gorges over 6 years ago

Only on contact form submissions when using a very specific plugin. Marilynn's problem appears to be unconnected, but I would need to know more details about what she's doing to know for sure.

#5 Updated by Raymond Hoh over 6 years ago

Looks like this is caused by Jetpack's Protect module:
https://github.com/Automattic/jetpack/blob/3.4.3/modules/protect/math-fallback.php#L59

Perhaps try disabling that module within the Jetpack plugin?

#6 Updated by Matt Gold over 6 years ago

Thanks, Ray. Marilynn, can you please give Ray's suggestion a try and let us know whether that solves the problem?

#7 Updated by Boone Gorges over 6 years ago

Thanks, Ray. See also #4013.

This is pretty infuriating. Jetpack auto-activates new modules. In this case, it introduced the Protect module, which ended up being auto-activated on any of our sites running Jetpack. For some reason that I haven't yet determined, the module is not properly working. So all of the sites running Jetpack on the Commons were silently infected with this bug. I have force-deactivated Protect on all Commons blogs in https://github.com/cuny-academic-commons/cac/commit/fbd24b70d8fdeafcdc0ae19f1312373437c2db92. At some point, I may try to figure out why the protection isn't working. At some point, we should also install something that prevents Jetpack from auto-activating new features, as it's quite obnoxious for it to do so.

Marilynn, can you please verify that you're now able to log in? Thanks.

#8 Updated by Matt Gold over 6 years ago

Yikes. Thanks for figuring this out, Boone.

#9 Updated by Marilynn Johnson over 6 years ago

Hi,

Yes, I am able to log in now! Thank you all for figuring out the problem.

~Marilynn

#10 Updated by Boone Gorges over 6 years ago

  • Category name set to WordPress Plugins
  • Status changed from Reporter Feedback to Resolved
  • Target version set to 1.7.20

Great! Thanks for reporting back.

#11 Updated by Marilynn Johnson over 6 years ago

Hi again Boone,

I am trying to update my site philosophy.commons.gc.cuny.edu again and am having the same captcha loop struggles I described here a month ago. Any help to get past it would be great.

Thank you!
Marilynn

#12 Updated by Boone Gorges over 6 years ago

Sorry about the issue, Marilynn. The previous fix got lost in a bad merge. It should be fixed again.

Also available in: Atom PDF