Project

General

Profile

Bug #4405

New portfolio text not saving

Added by Matt Gold over 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Public Portfolio
Target version:
Start date:
2015-08-08
Due date:
% Done:

0%

Estimated time:

Description

I'm trying to save some new info in my portfolio. I enter the text in the Publications section and then click save. I see the info in the box after that, but when I save the changes to my profile, the information disappears. Maybe I'm running into a word-count limit? Screenshot attached

Screen Shot 2015-08-08 at 8.38.55 AM.png (144 KB) Screen Shot 2015-08-08 at 8.38.55 AM.png Matt Gold, 2015-08-08 08:41 AM
mkgold-info.txt (3.51 KB) mkgold-info.txt Matt Gold, 2016-03-28 11:14 AM
Screen Shot 2016-04-02 at 10.04.14 AM.png (282 KB) Screen Shot 2016-04-02 at 10.04.14 AM.png Matt Gold, 2016-04-02 10:09 AM

Related issues

Related to CUNY Academic Commons - Bug #3814: Strange profile behaviorResolved2015-02-14

Related to CUNY Academic Commons - Bug #5406: Pasted portfolio widget content does not retain spacingResolved2016-04-04

History

#1 Updated by Matt Gold over 3 years ago

Actually, I can't seem to change ANY changes to that section . . .

#2 Updated by Boone Gorges over 3 years ago

  • Status changed from Assigned to Reporter Feedback

It's possible that this is due to some incompatible markup in the text you're trying to save. See #3275, #3814.

A couple questions and things to try:

1. When attempting to modify your Publications, open your browser console. Do any JavaScript errors appear there, especially when clicking "OK" to exit "edit mode"?
2. Are you writing the Publications section in the browser, or are you pasting it in from another application? If so, which application? What happens when you first paste it into a plaintext editor, and then reapply formatting in the browser?
3. Can you share the full content you're trying to use? Ideally, this would be in the original format you're using (say, .docx, if that's what you're starting with).

#3 Updated by Boone Gorges over 3 years ago

  • Target version set to Future release

We'll move this back into a milestone when we track down the issue more clearly.

#4 Updated by Matt Gold almost 3 years ago

Hi Boone,

Sorry it took me so long to get to this. I am not writing directly into the box but I am pasting. Did not see any javascript errors in the console when saving.

Here is what I did:
  • copied text from my webpage - http://mkgold.net/research/
  • pasted it into TextWrangler
  • pasted it into the editing box on the Commons
  • hit OK
  • saved the profile

The result is a mishmash of text that doesn't recognize formatting/spacing

I've attached a text file with the info I'm trying to paste in. Thanks for your help with this.

#5 Updated by Boone Gorges almost 3 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from Future release to 1.9.12

Thanks for the detailed steps to reproduce, Matt. Your problem is due to br tags being stripped, which in turn is caused by a recent change to the way that BuddyPress sanitizes xprofile fields. Fixed in https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/990544e2bbe9d41d75217558d198fd85baa43294.

This is not exactly the problem the ticket was originally meant to address, but given that you're not having that problem anymore, I think we can mark this ticket as resolved.

#6 Updated by Matt Gold almost 3 years ago

Thanks, Boone! Looking forward to seeing the fix on the production server

#7 Updated by Matt Gold almost 3 years ago

Hi Boone,

Just tried to update my profile following the fix.

Here's what is happening:

-- spacing is still a bit messed up; the spacing I see between lines in the editing box (see screenshot) is getting collapsed when I save

-- some weird stuff is going on with italics; I tried to italicize book/journal titles. When I did so, about half of the whole text wound up being italicized -- it seems like there is an unclosed tag somewhere

Some notes: I was pasting from the plain-text file (opened in TextEdit on a Mac) that I attached earlier this this message; when I was starting, I deleted all existing text, saved, and then entered edit mode and pasted; I had Firebug console open and did not see any javascript errors

#8 Updated by Matt Gold almost 3 years ago

Sorry -- forgot to attached a screenshot

and here's a link to my profile - http://commons.gc.cuny.edu/members/admin/

#9 Updated by Boone Gorges almost 3 years ago

Thanks, Matt. I have opened two new tickets to discuss these issues: #5406, #5407

#10 Updated by Matt Gold almost 3 years ago

Thanks!

Also available in: Atom PDF