Project

General

Profile

Bug #442

Members settings reset

Added by Sarah Morgano over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2010-12-07
Due date:
% Done:

0%

Estimated time:

Description

I was approached by two members of the Academic Commons who joined groups and added friends, but are not showing up under their profile.

Ellen Smiley is still receiving email notification from the Committee on Academic Technology group, but she is not listed as a member although she joined back in September. As a short term fix I told her to re-request membership to the group and check her notification settings once she's listed as a group member. I remember her being listed as one of my friends, but I recently sent another friend request because she wasn't listed as a friend.

B. Loerinc Helft is also experiencing problems with her account. She joined over a year ago and signed up for a couple of groups back in September, but stopped receiving notifications and now she is not listed as a member of the groups that she joined.

Neither of the members did anything drastic to their accounts so I'm not sure why their settings have been reset and one is still receiving group notifications while the other is not. I told them that I would create a ticket on here and reach out to them if we needed additional information or screenshots for troubleshooting purposes.
-Sarah

History

#1 Updated by Boone Gorges over 11 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Normal to High

The email notification thing is described here: #441 It will be fixed in 1.1.1. (Though your advice to rejoin the group and change the settings will work too. Actually just joining and then leaving the group would do it.)

I'll look into the others. I can't imagine that those problems were caused by the 1.1 upgrade, though it's possible.

#2 Updated by Sarah Morgano over 11 years ago

Hi Boone,

I will instruct them to request membership again to the groups they want to participate in. As a note, these problems existed before the 1.1 upgrade.

Best,

Sarah

#3 Updated by Boone Gorges over 11 years ago

  • Status changed from Assigned to Resolved

Hi Sarah,

I looked a bit deeper into the data issues.

B. Loerinc Helft is only a member of one group, "SPS Online Baccalaureate – Capstones", of which she is the admin (and which has apparently not been active since 10-5-2009). If somebody is kicked out of a group, that information remains in the database; I don't see any instances where she is listed as having been kicked out. So that leaves a few possibilities: (1) she manually left those groups at some point and is now misremembering; (2) a bug allowed her to reject an invitation for a group she had already joined (which has the effect of deleting the group membership); (3) an admin (me or Matt) removed her from groups manually; (4) there has been data loss in the system. (3) seems unlikely because this is the first I've heard of the problem, and because the entire database rows are missing rather than corrupted. (4) seems unlikely too - I personally have never used our group management tool to remove a member from a group on the production site. So my guess is that it's either (1) or (2), and in the case of (2) I can't do much troubleshooting since there is no trace of the error.

As for Ellen: I only see one friendship between the two of you, begun on Dec 4. I've traced back through the site's activity stream and I don't see anything abnormal (like multiple friendship notices for the two of you). By best guess is that this is another case where there was no software problem, but perhaps something being misremembered (you never had a friendship before 12/4) or a usability problem (you thought you'd initiated a friendship from what you saw in the UI but it actually hadn't happened).

I'm sorry I'm unable to come up with more definitive answers. I'm going to close the ticket, but please feel free to reopen it if you scrounge up more details that might shed some light.

#4 Updated by Matt Gold over 11 years ago

  • Status changed from Resolved to Assigned

Reopening this ticket with new information from George:

"There are some inaccuracies in Boone's update. For instance, B is a member of CAT (and the CAT group on the Commons). I invited and confirmed her
membership some time ago, but never modified it or deleted it or whatever. So the identification of her as a member of only one group (the SPS
capstones group) isn't right. The provocation for her communication is that she hasn't been receiving anything from the CAT group (including that
lively discussion you and Joe and Chris and Mike are engaged in)."

#5 Updated by Boone Gorges over 11 years ago

Be that as it may, the story told by the database is this. B is listed as being a member of only one group, the SPS Capstones group. I can't find her in the member list for the CAT group, either in the group listing http://commons.gc.cuny.edu/groups/cuny-committee-on-academic-technology-62702785/members/ or when I query the database directly. The version of the Commons database that I have on my computer is several months old (five or six, I would guess), and the same is true of that old snapshot: B is only a member of that single group. So whatever happened to her account, it happened quite some time ago.

Is it possible that B has more than one Commons account, and that I'm looking at the wrong one?

I am a bit perplexed by the email notification bit, though. Given that, according to my research, B has not been in the CAT group for some time, I'm not sure how it would have been the case that she was receiving email updates before the 1.1 upgrade.

If anyone has any ideas, I'd be happy to hear them.

#6 Updated by Boone Gorges over 11 years ago

  • Target version changed from 1.1.1 to 1.1.2

#7 Updated by Matt Gold over 11 years ago

Sent two docs by email -- one showing a confirmation message the member had received when she was accepted to the CAT group, and one other message notification.

#8 Updated by Boone Gorges over 11 years ago

  • Target version changed from 1.1.2 to 1.1.3

#9 Updated by Boone Gorges over 11 years ago

  • Status changed from Assigned to Resolved

Closing this ticket because I believe that the issue has been more or less resolved in the particular cases at hand. For more general discussion, please open another ticket.

Also available in: Atom PDF