Project

General

Profile

Bug #449

WooThemes displaying category list in nav

Added by Matt Gold over 11 years ago. Updated over 11 years ago.

Status:
Rejected
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2010-12-08
Due date:
% Done:

0%

Estimated time:

Description

I've noticed that several of the new WooThemes we installed with 1.1 are having some odd problems. Notably, themes such as Headlines (to take one example among many) seem to add a list of categories at the top of the main section of the page. On a blog like the News blog, which has hundreds of categories, this makes the theme unusable.

I tried to play with the theme settings to take out the appearance of categories, but I didn't see a way to do it, so I'm thinking that we may have to hack this theme (and other WooThemes) if we want this to work.

Chris, I was wondering whether you might be able to take the lead on this. If you could create a test blog and go through some of the WooThemes (many of the problems are apparent on preview) and work towards some solutions, I would appreciate it.


Related issues

Related to CUNY Academic Commons - Bug #474: Navigation Bar in WooThemesRejected2010-12-13

History

#1 Updated by Boone Gorges over 11 years ago

Please do troubleshoot, but please report back before hacking any themes and committing the changes. Some may be fixable without modifying the theme files, which is highly preferable.

#2 Updated by Sarah Morgano over 11 years ago

Should we wait to post about the WooThemes until this is resolved?

#3 Updated by Boone Gorges over 11 years ago

  • Target version changed from 1.1.2 to 1.1.3

#4 Updated by Boone Gorges over 11 years ago

  • Target version changed from 1.1.3 to 1.1.4

#5 Updated by Boone Gorges over 11 years ago

  • Subject changed from WooThemes Troubleshooting to WooThemes displaying category list in nav

Changing the title of this ticket because you only specify a single bug. If you have other issues with these themes, please open separate tickets so that we can keep track.

#6 Updated by Boone Gorges over 11 years ago

  • Status changed from Assigned to Rejected

By default, many of these themes use categories as their secondary nav (pages are generally the primary nav). You can override the default by using WP's menu system. Dashboard > Appearance > Menus

From the codex: http://codex.wordpress.org/Appearance_Menus_SubPanel

When creating a menu, be sure to set the menu as the active menu for the relevant Theme Location (upper left of the Menus panel).

This is a documentation issue. What we need are good docs (and pointers to docs) on the Commons codex, FAQ page, etc.

#7 Updated by Matt Gold over 11 years ago

I hear you, but I'd say it's not purely a documentation issue, in part because it's very hard to connect people to documentation at the moment when they are choosing and previewing themes. If they preview a theme and see that it is borked, they are unlikely to spend lots of time exploring the Codex to figure out what is wrong; they'll often just choose a different theme.

I was going to suggest that we think about creating some kind of plugin that would add text to the dashboard theme chooser that would point people towards help resources around picking themes, but I suppose that we can/should wait until WP's new theme chooser is in place in the next version.

#8 Updated by Boone Gorges over 11 years ago

Yes, it's worthwhile to wait until the 3.1 theme picker before we start customizing anything.

In any case, I closed the ticket because the issue originally reported is not a bug with the themes. They are behaving as intended.

Also available in: Atom PDF