Project

General

Profile

Bug #5221

Alter Error messages for RBE

Added by Matt Gold about 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Reply By Email
Target version:
Start date:
2016-02-10
Due date:
% Done:

0%

Estimated time:

Description

Hi Ray,

It's good that the error message RBE throws says "Your message could not be posted" in the header of the message, but since it reproduces the failed message itself in the body of the email, people may mistakenly think the message posted if they don't catch the subject line.

Perhaps we should truncate the message when sending a failure notice and make it more obvious, generally, that the message didn't post. CC'ing Lisa Rhody, who experienced this today.

History

#1 Updated by Raymond Hoh about 3 years ago

I would gladly take suggestions for a better email message when a message fails to post.

For reference, this is the message that Lisa received when her topic failed to post:

Hi there,

Your new forum topic:

[body of message]

Could not be posted because it appears that you do not have access to that forum.

We apologize for any inconvenience this may have caused.

#2 Updated by Boone Gorges about 3 years ago

  • Target version set to 1.10

#3 Updated by Lisa Rhody about 3 years ago

The problem with the text for the message is that it quotes the entire body of the message, not just the subject of the message or "forum topic." If the message is a long one, as mine was, then the second half of the message that reads: "could not be posted..." doesn't appear until you scroll all the way down. Granted, the subject of the email should give it away, but for those people who use email clients where the subject heading is not always visible, this just looks like your seeing your post being distributed.

Probably not a big problem, but maybe simply quoting back the first 50 characters of the message or so would work just as well, as would front loading the error message. For example:
~~~~~
Hi there:

Unfortunately, your message could not be posted because you do not have access to the forum. We are sorry for the inconvenience, but you will need to repost the following message:

etc. etc.

~~~~~

I hope that's helpful!

Best,
Lisa

#4 Updated by Matt Gold about 3 years ago

Hi All --

Just wanted to give this a bump. Lisa says that the message saying that the message failed to post still appears at the bottom of the message; she suggests we move it to the top of the message so that the fact that the message failed is more obvious to users

#5 Updated by Samantha Raddatz almost 3 years ago

I like Lisa's suggested text. I think moving the error alert to the top will be a huge help here!
Let me know if any further UX input is needed for this.

#6 Updated by Raymond Hoh over 2 years ago

  • Status changed from Assigned to Resolved

Fixed in commit e92087c.

Also available in: Atom PDF