Project

General

Profile

Bug #5255

Social Paper Comment Icon Not Appearing

Added by Samantha Raddatz about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Social Paper
Target version:
Start date:
2016-02-23
Due date:
% Done:

0%

Estimated time:

Description

I started a social paper last night for the user testing draft. It's been shared privately with both the CAC Team and Subcommittee groups. The + icon for adding comments isn't appearing for Matt or me.

If it makes any difference -- I set it to private, added the CAC team as a group, published, and then came back about 20 minutes later to add the CAC subcommittee as a group and clicked 'Update'. I didn't check prior to that last step to see if the comments icon was appearing.

1.png (134 KB) 1.png Luke Waltzer, 2016-02-23 02:42 PM
2.png (134 KB) 2.png Luke Waltzer, 2016-02-23 02:42 PM
3.png (140 KB) 3.png Luke Waltzer, 2016-02-23 02:42 PM

History

#1 Updated by Luke Waltzer about 3 years ago

I'm seeing same thing, for both public and private papers, tested in Chrome and Safari.

#2 Updated by Boone Gorges about 3 years ago

Looking into it.

#3 Updated by Boone Gorges about 3 years ago

  • Status changed from New to Assigned
  • Target version set to 1.9.9

There are a couple of related bugs that must have been introduced in a recent version of Inline Comments. I've just put a hotfix in place that brings IC back to life, though note that the bubbles won't pop up until a few seconds after the page is loaded (this is part of the problem - IC is not waiting until the document is ready to do some stuff). I will do a deeper dive in the upcoming days to see if I can find a better fix and suggest it to the author of IC.

(cc Ray in case you have any bright ideas - see the dirty index on the production server)

#4 Updated by Matt Gold about 3 years ago

whoa - glad we caught this!

#5 Updated by Luke Waltzer about 3 years ago

Seeing issue where when I submit a comment it is successfully stored (screenshot 1), then when I click elsewhere on the page, the comment and comments indicator are not visible (screenshot 2) until I reload the page (screenshot 3).

Using Chrome.

#6 Updated by Luke Waltzer about 3 years ago

fwiw I have confirmed that multiple comments will be stored without a refresh.

#7 Updated by Boone Gorges about 3 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, can I ask you to have a look at this?

#8 Updated by Raymond Hoh about 3 years ago

Boone, your fixes look solid!

I've submitted a PR to the Inline Comments repo. If you have anything to add to the PR, let me know.

As for Luke's bug, it does not appear to be a regression; the bug existed before the latest changes. I've opened a new ticket for this as it is unrelated to this comment icon issue. See #5257.

#9 Updated by Boone Gorges about 3 years ago

  • Status changed from Assigned to Resolved

Cool, Ray! Thanks for verifying my fixes (and tracking down the cause). Thanks also for checking that Luke's report is independent.

I'm going to commit these changes and merge them into the 1.9 branch, with the caveat that the changes will need to be reapplied if the PR is not accepted before IC's next release.

https://github.com/cuny-academic-commons/cac/commit/c2f8d5dd5ee85688222396cc5f80f53b88d7c67a

Also available in: Atom PDF