Project

General

Profile

Bug #6980

Cannot post to forum

Added by Laura Kane about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
Group Forums
Target version:
Start date:
2016-12-07
Due date:
% Done:

0%

Estimated time:

Description

Hi Commons Team,

I've just tried 3 times to post to the JITP (Private) Group forum and the posts are not going through. I hit "submit" and the page refreshes to the main forum list, but my new post is not there. I've tried in Chrome and Firefox.


Related issues

Related to CUNY Academic Commons - Bug #3601: Forum replies do not show up on the group homepageResolved2014-10-26

History

#1 Updated by Boone Gorges about 5 years ago

I'm looking into it.

#2 Updated by Boone Gorges about 5 years ago

  • Status changed from New to Reporter Feedback

General posting seems to be working normally.

Laura, can you please share some additional information for debugging?

- Are you posting a new topic or a reply to an existing topic? If the latter, can you please share the URL?
- Please open a JavaScript console to see if any errors come up during the submission process http://webmasters.stackexchange.com/questions/8525/how-to-open-the-javascript-console-in-different-browsers
- Can you please share the exact text of what you're trying to post? It's possible that you're tripping a filter or something like that with a particular piece of content.

#3 Updated by Laura Kane about 5 years ago

Sure!

1) Replying to a topic: https://commons.gc.cuny.edu/groups/journal-of-interactive-technology-and-pedagogy/forum/topic/communications-outreach/

2) Screenshot attached

3)

Hello All,

A new Assignments piece was just published today – please publicize widely!

“Observations through Photovoice: Interactive Digital Assessment and Authentic Learning beyond the Lecture Hall” by Anne E. Pfister and David Wilson

<em>“Observations through Photovoice” is a participatory project that invites undergraduate students to demonstrate knowledge of basic anthropological themes by taking digital photographs of cultural phenomena in their own social worlds.</em>

https://jitp.commons.gc.cuny.edu/observations_through_photovoice/

Boone Gorges wrote:

General posting seems to be working normally.

Laura, can you please share some additional information for debugging?

- Are you posting a new topic or a reply to an existing topic? If the latter, can you please share the URL?
- Please open a JavaScript console to see if any errors come up during the submission process http://webmasters.stackexchange.com/questions/8525/how-to-open-the-javascript-console-in-different-browsers
- Can you please share the exact text of what you're trying to post? It's possible that you're tripping a filter or something like that with a particular piece of content.

#4 Updated by Boone Gorges about 5 years ago

Thanks, Laura.

I was able to reproduce. Something odd is happening with the bbPress forum plugin that is wreaking havoc when a group admin posts tries to reply to a topic of which they were not the original author. (I've described the technical details in a bbPress bug report. I don't recommend reading it too closely :-/ https://bbpress.trac.wordpress.org/ticket/3030#ticket)

I've put a hotfix in place on the Commons that appears to fix the problem for me. Laura, can you verify?

#5 Updated by Raymond Hoh about 5 years ago

Boone, your comment reminds me of this fix we put in place for CBOX:
https://github.com/cuny-academic-commons/commons-in-a-box/commit/1200ba686e810bedde3ad7b0e2137ebea4c7fc31

I believe we also added this fix on the Commons, but I cannot seem to find it anywhere.

Update: Found it. Fix is in our bp-nelo theme. See #3601. We might need to adjust that code to fix the problem being noted here.

#6 Updated by Raymond Hoh about 5 years ago

  • Related to Bug #3601: Forum replies do not show up on the group homepage added

#7 Updated by Laura Kane about 5 years ago

Hi Boone,

Apologies for the delayed response. I've just tested - I am able to post now.

Thank you!

Boone Gorges wrote:

Thanks, Laura.

I was able to reproduce. Something odd is happening with the bbPress forum plugin that is wreaking havoc when a group admin posts tries to reply to a topic of which they were not the original author. (I've described the technical details in a bbPress bug report. I don't recommend reading it too closely :-/ https://bbpress.trac.wordpress.org/ticket/3030#ticket)

I've put a hotfix in place on the Commons that appears to fix the problem for me. Laura, can you verify?

#8 Updated by Boone Gorges about 5 years ago

  • Category name set to Group Forums
  • Status changed from Reporter Feedback to Assigned
  • Target version set to 1.10.4

Thanks for circling back, Laura!

I've committed the change to the repository in https://github.com/cuny-academic-commons/cac/commit/91e8ed616aaa96a22859889d77b99959033f8a11

Ray - Thanks for the reminder about this. I knew I remembered working on something similar in the past. Do you have any idea why your previous fix (filtering with the group permalink) would suddenly have broken? I can't pinpoint a change in bbPress that would've caused it. I like the idea of a filter-based fix, so that we don't have to override the template, but `the_permalink` is a pretty generic filter - it would be much more palatable if bbPress had a specific `bbp_reply_form_action` filter or something like that.

#9 Updated by Boone Gorges about 5 years ago

  • Status changed from Assigned to Resolved

Also available in: Atom PDF