Project

General

Profile

Bug #3601

Forum replies do not show up on the group homepage

Added by Matt Gold almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2014-10-26
Due date:
% Done:

0%

Estimated time:

Description

I recently posted to a forum via the web - http://commons.gc.cuny.edu/groups/digital-praxis-seminar-2014-2015/forum/topic/updated-syllabus-final-assignment-resources-page/ - but I did not receive an email notification. Perhaps this is a problem with our email notification system, or perhaps there is a new setting on our upgraded form of BBPress that alters whether a user receives notification of his or her own posts?


Related issues

Related to CUNY Academic Commons - Bug #3598: RBE message not postedResolved2014-10-24

Related to CUNY Academic Commons - Bug #6980: Cannot post to forumResolved2016-12-07

History

#1 Updated by Matt Gold almost 5 years ago

FYI, the creation of this forum post does not appear n my My Commons > My Groups page, either

#2 Updated by Matt Gold almost 5 years ago

The post also does not appear in the group feed on the homepage of the group - http://commons.gc.cuny.edu/groups/digital-praxis-seminar-2014-2015/

#3 Updated by Raymond Hoh almost 5 years ago

If the post did not show up on the group homepage, that means the forum post was not recorded into the activity stream by BuddyPress.

I'm guessing the issue is related to Akismet.

I would check a few things:

1. In the WP admin dashboard, navigate to 'Topics' and click on the 'Spam' filter. If the post is shown there, unspam the post.

2. In the WP network admin dashboard, navigate to 'Activity' and click on the 'Spam' filter. If the post is shown there, unspam the post.

Let me know if either of the above points was the issue.

#4 Updated by Matt Gold almost 5 years ago

Thanks, Ray. I checked Topics > Spam and saw three legitimate posts there, though none were by me. I marked them as non-spam so that the user in question wouldn't be caught by the filter again.

I checked Network Admin > Activity > Spam but did not see the discussion board post there . . .

#5 Updated by Matt Gold almost 5 years ago

  • Status changed from Assigned to Resolved

Hi All,

Things appear to be working normally now. Not sure why; I'll mark as resolved and reopen if I notice anything amiss.

#6 Updated by Raymond Hoh almost 5 years ago

  • Subject changed from Email notification not received to Forum replies do not show up on the group homepage
  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.7.3

Matt Gold wrote:

The post also does not appear in the group feed on the homepage of the group - http://commons.gc.cuny.edu/groups/digital-praxis-seminar-2014-2015/

Finally back in the thick of things and have had a chance to duplicate this issue.

This is due to a bug with BuddyPress 2.1 affecting bbPress and bp-default themes (like bp-nelo).

When a bp-default theme is in use, the form action to reply to the forum topic changes to example.com/groups/ (usually this value is blank). Because the form action now resides at /groups/, this messes up how bbPress is able to determine that the forum post is a group forum reply and thus, the reply will not be recorded on the group homepage. This consequently means that an email notification for the forum reply will not be sent to group subscribers.

To remedy this in the meantime, I decided to override the bbPress form template in bp-nelo to force the form action to the group permalink when on a group forum topic page. See commit 7be1c5c.


Update: I've decided to fix this with filters instead of overriding the bbPress reply form template. See commit 2df6508. This also allows us to apply the same fix to the CBOX Theme, which suffers from a similar problem.

#7 Updated by Matt Gold almost 5 years ago

Thanks so much for your work on this, Ray.

#8 Updated by Raymond Hoh over 2 years ago

  • Related to Bug #6980: Cannot post to forum added

Also available in: Atom PDF