Project

General

Profile

Bug #7750

Media Gallery not loading

Added by Lisa Rhody over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2017-03-06
Due date:
% Done:

0%

Estimated time:

Description

HI all,

We are experiencing difficulty getting the Media Library to load for the cuny.is/gcdi site. I know that we have images in the Media Library, but the page looks like it's hug up and refuses to load any images. There is a

Here's what I get in the console when I open up the post page:

jquery-migrate.min.js:2 JQMIGRATE: Migrate is installed, version 1.4.1
plugin.min.js:1 Deprecated TinyMCE API call: <target>.onNodeChange.add(..)
widgets.wp.com/notifications/?jetpack=true&link_accounts_url=https%3A//gcdi…https://gcdi.commons.gc.cuny.edu/wp-admin/post.php?post=4848&action=edit:1 Uncaught SyntaxError: Unexpected end of JSON input
at JSON.parse (<anonymous>)
at XMLHttpRequest.r.onreadystatechange (build.min.js:2)

Then if you look at the network activity, there's an admin-ajax.php request that continues to loop and loop and loop with no response.

Thanks for looking into it!
Best,
Lisa

History

#1 Updated by Boone Gorges over 4 years ago

  • Status changed from New to Reporter Feedback

What do you mean by the "Media Gallery"/"Media Library"? Is that the slider at the top of the page?

When I first loaded the page, that content wasn't loading. But after a hard-refresh, it's now appearing. Perhaps Jetpack updated its JavaScript without forcing a cache flush?

Can you verify that I'm looking in the right place, and that a hard refresh fixes it for you? If so, I can look into whether there's something I can do to force Jetpack to increment its cache.

#2 Updated by Matt Gold over 4 years ago

FWIW, it is working for me as well -- see attached screenshot

#3 Updated by Lisa Rhody over 4 years ago

HI all,
By Media Library, I mean the area that you access when selecting ways to add media content to a post / page / or slide or a featured image.

For example, in this week's Digital GC post, we select a "featured image" to be included with the post. If you go into the Edit Post page, and select on the right hand column "Set Featured Image," this action calls up a "Featured Image" page. That page has two tabs: Upload Files and Media Library. I've attached a screen shot. That's where I've been looking at the panel. In reviewing earlier bugs, I noticed that there's an issue around Jetpack's Publicize. Coincidentally, we have just activated Jetpack's Publicize widget to improve social media integration. Perhaps this is the source of the trouble?

Best,
Lisa

#4 Updated by Lisa Rhody over 4 years ago

Could this be related to #6178?

#5 Updated by Lisa Rhody over 4 years ago

After disabling as much of Jetpack as I could, I'm still having trouble getting the Media Library to load. I know there are a ton of images there, and we depend on them for correctly formatting the post featured images... so I'm not sure what else to say. I've been preserving the console log, so I can send that along if desired.

#6 Updated by Boone Gorges over 4 years ago

  • Target version set to 1.10.13

I've tracked this down to a bug in PressForward. Details are here https://github.com/PressForward/pressforward/issues/903

For the time being, I've put a hotfix in place on the Commons that disables the problematic part of PressForward. Lisa, can you confirm that this fixes the problem for you? https://gcdi.commons.gc.cuny.edu/wp-admin/upload.php If so, I'll put a more permanent fix in place, and also investigate whether this problem is related to other tickets.

#7 Updated by Lisa Rhody over 4 years ago

Thanks, Boone. I can confirm that the fix worked. I'm going to try to re-enable Jetpack now. Thanks so much for chasing that down (both from a PF and a CAC perspective)!

#8 Updated by Boone Gorges over 4 years ago

  • Status changed from Reporter Feedback to Resolved

Fixed in a more permanent way in https://github.com/cuny-academic-commons/cac/commit/7e54394bf51039991c7027e1635a3289c47a482e (which was fixed in https://github.com/cuny-academic-commons/cac/commit/84963890292b03ad0cbf7ef4130b0d3e99b5f564)

It looks like this is a separate issue from #6178, which has to do with specific Publicize problems that are located on wordpress.com's servers.

Also available in: Atom PDF